problem with maven embebed in netbeans 5.5.1

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with maven embebed in netbeans 5.5.1

AlonsoIR
hi everybody, i`using netbeans 5.5.1 with jdk 1.6. App server is embebed tomcat 5.5.17 and i `m having some troubles when i build the war file. It seems that WEB-INF/classes dir is not updated!

i´ll try to explain better!

my workspace is C:\trabajo\ws\AFEL\sources, where i have pom.xml, profiles.xml, nbactions.xml and src  directory with my web project. If i run build goal on netbeans, it extracts to screen something like this:

[compiler:compile]
[INFO]Compiling 28 source files to C:\trabajo\ws\AFEL\sources\target\classes
[resources:testResources]
[INFO]Using default encoding to copy filtered resources.
[compiler:testCompile]
[INFO]No sources to compile
[surefire:test]
[INFO]No tests to run.
[war:war]
[INFO]Packaging webapp
[INFO]Assembling webapp[frontal] in [C:\trabajo\ws\AFEL\sources\target\frontal-1.0-SNAPSHOT]
[INFO]Processing war project
[INFO]Webapp assembled in[6484 msecs]
[INFO]Building war: C:\trabajo\ws\AFEL\sources\target\frontal-1.0-SNAPSHOT.war
[install:install]
[INFO]Installing C:\trabajo\ws\AFEL\sources\target\frontal-1.0-SNAPSHOT.war to C:\Documents and Settings\operador\.m2\repository\es\yell\frontlite\frontal\1.0-SNAPSHOT\frontal-1.0-SNAPSHOT.war
[INFO]------------------------------------------------------------------------
[INFO]BUILD SUCCESSFUL
[INFO]------------------------------------------------------------------------
[INFO]Total time: 14 seconds
[INFO]Finished at: Wed Nov 14 15:58:51 CET 2007
[INFO]Final Memory: 47M/87M
[INFO]------------------------------------------------------------------------

the content of C:\trabajo\ws\AFEL\sources\target\classes is diferent with regard to WEB-INF/classes contained in the generated war!

pls help, how can i fix this strange behavior?

PD

i already tried unistalling and purging netbeans files
Reply | Threaded
Open this post in threaded view
|

Re: problem with maven embebed in netbeans 5.5.1

Milos Kleint-2
does the same happen when invoking on the command line?
worth filing as issue at http://jira.codehaus.org/browse/MEVENIDE

Milos

On Nov 14, 2007 4:06 PM, logancillo <[hidden email]> wrote:

>
> hi everybody, i`using netbeans 5.5.1 with jdk 1.6. App server is embebed
> tomcat 5.5.17 and i `m having some troubles when i build the war file. It
> seems that WEB-INF/classes dir is not updated!
>
> i´ll try to explain better!
>
> my workspace is C:\trabajo\ws\AFEL\sources, where i have pom.xml,
> profiles.xml, nbactions.xml and src  directory with my web project. If i
> run
> build goal on netbeans, it extracts to screen something like this:
>
> [compiler:compile]
> [INFO]Compiling 28 source files to
> C:\trabajo\ws\AFEL\sources\target\classes
> [resources:testResources]
> [INFO]Using default encoding to copy filtered resources.
> [compiler:testCompile]
> [INFO]No sources to compile
> [surefire:test]
> [INFO]No tests to run.
> [war:war]
> [INFO]Packaging webapp
> [INFO]Assembling webapp[frontal] in
> [C:\trabajo\ws\AFEL\sources\target\frontal-1.0-SNAPSHOT]
> [INFO]Processing war project
> [INFO]Webapp assembled in[6484 msecs]
> [INFO]Building war:
> C:\trabajo\ws\AFEL\sources\target\frontal-1.0-SNAPSHOT.war
> [install:install]
> [INFO]Installing C:\trabajo\ws\AFEL\sources\target\frontal-
> 1.0-SNAPSHOT.war
> to C:\Documents and
>
> Settings\operador\.m2\repository\es\yell\frontlite\frontal\1.0-SNAPSHOT\frontal-
> 1.0-SNAPSHOT.war
>
> [INFO]------------------------------------------------------------------------
> [INFO]BUILD SUCCESSFUL
>
> [INFO]------------------------------------------------------------------------
> [INFO]Total time: 14 seconds
> [INFO]Finished at: Wed Nov 14 15:58:51 CET 2007
> [INFO]Final Memory: 47M/87M
>
> [INFO]------------------------------------------------------------------------
>
> the content of C:\trabajo\ws\AFEL\sources\target\classes is diferent with
> regard to WEB-INF/classes contained in the generated war!
>
> pls help, how can i fix this strange behavior?
>
> PD
>
> i already tried unistalling and purging netbeans files
> --
> View this message in context:
> http://www.nabble.com/problem-with-maven-embebed-in-netbeans-5.5.1-tf4805705s177.html#a13748536
> Sent from the Maven - Users mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: problem with maven embebed in netbeans 5.5.1

AlonsoIR
thx for your response!, yep! it happens too!

2007/11/18, Milos Kleint <[hidden email]>:

>
> does the same happen when invoking on the command line?
> worth filing as issue at http://jira.codehaus.org/browse/MEVENIDE
>
> Milos
>
> On Nov 14, 2007 4:06 PM, logancillo <[hidden email]> wrote:
>
> >
> > hi everybody, i`using netbeans 5.5.1 with jdk 1.6. App server is embebed
> > tomcat 5.5.17 and i `m having some troubles when i build the war file.
> It
> > seems that WEB-INF/classes dir is not updated!
> >
> > i´ll try to explain better!
> >
> > my workspace is C:\trabajo\ws\AFEL\sources, where i have pom.xml,
> > profiles.xml, nbactions.xml and src  directory with my web project. If i
> > run
> > build goal on netbeans, it extracts to screen something like this:
> >
> > [compiler:compile]
> > [INFO]Compiling 28 source files to
> > C:\trabajo\ws\AFEL\sources\target\classes
> > [resources:testResources]
> > [INFO]Using default encoding to copy filtered resources.
> > [compiler:testCompile]
> > [INFO]No sources to compile
> > [surefire:test]
> > [INFO]No tests to run.
> > [war:war]
> > [INFO]Packaging webapp
> > [INFO]Assembling webapp[frontal] in
> > [C:\trabajo\ws\AFEL\sources\target\frontal-1.0-SNAPSHOT]
> > [INFO]Processing war project
> > [INFO]Webapp assembled in[6484 msecs]
> > [INFO]Building war:
> > C:\trabajo\ws\AFEL\sources\target\frontal-1.0-SNAPSHOT.war
> > [install:install]
> > [INFO]Installing C:\trabajo\ws\AFEL\sources\target\frontal-
> > 1.0-SNAPSHOT.war
> > to C:\Documents and
> >
> >
> Settings\operador\.m2\repository\es\yell\frontlite\frontal\1.0-SNAPSHOT\frontal-
> > 1.0-SNAPSHOT.war
> >
> >
> [INFO]------------------------------------------------------------------------
> > [INFO]BUILD SUCCESSFUL
> >
> >
> [INFO]------------------------------------------------------------------------
> > [INFO]Total time: 14 seconds
> > [INFO]Finished at: Wed Nov 14 15:58:51 CET 2007
> > [INFO]Final Memory: 47M/87M
> >
> >
> [INFO]------------------------------------------------------------------------
> >
> > the content of C:\trabajo\ws\AFEL\sources\target\classes is diferent
> with
> > regard to WEB-INF/classes contained in the generated war!
> >
> > pls help, how can i fix this strange behavior?
> >
> > PD
> >
> > i already tried unistalling and purging netbeans files
> > --
> > View this message in context:
> >
> http://www.nabble.com/problem-with-maven-embebed-in-netbeans-5.5.1-tf4805705s177.html#a13748536
> > Sent from the Maven - Users mailing list archive at Nabble.com.
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>



--
Alonso Isidoro Roman.
Reply | Threaded
Open this post in threaded view
|

Re: problem with maven embebed in netbeans 5.5.1

AlonsoIR
In reply to this post by Milos Kleint-2
Milos, is this a resolved problem? i dont know if there is an open task on jira.codehauss...


Reply | Threaded
Open this post in threaded view
|

Re: problem with maven embebed in netbeans 5.5.1

Milos Kleint-2
I didn't hear a problem description similar to yours so far. So it's
probably a still-to-be-fixed issue.

Milos

On 11/19/07, logancillo <[hidden email]> wrote:

>
>
> Milos, is this a resolved problem? i dont know if there is an open task on
> jira.codehauss...
>
>
>
> --
> View this message in context:
> http://www.nabble.com/problem-with-maven-embebed-in-netbeans-5.5.1-tf4805705s177.html#a13830305
> Sent from the Maven - Users mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Maven1.x Integration with Eclipse

Smitha.Aldrin
 
Hi

Is there any pluggin available for integrating maven1.x with Eclipse


Thanks And Regards
Smitha ALdrin

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Maven1.x Integration with Eclipse

Tomasz Pik
On Nov 19, 2007 10:58 AM,  <[hidden email]> wrote:
>
> Hi
>
> Is there any pluggin available for integrating maven1.x with Eclipse

http://mevenide.codehaus.org/mevenide-ui-eclipse/features.html

Regards,
Tomek

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: problem with maven embebed in netbeans 5.5.1

AlonsoIR
In reply to this post by Milos Kleint-2
ok, thx, i´ll report this possible bug very soon!
Reply | Threaded
Open this post in threaded view
|

RE: Maven1.x Integration with Eclipse

Smitha.Aldrin
In reply to this post by Tomasz Pik
Hi Tomek

I found the site useful.Thank you so much.
I installed the pluggin.But from Eclipse how to I set the goals?
In the command promt we used to give like maven full-build; How can I
get this done from Eclipse.

Thanks And Regards
Smitha Aldrin

-----Original Message-----
From: Tomasz Pik [mailto:[hidden email]]
Sent: Monday, November 19, 2007 4:09 AM
To: Maven Users List
Subject: Re: Maven1.x Integration with Eclipse

On Nov 19, 2007 10:58 AM,  <[hidden email]> wrote:
>
> Hi
>
> Is there any pluggin available for integrating maven1.x with Eclipse

http://mevenide.codehaus.org/mevenide-ui-eclipse/features.html

Regards,
Tomek

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]