mvn versions:use-latest-version fails to pick up latest version

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

mvn versions:use-latest-version fails to pick up latest version

jedrzej.dudkiewicz
I use the following command:

 

mvn versions:use-latest-versions -DexcludeReactor=false
-DgenerateBackupPoms=false # command (1)

 

to update versions in my poms. I have the following setup:

pom.xml (main pom)

    /modules

        /module-a/pom.xml (pom a)

        /module-b/pom.xml (pom b)

 

"Main pom" has <modules> tag:

 

<modules>

    <module>module-a</module>

    <module>module-b</module>

</modules>

 

"Pom a" has version 1.0.4-SNAPSHOT. "Pom b" has "pom a" (its artifact) as
dependency, something along the line "group:module-a:1.0.3-SNAPSHOT". When I
run aforementioned command (1), "module-a" version in "pom b" is not updated
to "group:module-a:1.0.4-SNAPSHOT" even though "module-a" is deployed to
Artifactory. If change version manually everything builds fine, which means
that artifact is reachable and obtainable and works fine.

 

I tried to do:

mvn -U clean

 

before issuing command (1), but it changes nothing.

 

What should I do to have this dependency updated?

 

Thanks in advance,

 

JD