Quantcast

mvn sonar:sonar

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

mvn sonar:sonar

Peter Horlock
Hi,

I am using hte maven sonar plugin and recently updated to the 1.10.1
server version.
Since then I got:
  [exec] [INFO] Sonar plugin (1.7) and server (1.10.1) version do not
matchExclusionPattern.
     [exec] Either update your server to the 1.7 plugin version or launch
     [exec] the mvn org.codehaus.sonar:sonar-maven-plugin:1.10.1:sonar
plugin command.

As far as I know org.codehaus.sonar:sonar-maven-plugin:1.10.1 doesn't exist yet.
The newest version I found was 1.8.

Using version 1.8, I however get:

[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Can not execute Sonar

Embedded error: Unable to build project for plugin
'org.codehaus.sonar.runtime:sonar-core-maven-plugin': POM
'org.codehaus.sonar.runtime:sonar-core-maven-plugin' not found in
repository: Unable to download the artifact from any repository

  org.codehaus.sonar.runtime:sonar-core-maven-plugin:pom:20090826155317


How can I fix that?

Thanks in advance,


Peter
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: mvn sonar:sonar

Anders Hammar
I think the sonar mailing list is a better option than this generic maven
mailing list (for this type of sonar specific issue).

/Anders

On Wed, Sep 2, 2009 at 13:46, Peter Horlock <[hidden email]>wrote:

> Hi,
>
> I am using hte maven sonar plugin and recently updated to the 1.10.1
> server version.
> Since then I got:
>  [exec] [INFO] Sonar plugin (1.7) and server (1.10.1) version do not
> matchExclusionPattern.
>     [exec] Either update your server to the 1.7 plugin version or launch
>     [exec] the mvn org.codehaus.sonar:sonar-maven-plugin:1.10.1:sonar
> plugin command.
>
> As far as I know org.codehaus.sonar:sonar-maven-plugin:1.10.1 doesn't exist
> yet.
> The newest version I found was 1.8.
>
> Using version 1.8, I however get:
>
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Can not execute Sonar
>
> Embedded error: Unable to build project for plugin
> 'org.codehaus.sonar.runtime:sonar-core-maven-plugin': POM
> 'org.codehaus.sonar.runtime:sonar-core-maven-plugin' not found in
> repository: Unable to download the artifact from any repository
>
>  org.codehaus.sonar.runtime:sonar-core-maven-plugin:pom:20090826155317
>
>
> How can I fix that?
>
> Thanks in advance,
>
>
> Peter
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: mvn sonar:sonar

Arnaud X Dostes
This has been covered many times in the sonar user mailing list, check the archive, you'll find your answer : http://mojo.codehaus.org/sonar-maven-plugin/mail-lists.html

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Anders Hammar
Sent: Wednesday, September 02, 2009 2:02 PM
To: Maven Users List
Subject: Re: mvn sonar:sonar

I think the sonar mailing list is a better option than this generic maven
mailing list (for this type of sonar specific issue).

/Anders

On Wed, Sep 2, 2009 at 13:46, Peter Horlock <[hidden email]>wrote:

> Hi,
>
> I am using hte maven sonar plugin and recently updated to the 1.10.1
> server version.
> Since then I got:
>  [exec] [INFO] Sonar plugin (1.7) and server (1.10.1) version do not
> matchExclusionPattern.
>     [exec] Either update your server to the 1.7 plugin version or launch
>     [exec] the mvn org.codehaus.sonar:sonar-maven-plugin:1.10.1:sonar
> plugin command.
>
> As far as I know org.codehaus.sonar:sonar-maven-plugin:1.10.1 doesn't exist
> yet.
> The newest version I found was 1.8.
>
> Using version 1.8, I however get:
>
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Can not execute Sonar
>
> Embedded error: Unable to build project for plugin
> 'org.codehaus.sonar.runtime:sonar-core-maven-plugin': POM
> 'org.codehaus.sonar.runtime:sonar-core-maven-plugin' not found in
> repository: Unable to download the artifact from any repository
>
>  org.codehaus.sonar.runtime:sonar-core-maven-plugin:pom:20090826155317
>
>
> How can I fix that?
>
> Thanks in advance,
>
>
> Peter
>
This email is confidential and subject to important disclaimers and
conditions including on offers for the purchase or sale of
securities, accuracy and completeness of information, viruses,
confidentiality, legal privilege, and legal entity disclaimers,
available at http://www.jpmorgan.com/pages/disclosures/email.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...