missing dependency version

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

missing dependency version

Rune Gellein
Hi,
I was have just moved to using the maven resolver ant task and I am now
getting this error:
/org.apache.maven.model.building.ModelBuildingException: 4 problems were
encountered while building the effective model for com.sun.xml.ws:rt:2.3.1
[FATAL] Non-parseable POM
C:\Users\me\m\org\glassfish\jaxb\jaxb-bom\2.3.1\jaxb-bom-2.3.1.pom: end tag
name </body> must match start tag name <hr> from line 5 (position: TEXT seen
...</center>\r\n</body>... @6:8)  @
C:\Users\me\m\org\glassfish\jaxb\jaxb-bom\2.3.1\jaxb-bom-2.3.1.pom, line 6,
column 8
[ERROR] 'dependencies.dependency.version' for
org.glassfish.jaxb:jaxb-runtime:jar is missing. @
[ERROR] 'dependencies.dependency.version' for org.jvnet.staxex:stax-ex:jar
is missing. @
[ERROR] 'dependencies.dependency.version' for javax.xml.bind:jaxb-api:jar is
missing. @/

This worked when I used the old maven ant task.  I can also see this gets
resolved correctly when using maven directly in the Intellij IDE.  So have I
missed something when using the resolver ant task?



--
Sent from: http://maven.40175.n5.nabble.com/Maven-Users-f40176.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: missing dependency version

Mark Prins
looks like you got a html document instead of a pom file as a response

On 2020-03-12 20:00, Rune Gellein wrote:

> Hi,
> I was have just moved to using the maven resolver ant task and I am now
> getting this error:
> /org.apache.maven.model.building.ModelBuildingException: 4 problems were
> encountered while building the effective model for com.sun.xml.ws:rt:2.3.1
> [FATAL] Non-parseable POM
> C:\Users\me\m\org\glassfish\jaxb\jaxb-bom\2.3.1\jaxb-bom-2.3.1.pom: end tag
> name </body> must match start tag name <hr> from line 5 (position: TEXT seen
> ...</center>\r\n</body>... @6:8)  @
> C:\Users\me\m\org\glassfish\jaxb\jaxb-bom\2.3.1\jaxb-bom-2.3.1.pom, line 6,
> column 8
> [ERROR] 'dependencies.dependency.version' for
> org.glassfish.jaxb:jaxb-runtime:jar is missing. @
> [ERROR] 'dependencies.dependency.version' for org.jvnet.staxex:stax-ex:jar
> is missing. @
> [ERROR] 'dependencies.dependency.version' for javax.xml.bind:jaxb-api:jar is
> missing. @/
>
> This worked when I used the old maven ant task.  I can also see this gets
> resolved correctly when using maven directly in the Intellij IDE.  So have I
> missed something when using the resolver ant task?
>
>
>
> --
> Sent from: http://maven.40175.n5.nabble.com/Maven-Users-f40176.html
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: missing dependency version

Rune Gellein
This post was updated on .
Thanks for your reply, Mark.

Seeing that path to that jaxb jar made me check my maven config again.
Turns out I had the repository duplicated.  I thought I was using one in [my
user]/.m2, but as the path shows it is actually in [my user]/m

The pom file it was using in the 'm' repository had some HTML failure content
instead of the actual pom content for that jar.  Hence the error.  I had
checked the pom in the other repo many times and found it correct.
My build works now with correct settings.xml.


Rune



--
Sent from: http://maven.40175.n5.nabble.com/Maven-Users-f40176.html

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org