missing artifact com.oracle:ojdbc8:jar:12.2.0.1

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

missing artifact com.oracle:ojdbc8:jar:12.2.0.1

Eng. Bilal Ghayad
Hello;

 

I am facing the error: missing artifact com.oracle:ojdbc8:jar:12.2.0.1 when
I add the below oracle dependency in the pom, can someone advise the reason
for this?

My eclipse is running on Windows 10 and below is the related pom
configuration:

 

       <properties>

             <java-version>1.8</java-version>

 
<org.springframework-version>3.1.1.RELEASE</org.springframework-version>

             <org.aspectj-version>1.8.13</org.aspectj-version>

             <org.slf4j-version>1.7.30</org.slf4j-version>

             <hibernate.version>4.3.5.Final</hibernate.version>

       </properties>

       <dependencies>

 

       <dependency>

             <groupId>com.oracle</groupId>

             <artifactId>ojdbc8</artifactId>

             <version>12.2.0.1</version>

             </dependency>

 

             <!-- Hibernate -->

        <dependency>

            <groupId>org.hibernate</groupId>

            <artifactId>hibernate-core</artifactId>

            <version>${hibernate.version}</version>

        </dependency>

       

        <dependency>

                    <groupId>org.hibernate</groupId>

                    <artifactId>hibernate-entitymanager</artifactId>

                    <version>${hibernate.version}</version>

       </dependency>

 

Regards

Bilal

Reply | Threaded
Open this post in threaded view
|

Re: missing artifact com.oracle:ojdbc8:jar:12.2.0.1

Anders Hammar
The only version currently available in Central repository is 19.3.0.0.
It's in a different groupId though.
More info here:
https://medium.com/oracledevs/oracle-jdbc-drivers-on-maven-central-64fcf724d8b

/Anders (mobile)

Den mån 13 jan. 2020 22:02Eng. Bilal Ghayad <[hidden email]> skrev:

> Hello;
>
>
>
> I am facing the error: missing artifact com.oracle:ojdbc8:jar:12.2.0.1 when
> I add the below oracle dependency in the pom, can someone advise the reason
> for this?
>
> My eclipse is running on Windows 10 and below is the related pom
> configuration:
>
>
>
>        <properties>
>
>              <java-version>1.8</java-version>
>
>
> <org.springframework-version>3.1.1.RELEASE</org.springframework-version>
>
>              <org.aspectj-version>1.8.13</org.aspectj-version>
>
>              <org.slf4j-version>1.7.30</org.slf4j-version>
>
>              <hibernate.version>4.3.5.Final</hibernate.version>
>
>        </properties>
>
>        <dependencies>
>
>
>
>        <dependency>
>
>              <groupId>com.oracle</groupId>
>
>              <artifactId>ojdbc8</artifactId>
>
>              <version>12.2.0.1</version>
>
>              </dependency>
>
>
>
>              <!-- Hibernate -->
>
>         <dependency>
>
>             <groupId>org.hibernate</groupId>
>
>             <artifactId>hibernate-core</artifactId>
>
>             <version>${hibernate.version}</version>
>
>         </dependency>
>
>
>
>         <dependency>
>
>                     <groupId>org.hibernate</groupId>
>
>                     <artifactId>hibernate-entitymanager</artifactId>
>
>                     <version>${hibernate.version}</version>
>
>        </dependency>
>
>
>
> Regards
>
> Bilal
>
>
Reply | Threaded
Open this post in threaded view
|

Re: missing artifact com.oracle:ojdbc8:jar:12.2.0.1

Rogelio Vizcaino
You can use maven install plugin to install the jar into your local repository.

Check this guide https://maven.apache.org/guides/mini/guide-3rd-party-jars-local.html <https://maven.apache.org/guides/mini/guide-3rd-party-jars-local.html>


> On 13 Jan 2020, at 15:19, Anders Hammar <[hidden email]> wrote:
>
> The only version currently available in Central repository is 19.3.0.0.
> It's in a different groupId though.
> More info here:
> https://medium.com/oracledevs/oracle-jdbc-drivers-on-maven-central-64fcf724d8b
>
> /Anders (mobile)
>
> Den mån 13 jan. 2020 22:02Eng. Bilal Ghayad <[hidden email]> skrev:
>
>> Hello;
>>
>>
>>
>> I am facing the error: missing artifact com.oracle:ojdbc8:jar:12.2.0.1 when
>> I add the below oracle dependency in the pom, can someone advise the reason
>> for this?
>>
>> My eclipse is running on Windows 10 and below is the related pom
>> configuration:
>>
>>
>>
>>       <properties>
>>
>>             <java-version>1.8</java-version>
>>
>>
>> <org.springframework-version>3.1.1.RELEASE</org.springframework-version>
>>
>>             <org.aspectj-version>1.8.13</org.aspectj-version>
>>
>>             <org.slf4j-version>1.7.30</org.slf4j-version>
>>
>>             <hibernate.version>4.3.5.Final</hibernate.version>
>>
>>       </properties>
>>
>>       <dependencies>
>>
>>
>>
>>       <dependency>
>>
>>             <groupId>com.oracle</groupId>
>>
>>             <artifactId>ojdbc8</artifactId>
>>
>>             <version>12.2.0.1</version>
>>
>>             </dependency>
>>
>>
>>
>>             <!-- Hibernate -->
>>
>>        <dependency>
>>
>>            <groupId>org.hibernate</groupId>
>>
>>            <artifactId>hibernate-core</artifactId>
>>
>>            <version>${hibernate.version}</version>
>>
>>        </dependency>
>>
>>
>>
>>        <dependency>
>>
>>                    <groupId>org.hibernate</groupId>
>>
>>                    <artifactId>hibernate-entitymanager</artifactId>
>>
>>                    <version>${hibernate.version}</version>
>>
>>       </dependency>
>>
>>
>>
>> Regards
>>
>> Bilal
>>
>>

Reply | Threaded
Open this post in threaded view
|

Re: missing artifact com.oracle:ojdbc8:jar:12.2.0.1

Anthony Whitford
In reply to this post by Anders Hammar
I’m pretty sure that the groupId should be com.oracle.jdbc, so that is step 1.

I would recommend going with version 19.3.0.0 that is available on Central since these drivers are often highly backwards compatible.  However, if you need an older version, a good strategy is to download it from Oracle’s Maven Repository:  https://maven.oracle.com/

If you have an Artifact Repository (like Artifactory) in your ecosystem that can proxy artifact repositories, then you simply need to add Oracle’s Maven Repository to its list of repositories to proxy.

You may find this interesting:  https://blogs.oracle.com/dev2dev/get-oracle-jdbc-drivers-from-the-oracle-maven-repo-netbeans-eclipse-intellij <https://blogs.oracle.com/dev2dev/get-oracle-jdbc-drivers-from-the-oracle-maven-repo-netbeans-eclipse-intellij>

Hope this helps,

Anthony



> On Jan 13, 2020, at 1:19 PM, Anders Hammar <[hidden email]> wrote:
>
> The only version currently available in Central repository is 19.3.0.0.
> It's in a different groupId though.
> More info here:
> https://medium.com/oracledevs/oracle-jdbc-drivers-on-maven-central-64fcf724d8b
>
> /Anders (mobile)
>
> Den mån 13 jan. 2020 22:02Eng. Bilal Ghayad <[hidden email]> skrev:
>
>> Hello;
>>
>>
>>
>> I am facing the error: missing artifact com.oracle:ojdbc8:jar:12.2.0.1 when
>> I add the below oracle dependency in the pom, can someone advise the reason
>> for this?
>>
>> My eclipse is running on Windows 10 and below is the related pom
>> configuration:
>>
>>
>>
>>       <properties>
>>
>>             <java-version>1.8</java-version>
>>
>>
>> <org.springframework-version>3.1.1.RELEASE</org.springframework-version>
>>
>>             <org.aspectj-version>1.8.13</org.aspectj-version>
>>
>>             <org.slf4j-version>1.7.30</org.slf4j-version>
>>
>>             <hibernate.version>4.3.5.Final</hibernate.version>
>>
>>       </properties>
>>
>>       <dependencies>
>>
>>
>>
>>       <dependency>
>>
>>             <groupId>com.oracle</groupId>
>>
>>             <artifactId>ojdbc8</artifactId>
>>
>>             <version>12.2.0.1</version>
>>
>>             </dependency>
>>
>>
>>
>>             <!-- Hibernate -->
>>
>>        <dependency>
>>
>>            <groupId>org.hibernate</groupId>
>>
>>            <artifactId>hibernate-core</artifactId>
>>
>>            <version>${hibernate.version}</version>
>>
>>        </dependency>
>>
>>
>>
>>        <dependency>
>>
>>                    <groupId>org.hibernate</groupId>
>>
>>                    <artifactId>hibernate-entitymanager</artifactId>
>>
>>                    <version>${hibernate.version}</version>
>>
>>       </dependency>
>>
>>
>>
>> Regards
>>
>> Bilal
>>
>>