maven.java.net - Certificate expired

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

maven.java.net - Certificate expired

lucas bakalian
Hi,

When trying to build Apache Phoenix 5.1

I encountered the following problem

[ERROR] Failed to execute goal on project phoenix-hbase-compat-2.3.0: Could not resolve dependencies for project org.apache.phoenix:phoenix-hbase-compat-2.3.0:jar:5.1.0.1.0.0.0-140: Failed to collect dependencies at org.apache.hbase:hbase-server:jar:2.3.0 -> org.glassfish.web:javax.servlet.jsp:jar:2.3.2 -> org.glassfish:javax.el:jar:3.0.1-b06-SNAPSHOT: Failed to read artifact descriptor for org.glassfish:javax.el:jar:3.0.1-b06-SNAPSHOT: Could not transfer artifact org.glassfish:javax.el:pom:3.0.1-b06-SNAPSHOT from/to jvnet-nexus-snapshots (https://maven.java.net/content/repositories/snapshots): Transfer failed for https://maven.java.net/content/repositories/snapshots/org/glassfish/javax.el/3.0.1-b06-SNAPSHOT/javax.el-3.0.1-b06-SNAPSHOT.pom: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: validity check failed: NotAfter: Fri Feb 19 13:00:00 CET 2021 -> [Help 1]

Which means that the nexus server’s certificate expired

Could you renew it ? Or do you need some help we need it for build our release.

Best regards,

Lucas BAKALIAN
Big Data System Architect
Professional Services
CEO - LUC DATA - PARIS
+336 15.88.1555

Reply | Threaded
Open this post in threaded view
|

Re: maven.java.net - Certificate expired

Anders Hammar
This issue was raised yesterday and Sonatype renewed it then. I just
verified and the cert looks good from where I connect (Europe) to
maven.java.net.

/Anders

On Tue, Feb 23, 2021 at 8:10 AM lucas bakalian <[hidden email]> wrote:

> Hi,
>
> When trying to build Apache Phoenix 5.1
>
> I encountered the following problem
>
> [ERROR] Failed to execute goal on project phoenix-hbase-compat-2.3.0:
> Could not resolve dependencies for project
> org.apache.phoenix:phoenix-hbase-compat-2.3.0:jar:5.1.0.1.0.0.0-140: Failed
> to collect dependencies at org.apache.hbase:hbase-server:jar:2.3.0 ->
> org.glassfish.web:javax.servlet.jsp:jar:2.3.2 ->
> org.glassfish:javax.el:jar:3.0.1-b06-SNAPSHOT: Failed to read artifact
> descriptor for org.glassfish:javax.el:jar:3.0.1-b06-SNAPSHOT: Could not
> transfer artifact org.glassfish:javax.el:pom:3.0.1-b06-SNAPSHOT from/to
> jvnet-nexus-snapshots (
> https://maven.java.net/content/repositories/snapshots): Transfer failed
> for
> https://maven.java.net/content/repositories/snapshots/org/glassfish/javax.el/3.0.1-b06-SNAPSHOT/javax.el-3.0.1-b06-SNAPSHOT.pom:
> sun.security.validator.ValidatorException: PKIX path validation failed:
> java.security.cert.CertPathValidatorException: validity check failed:
> NotAfter: Fri Feb 19 13:00:00 CET 2021 -> [Help 1]
>
> Which means that the nexus server’s certificate expired
>
> Could you renew it ? Or do you need some help we need it for build our
> release.
>
> Best regards,
>
> Lucas BAKALIAN
> Big Data System Architect
> Professional Services
> CEO - LUC DATA - PARIS
> +336 15.88.1555
>
>