[maven-integration-testing] branch MNG-6522 updated: [MNG-6522] Fix typos

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[maven-integration-testing] branch MNG-6522 updated: [MNG-6522] Fix typos

slachiewicz
This is an automated email from the ASF dual-hosted git repository.

slachiewicz pushed a commit to branch MNG-6522
in repository https://gitbox.apache.org/repos/asf/maven-integration-testing.git


The following commit(s) were added to refs/heads/MNG-6522 by this push:
     new 0d40077  [MNG-6522] Fix typos
0d40077 is described below

commit 0d400778fcee230de8e75d6916b1422a3bde8022
Author: Sylwester Lachiewicz <[hidden email]>
AuthorDate: Fri Jan 11 22:49:42 2019 +0100

    [MNG-6522] Fix typos
---
 .../java/org/apache/maven/it/AbstractMavenIntegrationTestCase.java  | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/core-it-support/maven-it-helper/src/main/java/org/apache/maven/it/AbstractMavenIntegrationTestCase.java b/core-it-support/maven-it-helper/src/main/java/org/apache/maven/it/AbstractMavenIntegrationTestCase.java
index 203d3b7..7e3c42a 100644
--- a/core-it-support/maven-it-helper/src/main/java/org/apache/maven/it/AbstractMavenIntegrationTestCase.java
+++ b/core-it-support/maven-it-helper/src/main/java/org/apache/maven/it/AbstractMavenIntegrationTestCase.java
@@ -556,18 +556,18 @@ public abstract class AbstractMavenIntegrationTestCase
         {
             // auto set source+target to lowest accepted value based on java version
             // Java9 requires at least 1.6
-            if ( VersionRange.createFromVersionSpec( "[1.9,12)" ).containsVersion( getJavaVersion() ) )
+            if ( VersionRange.createFromVersionSpec( "[9,12)" ).containsVersion( getJavaVersion() ) )
             {
                 verifier.getSystemProperties().put( "maven.compiler.source", "1.6" );
                 verifier.getSystemProperties().put( "maven.compiler.target", "1.6" );
-                verifier.getSystemProperties().put( "maven.compiler.release.", "6" );
+                verifier.getSystemProperties().put( "maven.compiler.release", "6" );
             }
             // Java12 requires at least 7
             if ( VersionRange.createFromVersionSpec( "[12,)" ).containsVersion( getJavaVersion() ) )
             {
                 verifier.getSystemProperties().put( "maven.compiler.source", "7" );
                 verifier.getSystemProperties().put( "maven.compiler.target", "7" );
-                verifier.getSystemProperties().put( "maven.compiler.release.", "7" );
+                verifier.getSystemProperties().put( "maven.compiler.release", "7" );
             }
         }
         catch ( InvalidVersionSpecificationException e )