maven-dependency-plugin

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

maven-dependency-plugin

Lulseged Zerfu
Hi

I have upgraded maven-dependency-plugin from 3.1.1 to 3.1.2 and see that my pluigins are executed in another order which makes my build  to fail.

In one of my modules I have the following order for these 3 plugins:

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-ear-plugin</artifactId>
        </plugin>

        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-dependency-plugin</artifactId>
        </pluign>

        <plugin>
            <groupId>io.openliberty.tools</groupId>
            <artifactId>liberty-maven-plugin</artifactId>
        </plugin>
    </plugins>
</build>

After updating to 3.1.2 the order is not preserved.

How can I execute package phase and the order it executed shall be in the order these plugins are defined?


1.     maven-ear-plugin

2.     maven-dependency-plugin

3.     liberty-maven-plugin

BR
Lulseged Zerfu