[maven-dependency-plugin] branch master updated: Upgrade ASM to 9.0 (Java 16 compatible)

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[maven-dependency-plugin] branch master updated: Upgrade ASM to 9.0 (Java 16 compatible)

rfscholte
This is an automated email from the ASF dual-hosted git repository.

rfscholte pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/maven-dependency-plugin.git


The following commit(s) were added to refs/heads/master by this push:
     new f23ac37  Upgrade ASM to 9.0 (Java 16 compatible)
f23ac37 is described below

commit f23ac37bcbee4a6162ff3ce2ff1b5fd1a30bcbe0
Author: rfscholte <[hidden email]>
AuthorDate: Fri Oct 16 11:21:14 2020 +0200

    Upgrade ASM to 9.0 (Java 16 compatible)
---
 pom.xml | 9 +++++++++
 1 file changed, 9 insertions(+)

diff --git a/pom.xml b/pom.xml
index 4da55ce..622b877 100644
--- a/pom.xml
+++ b/pom.xml
@@ -98,6 +98,15 @@ under the License.
     <project.build.outputTimestamp>2020-10-07T14:48:53Z</project.build.outputTimestamp>
   </properties>
 
+  <dependencyManagement>
+    <dependencies>
+      <dependency> <!-- override older version in maven-dependency-analyzer:1.11.3 -->
+        <groupId>org.ow2.asm</groupId>
+        <artifactId>asm</artifactId>
+        <version>9.0</version>
+      </dependency>
+    </dependencies>
+  </dependencyManagement>
   <dependencies>
     <!-- maven -->
     <!-- Remove once deprecated code has been replaced/removed  -->