m2eclipse on maven-3.0-beta-1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

m2eclipse on maven-3.0-beta-1

erik-6
Hello,

Can we expect a release of m2eclipse on maven 3.0-beta-1?

It seems that 0.10.0 is based on an alpha-release, which has a bug that
heavily affects our builds ([MNG-3092] - Version ranges with
non-snapshot bounds can contain snapshot versions).
This bug has been solved in 3.0-beta-1.

regards,
Erik


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

Re: m2eclipse on maven-3.0-beta-1

jochen-2
On Tue, Jun 8, 2010 at 8:27 PM, Erik Schepers <[hidden email]> wrote:

> Can we expect a release of m2eclipse on maven 3.0-beta-1?
>
> It seems that 0.10.0 is based on an alpha-release, which has a bug that
> heavily affects our builds ([MNG-3092] - Version ranges with
> non-snapshot bounds can contain snapshot versions).
> This bug has been solved in 3.0-beta-1.

Did you try to configure m2eclipse to use an external build?

Jochen


--
Germanys national anthem is the most boring in the world - how telling!

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email


Reply | Threaded
Open this post in threaded view
|

RE: m2eclipse on maven-3.0-beta-1

erikschepers
Yes, but m2eclipse uses an internal maven-embedder (that comes with the m2eclipse plugin), which is based on maven-alpha-4.
By configuring an external maven (3.0-beta-1), everything in the run-as-maven-menu executes on maven 3.0-beta-1, but m2eclipse still uses the alpha-4, so update-dependencies, update-project-configuration, the dependency-hierarchy tab in the pom-editor, and-so-on all, all run on the embedded 3.0-alpha-4...
And we need those things to be on beta-1 as well.

regards,
Erik

-----Original Message-----
From: Jochen Wiedmann [mailto:[hidden email]]
Sent: Wednesday, 09 June, 2010 08:05
To: [hidden email]
Subject: Re: [m2eclipse-user] m2eclipse on maven-3.0-beta-1

On Tue, Jun 8, 2010 at 8:27 PM, Erik Schepers <[hidden email]> wrote:

> Can we expect a release of m2eclipse on maven 3.0-beta-1?
>
> It seems that 0.10.0 is based on an alpha-release, which has a bug that
> heavily affects our builds ([MNG-3092] - Version ranges with
> non-snapshot bounds can contain snapshot versions).
> This bug has been solved in 3.0-beta-1.

Did you try to configure m2eclipse to use an external build?

Jochen


--
Germanys national anthem is the most boring in the world - how telling!

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email