liferay plugin version

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

liferay plugin version

Francesco Viscomi
Hi all,
When i compile a project with embedded maven  in eclipse (the version is:
3.1.1/1.5.0.20131218-0705)  it compiles right;

when I try to compile the same project from command line
mvn -version

Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
2017-10-18T09:58:13+02:00)
Maven home: /home/fra/maven/apache-maven-3.5.2
Java version: 1.7.0_80, vendor: Oracle Corporation
Java home: /home/fra/jdk1.7.0_80/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "4.13.0-38-generic", arch: "amd64", family:
"unix"

it dosn't compile and the error is:

[ERROR] Failed to execute goal
com.liferay.maven.plugins:liferay-maven-plugin:6.2.10.5:build-css (default)
on project sample-spring-mvc-portlet: Execution default of goal
com.liferay.maven.plugins:liferay-maven-plugin:6.2.10.5:build-css failed:
Plugin com.liferay.maven.plugins:liferay-maven-plugin:6.2.10.5 or one of
its dependencies could not be resolved: The following artifacts could not
be resolved: org.apache.maven:maven-artifact:jar:2.0.10,
org.apache.maven:maven-model:jar:2.0.10,
org.apache.maven:maven-plugin-api:jar:2.0.10,
org.apache.maven:maven-project:jar:2.0.10,
org.apache.maven:maven-settings:jar:2.0.10,
org.apache.maven:maven-profile:jar:2.0.10,
org.apache.maven:maven-artifact-manager:jar:2.0.10,
org.apache.maven:maven-repository-metadata:jar:2.0.10,
org.apache.maven:maven-plugin-registry:jar:2.0.10,
org.codehaus.plexus:plexus-component-api:jar:1.0-alpha-15,
org.codehaus.plexus:plexus-classworlds:jar:1.2-alpha-6: Could not transfer
artifact org.apache.maven:maven-artifact:jar:2.0.10 from/to central (
https://repo.maven.apache.org/maven2): Received fatal alert:
protocol_version

How I can solve the issue??

the pom is:

<build>
        <plugins>
            <plugin>
                <groupId>com.liferay.maven.plugins</groupId>
                <artifactId>liferay-maven-plugin</artifactId>
                <version>${liferay.maven.plugin.version}</version>
                <executions>
                    <execution>
                        <phase>generate-sources</phase>
                        <goals>
                            <goal>build-css</goal>
                        </goals>
                    </execution>
                </executions>
                <configuration>

<autoDeployDir>${liferay.auto.deploy.dir}</autoDeployDir>

<appServerDeployDir>${liferay.app.server.deploy.dir}</appServerDeployDir>

<appServerLibGlobalDir>${liferay.app.server.lib.global.dir}</appServerLibGlobalDir>

<appServerPortalDir>${liferay.app.server.portal.dir}</appServerPortalDir>
                    <liferayVersion>${liferay.version}</liferayVersion>
                    <pluginType>portlet</pluginType>
                </configuration>
            </plugin>
            <plugin>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>2.5</version>
                <configuration>
                    <encoding>UTF-8</encoding>
                    <source>1.6</source>
                    <target>1.6</target>
                </configuration>
            </plugin>
            <plugin>
                <artifactId>maven-resources-plugin</artifactId>
                <version>2.5</version>
                <configuration>
                    <encoding>UTF-8</encoding>
                </configuration>
            </plugin>
        </plugins>
    </build>



thanks

--
Ing. Viscomi Francesco
Reply | Threaded
Open this post in threaded view
|

Re: liferay plugin version

rfscholte
It seems like you've missed an important message: Maven Central  
discontinued support for TLSv1.1 and below.

Read  
https://central.sonatype.org/articles/2018/May/04/discontinued-support-for-tlsv11-and-below/ 
for all the details and how to solve this.

thanks,
Robert

ps. Stack Overflow has several questions and answers about this too, like  
https://stackoverflow.com/questions/50824789/why-am-i-getting-received-fatal-alert-protocol-version-or-peer-not-authentic

On Sat, 01 Sep 2018 17:12:57 +0200, Francesco Viscomi <[hidden email]>  
wrote:

> Hi all,
> When i compile a project with embedded maven  in eclipse (the version is:
> 3.1.1/1.5.0.20131218-0705)  it compiles right;
>
> when I try to compile the same project from command line
> mvn -version
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T09:58:13+02:00)
> Maven home: /home/fra/maven/apache-maven-3.5.2
> Java version: 1.7.0_80, vendor: Oracle Corporation
> Java home: /home/fra/jdk1.7.0_80/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "4.13.0-38-generic", arch: "amd64", family:
> "unix"
>
> it dosn't compile and the error is:
>
> [ERROR] Failed to execute goal
> com.liferay.maven.plugins:liferay-maven-plugin:6.2.10.5:build-css  
> (default)
> on project sample-spring-mvc-portlet: Execution default of goal
> com.liferay.maven.plugins:liferay-maven-plugin:6.2.10.5:build-css failed:
> Plugin com.liferay.maven.plugins:liferay-maven-plugin:6.2.10.5 or one of
> its dependencies could not be resolved: The following artifacts could not
> be resolved: org.apache.maven:maven-artifact:jar:2.0.10,
> org.apache.maven:maven-model:jar:2.0.10,
> org.apache.maven:maven-plugin-api:jar:2.0.10,
> org.apache.maven:maven-project:jar:2.0.10,
> org.apache.maven:maven-settings:jar:2.0.10,
> org.apache.maven:maven-profile:jar:2.0.10,
> org.apache.maven:maven-artifact-manager:jar:2.0.10,
> org.apache.maven:maven-repository-metadata:jar:2.0.10,
> org.apache.maven:maven-plugin-registry:jar:2.0.10,
> org.codehaus.plexus:plexus-component-api:jar:1.0-alpha-15,
> org.codehaus.plexus:plexus-classworlds:jar:1.2-alpha-6: Could not  
> transfer
> artifact org.apache.maven:maven-artifact:jar:2.0.10 from/to central (
> https://repo.maven.apache.org/maven2): Received fatal alert:
> protocol_version
>
> How I can solve the issue??
>
> the pom is:
>
> <build>
>         <plugins>
>             <plugin>
>                 <groupId>com.liferay.maven.plugins</groupId>
>                 <artifactId>liferay-maven-plugin</artifactId>
>                 <version>${liferay.maven.plugin.version}</version>
>                 <executions>
>                     <execution>
>                         <phase>generate-sources</phase>
>                         <goals>
>                             <goal>build-css</goal>
>                         </goals>
>                     </execution>
>                 </executions>
>                 <configuration>
>
> <autoDeployDir>${liferay.auto.deploy.dir}</autoDeployDir>
>
> <appServerDeployDir>${liferay.app.server.deploy.dir}</appServerDeployDir>
>
> <appServerLibGlobalDir>${liferay.app.server.lib.global.dir}</appServerLibGlobalDir>
>
> <appServerPortalDir>${liferay.app.server.portal.dir}</appServerPortalDir>
>                     <liferayVersion>${liferay.version}</liferayVersion>
>                     <pluginType>portlet</pluginType>
>                 </configuration>
>             </plugin>
>             <plugin>
>                 <artifactId>maven-compiler-plugin</artifactId>
>                 <version>2.5</version>
>                 <configuration>
>                     <encoding>UTF-8</encoding>
>                     <source>1.6</source>
>                     <target>1.6</target>
>                 </configuration>
>             </plugin>
>             <plugin>
>                 <artifactId>maven-resources-plugin</artifactId>
>                 <version>2.5</version>
>                 <configuration>
>                     <encoding>UTF-8</encoding>
>                 </configuration>
>             </plugin>
>         </plugins>
>     </build>
>
>
>
> thanks

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]