[jira] Reopened: (WAGONFTP-9) Wagon FTP hangs attempting to deploy artifact

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] Reopened: (WAGONFTP-9) Wagon FTP hangs attempting to deploy artifact

JIRA jira@codehaus.org
     [ http://jira.codehaus.org/browse/WAGONFTP-9?page=all ]
     
K.C. Baltz reopened WAGONFTP-9:
-------------------------------


It's probably something I'm doing wrong, but I'm having trouble testing this fix.  I have the following in my pom.xml:

        <extensions>
            <extension>
                <groupId>org.apache.maven.wagon</groupId>
                <artifactId>wagon-ftp</artifactId>
                <version>1.0-alpha-6</version>
            </extension>
            <extension>
                <groupId>org.apache.maven.wagon</groupId>
                <artifactId>wagon-ssh</artifactId>
                <version>1.0-alpha-6</version>
            </extension>

However when I try to deploy via FTP, I get the following:

[INFO] Error deploying artifact: Unsupported Protocol: 'ftp': Cannot find wagon
which supports the requested protocol: ftp

Component descriptor cannot be found in the component repository: org.apache.mav
en.wagon.Wagonftp.

I'm testing with Maven 2.0.1.  

It appears I have been downloading 1.0-alpha-6 from http://public.planetmirror.com/pub/maven2/, not Ibiblio.  Is that a good place to get it?

> Wagon FTP hangs attempting to deploy artifact
> ---------------------------------------------
>
>          Key: WAGONFTP-9
>          URL: http://jira.codehaus.org/browse/WAGONFTP-9
>      Project: wagon-ftp
>         Type: Bug

>  Environment: Running Maven 2 on Windows XP, repository on Sun Solaris 10
>     Reporter: K.C. Baltz
>     Assignee: Brett Porter
>      Fix For: 1.0-alpha-6

>
>
> When deploying my artifact to my repository via FTP, the process hangs (it eventually fails after many minutes).  I've noticed that it only fails the second time the artifact is deployed, so it seems to be related to retrieving the previous build number/metadata.
>         <snapshotRepository>
>             <id>CopartSnapshotDeploy</id>
>             <name>Repository Name</name>
>             <url>ftp://cvs.copart.com/repository</url>
>         </snapshotRepository>

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]