[jira] Created: (WAGON-34) CLONE -wagon-file failed when used by maven-site-plugin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (WAGON-34) CLONE -wagon-file failed when used by maven-site-plugin

JIRA jira@codehaus.org
CLONE -wagon-file failed when used by maven-site-plugin
-------------------------------------------------------

         Key: WAGON-34
         URL: http://jira.codehaus.org/browse/WAGON-34
     Project: wagon
        Type: Bug

    Versions: 1.0-alpha-6    
    Reporter: Matt Hicks
 Assigned to: Brett Porter
     Fix For: 1.0-alpha-7
 Attachments: wagon-file.patch

When maven-site-plugin try a deploy on a file URL, an error is triggered.  This is because maven-site-plugin call "wagon.putDirectory( inputDirectory, "." );" which fails.

See http://www.nabble.com/With-maven-2.0.2-site%3Adeploy-doesn%27t-work-t934716.html


In attachment, you can find a patch adding a test case, and the patch fixing the bug.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (WAGON-34) CLONE -wagon-file failed when used by maven-site-plugin

JIRA jira@codehaus.org
     [ http://jira.codehaus.org/browse/WAGON-34?page=all ]

Matt Hicks updated WAGON-34:
----------------------------

    Attachment: wagon-file.patch

> CLONE -wagon-file failed when used by maven-site-plugin
> -------------------------------------------------------
>
>          Key: WAGON-34
>          URL: http://jira.codehaus.org/browse/WAGON-34
>      Project: wagon
>         Type: Bug

>     Versions: 1.0-alpha-6
>     Reporter: Matt Hicks
>     Assignee: Brett Porter
>      Fix For: 1.0-alpha-7
>  Attachments: wagon-file.patch
>
>
> When maven-site-plugin try a deploy on a file URL, an error is triggered.  This is because maven-site-plugin call "wagon.putDirectory( inputDirectory, "." );" which fails.
> See http://www.nabble.com/With-maven-2.0.2-site%3Adeploy-doesn%27t-work-t934716.html
> In attachment, you can find a patch adding a test case, and the patch fixing the bug.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (WAGON-34) CLONE -wagon-file failed when used by maven-site-plugin

JIRA jira@codehaus.org
In reply to this post by JIRA jira@codehaus.org
    [ http://jira.codehaus.org/browse/WAGON-34?page=comments#action_56935 ]

Matt Hicks commented on WAGON-34:
---------------------------------

Even with the latest version of WagonFile, we still saw the issue of the path.exists() returning false.  Removing the '.' from the path when it wasn't required corrected the problem.  The patch is attached above.

> CLONE -wagon-file failed when used by maven-site-plugin
> -------------------------------------------------------
>
>          Key: WAGON-34
>          URL: http://jira.codehaus.org/browse/WAGON-34
>      Project: wagon
>         Type: Bug

>     Versions: 1.0-alpha-6
>     Reporter: Matt Hicks
>     Assignee: Brett Porter
>      Fix For: 1.0-alpha-7
>  Attachments: wagon-file.patch
>
>
> When maven-site-plugin try a deploy on a file URL, an error is triggered.  This is because maven-site-plugin call "wagon.putDirectory( inputDirectory, "." );" which fails.
> See http://www.nabble.com/With-maven-2.0.2-site%3Adeploy-doesn%27t-work-t934716.html
> In attachment, you can find a patch adding a test case, and the patch fixing the bug.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[jira] Closed: (WAGON-34) CLONE -wagon-file failed when used by maven-site-plugin

JIRA jira@codehaus.org
In reply to this post by JIRA jira@codehaus.org
     [ http://jira.codehaus.org/browse/WAGON-34?page=all ]
     
Brett Porter closed WAGON-34:
-----------------------------

    Resolution: Fixed

> CLONE -wagon-file failed when used by maven-site-plugin
> -------------------------------------------------------
>
>          Key: WAGON-34
>          URL: http://jira.codehaus.org/browse/WAGON-34
>      Project: wagon
>         Type: Bug

>     Versions: 1.0-alpha-6
>     Reporter: Matt Hicks
>     Assignee: Brett Porter
>      Fix For: 1.0-alpha-7
>  Attachments: wagon-file.patch
>
>
> When maven-site-plugin try a deploy on a file URL, an error is triggered.  This is because maven-site-plugin call "wagon.putDirectory( inputDirectory, "." );" which fails.
> See http://www.nabble.com/With-maven-2.0.2-site%3Adeploy-doesn%27t-work-t934716.html
> In attachment, you can find a patch adding a test case, and the patch fixing the bug.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]