[jira] Created: (MPTEST-65) Upgrade to Junit 4.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (MPTEST-65) Upgrade to Junit 4.0

JIRA jira@codehaus.org
Upgrade to Junit 4.0
--------------------

                 Key: MPTEST-65
                 URL: http://jira.codehaus.org/browse/MPTEST-65
             Project: maven-test-plugin
          Issue Type: Task
            Reporter: Arnaud Heritier
            Priority: Minor


Upgrade to Junit 4.0
JUnit 4.1 isn't (yet) available on ibiblio.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (MPTEST-65) Upgrade to Junit 4.0

JIRA jira@codehaus.org
     [ http://jira.codehaus.org/browse/MPTEST-65?page=all ]

Arnaud Heritier updated MPTEST-65:
----------------------------------

    Affects Version/s: 1.6.2
                       1.7
                       1.8
        Fix Version/s: 1.9

> Upgrade to Junit 4.0
> --------------------
>
>                 Key: MPTEST-65
>                 URL: http://jira.codehaus.org/browse/MPTEST-65
>             Project: maven-test-plugin
>          Issue Type: Task
>    Affects Versions: 1.6.2, 1.7, 1.8
>            Reporter: Arnaud Heritier
>            Priority: Minor
>             Fix For: 1.9
>
>
> Upgrade to Junit 4.0
> JUnit 4.1 isn't (yet) available on ibiblio.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] Closed: (MPTEST-65) Upgrade to Junit 4.0

JIRA jira@codehaus.org
In reply to this post by JIRA jira@codehaus.org
     [ http://jira.codehaus.org/browse/MPTEST-65?page=all ]

Arnaud Heritier closed MPTEST-65.
---------------------------------

    Resolution: Fixed

Done

> Upgrade to Junit 4.0
> --------------------
>
>                 Key: MPTEST-65
>                 URL: http://jira.codehaus.org/browse/MPTEST-65
>             Project: maven-test-plugin
>          Issue Type: Task
>    Affects Versions: 1.6.2, 1.7, 1.8
>            Reporter: Arnaud Heritier
>         Assigned To: Arnaud Heritier
>            Priority: Minor
>             Fix For: 1.9
>
>
> Upgrade to Junit 4.0
> JUnit 4.1 isn't (yet) available on ibiblio.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] Updated: (MPTEST-65) Upgrade to Junit 4.0

JIRA jira@codehaus.org
In reply to this post by JIRA jira@codehaus.org
     [ http://jira.codehaus.org/browse/MPTEST-65?page=all ]

Arnaud Heritier updated MPTEST-65:
----------------------------------

    Affects Version/s:     (was: 1.7)
                           (was: 1.6.2)
        Fix Version/s:     (was: 1.9)

To be done.....

> Upgrade to Junit 4.0
> --------------------
>
>                 Key: MPTEST-65
>                 URL: http://jira.codehaus.org/browse/MPTEST-65
>             Project: maven-test-plugin
>          Issue Type: Task
>    Affects Versions: 1.8
>            Reporter: Arnaud Heritier
>         Assigned To: Arnaud Heritier
>            Priority: Minor
>
> Upgrade to Junit 4.0
> JUnit 4.1 isn't (yet) available on ibiblio.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] Reopened: (MPTEST-65) Upgrade to Junit 4.0

JIRA jira@codehaus.org
In reply to this post by JIRA jira@codehaus.org
     [ http://jira.codehaus.org/browse/MPTEST-65?page=all ]

Arnaud Heritier reopened MPTEST-65:
-----------------------------------

             
Can't do it. It requires JDK 1.5 and we can load it dynamically

> Upgrade to Junit 4.0
> --------------------
>
>                 Key: MPTEST-65
>                 URL: http://jira.codehaus.org/browse/MPTEST-65
>             Project: maven-test-plugin
>          Issue Type: Task
>    Affects Versions: 1.8
>            Reporter: Arnaud Heritier
>         Assigned To: Arnaud Heritier
>            Priority: Minor
>
> Upgrade to Junit 4.0
> JUnit 4.1 isn't (yet) available on ibiblio.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] Commented: (MPTEST-65) Upgrade to Junit 4.0

JIRA jira@codehaus.org
In reply to this post by JIRA jira@codehaus.org
    [ http://jira.codehaus.org/browse/MPTEST-65?page=comments#action_79070 ]
           
Arnaud Heritier commented on MPTEST-65:
---------------------------------------

It's possible to use JUnit 4.x with maven 1.x :
- add Junit 4.X in your dependencies
- Use the JUnit4TestAdapter in your test classes :
    /**
     * @return instance of this as Junit test case
     */
    public static junit.framework.Test suite()
    {
        return new JUnit4TestAdapter(MyTestClass.class);
    }
- run maven with a jdk >= 5

> Upgrade to Junit 4.0
> --------------------
>
>                 Key: MPTEST-65
>                 URL: http://jira.codehaus.org/browse/MPTEST-65
>             Project: maven-test-plugin
>          Issue Type: Task
>    Affects Versions: 1.8
>            Reporter: Arnaud Heritier
>         Assigned To: Arnaud Heritier
>            Priority: Minor
>
> Upgrade to Junit 4.0
> JUnit 4.1 isn't (yet) available on ibiblio.

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira