[jira] Created: (MPLUGIN-79) Fix detection of JDK requirement

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] Created: (MPLUGIN-79) Fix detection of JDK requirement

JIRA jira@codehaus.org
Fix detection of JDK requirement
--------------------------------

                 Key: MPLUGIN-79
                 URL: http://jira.codehaus.org/browse/MPLUGIN-79
             Project: Maven 2.x Plugin Tools
          Issue Type: Bug
          Components: Plugin Plugin
            Reporter: Benjamin Bentmann
            Priority: Trivial
         Attachments: jdk-requirement.patch

- {{getPluginArtifactMap()}} returns {{Map<String, Artifact>}} while {{Map<String, Plugin>}} is required for {{discoverJdkRequirementFromPlugins()}}
- The [Maven Compiler Plugin|http://maven.apache.org/plugins/maven-compiler-plugin/] has a fixed default value for "target", the current JDK version is irrelevant.

Last but not least: Why is {{discoverJdkRequirementFromPlugins()}} iterating over a map searching for a key? Wouldn't {{pluginsAsMap.get("org.apache.maven.plugins:maven-compiler-plugin")}} just do fine?

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] Closed: (MPLUGIN-79) Fix detection of JDK requirement

JIRA jira@codehaus.org

     [ http://jira.codehaus.org/browse/MPLUGIN-79?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Vincent Siveton closed MPLUGIN-79.
----------------------------------

         Assignee: Vincent Siveton
       Resolution: Fixed
    Fix Version/s: 2.4

Applied. Thanks!

> Fix detection of JDK requirement
> --------------------------------
>
>                 Key: MPLUGIN-79
>                 URL: http://jira.codehaus.org/browse/MPLUGIN-79
>             Project: Maven 2.x Plugin Tools
>          Issue Type: Bug
>          Components: Plugin Plugin
>            Reporter: Benjamin Bentmann
>            Assignee: Vincent Siveton
>            Priority: Trivial
>             Fix For: 2.4
>
>         Attachments: jdk-requirement.patch
>
>
> - {{getPluginArtifactMap()}} returns {{Map<String, Artifact>}} while {{Map<String, Plugin>}} is required for {{discoverJdkRequirementFromPlugins()}}
> - The [Maven Compiler Plugin|http://maven.apache.org/plugins/maven-compiler-plugin/] has a fixed default value for "target", the current JDK version is irrelevant.
> Last but not least: Why is {{discoverJdkRequirementFromPlugins()}} iterating over a map searching for a key? Wouldn't {{pluginsAsMap.get("org.apache.maven.plugins:maven-compiler-plugin")}} just do fine?

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira