java 1.4?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

java 1.4?

Benson Margulies
Some versions of plugins in the parent are still constrained,
according to comment, by a desire to support java 1.4. Is this still
policy?

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: java 1.4?

Olivier Lamy
Imho not
I usually move code to 1.5 when working on releasing something

--
Olivier
Le 4 juin 2011 20:08, "Benson Margulies" <[hidden email]> a écrit :
> Some versions of plugins in the parent are still constrained,
> according to comment, by a desire to support java 1.4. Is this still
> policy?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
Reply | Threaded
Open this post in threaded view
|

Re: java 1.4?

Benson Margulies
So I could bop the cobertura version in the overall maven parent pom?
Or just in the plugin pom?

On Sat, Jun 4, 2011 at 2:44 PM, Olivier Lamy <[hidden email]> wrote:

> Imho not
> I usually move code to 1.5 when working on releasing something
>
> --
> Olivier
> Le 4 juin 2011 20:08, "Benson Margulies" <[hidden email]> a écrit :
>> Some versions of plugins in the parent are still constrained,
>> according to comment, by a desire to support java 1.4. Is this still
>> policy?
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: java 1.4?

stephenconnolly
I say bop at the highest level, if someone has an objection they can veto...


the only exception is if you are changing a dependency of core to a
different license (in which case if the new license is out of a specified
white list, the pmc must vote on the license change)

- Stephen

---
Sent from my Android phone, so random spelling mistakes, random nonsense
words and other nonsense are a direct result of using swype to type on the
screen
On 4 Jun 2011 20:54, "Benson Margulies" <[hidden email]> wrote:

> So I could bop the cobertura version in the overall maven parent pom?
> Or just in the plugin pom?
>
> On Sat, Jun 4, 2011 at 2:44 PM, Olivier Lamy <[hidden email]> wrote:
>> Imho not
>> I usually move code to 1.5 when working on releasing something
>>
>> --
>> Olivier
>> Le 4 juin 2011 20:08, "Benson Margulies" <[hidden email]> a écrit
:

>>> Some versions of plugins in the parent are still constrained,
>>> according to comment, by a desire to support java 1.4. Is this still
>>> policy?
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
Reply | Threaded
Open this post in threaded view
|

Re: java 1.4?

Arnaud Héritier
The only thing we should take care is to note the upgrade in the cahngelog
of each plugin updated as it could avoid the upgrade for some users using an
old maven version with Java 4 ?

On Sat, Jun 4, 2011 at 10:00 PM, Stephen Connolly <
[hidden email]> wrote:

> I say bop at the highest level, if someone has an objection they can
> veto...
>
>
> the only exception is if you are changing a dependency of core to a
> different license (in which case if the new license is out of a specified
> white list, the pmc must vote on the license change)
>
> - Stephen
>
> ---
> Sent from my Android phone, so random spelling mistakes, random nonsense
> words and other nonsense are a direct result of using swype to type on the
> screen
> On 4 Jun 2011 20:54, "Benson Margulies" <[hidden email]> wrote:
> > So I could bop the cobertura version in the overall maven parent pom?
> > Or just in the plugin pom?
> >
> > On Sat, Jun 4, 2011 at 2:44 PM, Olivier Lamy <[hidden email]> wrote:
> >> Imho not
> >> I usually move code to 1.5 when working on releasing something
> >>
> >> --
> >> Olivier
> >> Le 4 juin 2011 20:08, "Benson Margulies" <[hidden email]> a
> écrit
> :
> >>> Some versions of plugins in the parent are still constrained,
> >>> according to comment, by a desire to support java 1.4. Is this still
> >>> policy?
> >>>
> >>> ---------------------------------------------------------------------
> >>> To unsubscribe, e-mail: [hidden email]
> >>> For additional commands, e-mail: [hidden email]
> >>>
> >>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>