how to get eclipse repos fixed?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

how to get eclipse repos fixed?

Russ Tremain-2
Hi,

I have a build using the tycho plugin to pull down p2 content from
http://download.eclipse.org/releases/staging/ and it appears that:

        org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar

is missing from that repository, but there are still references to it
in content.xml:

     <unit id="org.eclipse.pde.ua.ui.source" singleton="false"
version="1.0.300.v20130830-1837">
       <update id="org.eclipse.pde.ua.ui.source"
range="[0.0.0,1.0.300.v20130830-1837)" severity="0" />
       <properties size="9">
         <property name="df_LT.bundleVendor" value="Eclipse.org" />
         <property name="df_LT.bundleName" value="PDE UA UI Source" />
         <property name="org.eclipse.equinox.p2.name" value="%bundleName" />
         <property name="org.eclipse.equinox.p2.provider"
value="%bundleVendor" />
         <property name="org.eclipse.equinox.p2.bundle.localization"
value="OSGI-INF/l10n/bundle-src" />
         <property name="maven-groupId" value="org.eclipse.pde" />
         <property name="maven-artifactId" value="org.eclipse.pde.ua.ui" />
         <property name="maven-version" value="1.0.300-SNAPSHOT" />
         <property name="maven-classifier" value="sources" />
       </properties>
       <provides size="4">
         <provided name="org.eclipse.pde.ua.ui.source"
version="1.0.300.v20130830-1837"
namespace="org.eclipse.equinox.p2.iu" />
         <provided name="org.eclipse.pde.ua.ui.source"
version="1.0.300.v20130830-1837" namespace="osgi.bundle" />
         <provided name="source" version="1.0.0"
namespace="org.eclipse.equinox.p2.eclipse.type" />
         <provided name="df_LT" version="1.0.0"
namespace="org.eclipse.equinox.p2.localization" />
       </provides>
       <artifacts size="1">
         <artifact id="org.eclipse.pde.ua.ui.source"
classifier="osgi.bundle" version="1.0.300.v20130830-1837" />
       </artifacts>
       <touchpoint id="org.eclipse.equinox.p2.osgi" version="1.0.0" />
       <touchpointData size="1">
         <instructions size="1">
           <instruction key="manifest">Bundle-SymbolicName:
org.eclipse.pde.ua.ui.source
Bundle-Version: 1.0.300.v20130830-1837</instruction>
         </instructions>
       </touchpointData>
     </unit>

Maven throws an error because it can't download the artifact (from
nexus in this case):

[ERROR] Internal error: java.lang.RuntimeException:
"Messages while reading artifacts from child repositories":
["Messages while reading artifacts from child repositories":
["Problems while reading artifacts from
http://localhost:8080/nexus/content/repositories/eclipse-4.4-I-builds":
["HTTP Server 'Internal Error':
http://localhost:8080/nexus/content/repositories/eclipse-4.4-I-builds/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"],
"Problems while reading artifacts from
http://localhost:8080/nexus/content/repositories/eclipse_release_staging":
["HTTP Server 'Internal Error':
http://localhost:8080/nexus/content/repositories/eclipse_release_staging/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"],
"Messages while reading artifacts from child repositories":
["Problems while reading artifacts from
http://localhost:8080/nexus/content/repositories/eclipse_release_staging":
["HTTP Server 'Internal Error':
http://localhost:8080/nexus/content/repositories/eclipse_release_staging/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"]]]]
-> [Help 1]

QUESTIONS:

We have these problems periodically and generally the solution has
been to try to route around the offending repository, but that is not
always possible.

How do I verify that the artifact is truly missing from the external
p2 repository?

Are there programs run against these repositories that periodically
scan for missing artifacts and repair the metadata?

How do we file a "bug" against the offending provider (eclipse.org in
this case)?

Is there any way to get tycho to "forgive" certain errors in
transitive dependencies?

I'm very interested in how others debug and correct this type of problems.

I did find a nice tool that Igor Fedorenko wrote, that I found
helpful in validating p2 site url's, but it doesn't do any
consistency checks on the remote p2 repository.

thanks in advance,
-Russ

[1] https://github.com/ifedorenko/p2-browser.git

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [tycho-user] [nexus-user] how to get eclipse repos fixed?

Russ Tremain-2
Hi Igor,

At 7:32 AM -0500 12/20/13, Igor Fedorenko wrote:
>Tycho does not introduce arbitrary dependency requirements, this
>installable unit must be required by one of your projects, otherwise
>Tycho would not complain about it. There is not way to suppress this
>kind of errors.

I don't believe it is required by any project of ours.  The proof is that when I removed the eclipse_release_staging repository, the build finally worked.  So I believe it is a transitive dependency pulled in by tycho.  We are using tycho 0.17, however, not the latest.

>I just checked and I see both org.eclipse.pde.ua.ui and
>org.eclipse.pde.ua.ui.source 1.0.300.v20130830-1837 are present in the
>repository. So this particular problem must be specific to your environment.

thanks for checking, how did you do it?  is there an eclipse tool that allows one to browse p2 repositories (I don't normally use eclipse).

>Not sure if this affects other developers, but I find Eclipse repository
>mirrors exceptionally unreliable and always tell Tycho to download from
>the main repository directly. Nexus p2 proxy implementation is supposed
>to fallback to main repository automatically, but I have not checked if
>this logic still works.

is it possible that this is a bug in the nexus-p2-repository plugin?

I have noticed that the nexus p2 composite repositories do not always work as one would expect; I have had to shut down nexus, remove the composite p2 repo, and restart it when changing the member repositories in order to force it to rebuild the composite {artifact,content}.xml files.

>I am not aware of any tool to verify consistency of p2 repositories.

seems like your tool is a good start.. ;)

>I don't know how/where to report this kind of problems.

thanks for your help..

-Russ

>
>--
>Regards,
>Igor
>
>On 12/19/2013, 17:05, Russ Tremain wrote:
>>Hi,
>>
>>I have a build using the tycho plugin to pull down p2 content from
>>http://download.eclipse.org/releases/staging/ and it appears that:
>>
>>     org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar
>>
>>is missing from that repository, but there are still references to it in
>>content.xml:
>>
>>     <unit id="org.eclipse.pde.ua.ui.source" singleton="false"
>>version="1.0.300.v20130830-1837">
>>       <update id="org.eclipse.pde.ua.ui.source"
>>range="[0.0.0,1.0.300.v20130830-1837)" severity="0" />
>>       <properties size="9">
>>         <property name="df_LT.bundleVendor" value="Eclipse.org" />
>>         <property name="df_LT.bundleName" value="PDE UA UI Source" />
>>         <property name="org.eclipse.equinox.p2.name"
>>value="%bundleName" />
>>         <property name="org.eclipse.equinox.p2.provider"
>>value="%bundleVendor" />
>>         <property name="org.eclipse.equinox.p2.bundle.localization"
>>value="OSGI-INF/l10n/bundle-src" />
>>         <property name="maven-groupId" value="org.eclipse.pde" />
>>         <property name="maven-artifactId" value="org.eclipse.pde.ua.ui" />
>>         <property name="maven-version" value="1.0.300-SNAPSHOT" />
>>         <property name="maven-classifier" value="sources" />
>>       </properties>
>>       <provides size="4">
>>         <provided name="org.eclipse.pde.ua.ui.source"
>>version="1.0.300.v20130830-1837" namespace="org.eclipse.equinox.p2.iu" />
>>         <provided name="org.eclipse.pde.ua.ui.source"
>>version="1.0.300.v20130830-1837" namespace="osgi.bundle" />
>>         <provided name="source" version="1.0.0"
>>namespace="org.eclipse.equinox.p2.eclipse.type" />
>>         <provided name="df_LT" version="1.0.0"
>>namespace="org.eclipse.equinox.p2.localization" />
>>       </provides>
>>       <artifacts size="1">
>>         <artifact id="org.eclipse.pde.ua.ui.source"
>>classifier="osgi.bundle" version="1.0.300.v20130830-1837" />
>>       </artifacts>
>>       <touchpoint id="org.eclipse.equinox.p2.osgi" version="1.0.0" />
>>       <touchpointData size="1">
>>         <instructions size="1">
>>           <instruction key="manifest">Bundle-SymbolicName:
>>org.eclipse.pde.ua.ui.source
>>Bundle-Version: 1.0.300.v20130830-1837</instruction>
>>         </instructions>
>>       </touchpointData>
>>     </unit>
>>
>>Maven throws an error because it can't download the artifact (from nexus
>>in this case):
>>
>>[ERROR] Internal error: java.lang.RuntimeException:
>>"Messages while reading artifacts from child repositories":
>>["Messages while reading artifacts from child repositories":
>>["Problems while reading artifacts from
>>http://localhost:8080/nexus/content/repositories/eclipse-4.4-I-builds":
>>["HTTP Server 'Internal Error':
>>http://localhost:8080/nexus/content/repositories/eclipse-4.4-I-builds/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"],
>>
>>"Problems while reading artifacts from
>>http://localhost:8080/nexus/content/repositories/eclipse_release_staging":
>>["HTTP Server 'Internal Error':
>>http://localhost:8080/nexus/content/repositories/eclipse_release_staging/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"],
>>
>>"Messages while reading artifacts from child repositories":
>>["Problems while reading artifacts from
>>http://localhost:8080/nexus/content/repositories/eclipse_release_staging":
>>["HTTP Server 'Internal Error':
>>http://localhost:8080/nexus/content/repositories/eclipse_release_staging/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"]]]]
>>-> [Help 1]
>>
>>QUESTIONS:
>>
>>We have these problems periodically and generally the solution has been
>>to try to route around the offending repository, but that is not always
>>possible.
>>
>>How do I verify that the artifact is truly missing from the external p2
>>repository?
>>
>>Are there programs run against these repositories that periodically scan
>>for missing artifacts and repair the metadata?
>>
>>How do we file a "bug" against the offending provider (eclipse.org in
>>this case)?
>>
>>Is there any way to get tycho to "forgive" certain errors in transitive
>>dependencies?
>>
>>I'm very interested in how others debug and correct this type of problems.
>>
>>I did find a nice tool that Igor Fedorenko wrote, that I found helpful
>>in validating p2 site url's, but it doesn't do any consistency checks on
>>the remote p2 repository.
>>
>>thanks in advance,
>>-Russ
>>
>>[1] https://github.com/ifedorenko/p2-browser.git
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: [hidden email]
>>For additional commands, e-mail: [hidden email]
>>
>_______________________________________________
>tycho-user mailing list
>[hidden email]
>https://dev.eclipse.org/mailman/listinfo/tycho-user


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [tycho-user] [nexus-user] how to get eclipse repos fixed?

Igor Fedorenko-3
I used p2browser, added http://download.eclipse.org/releases/staging/
repository, searched for org.eclipse.pde.ua.ui, then downloaded the two
plugins.

--
Regards,
Igor

On 12/20/2013, 19:03, Russ Tremain wrote:

> Hi Igor,
>
> At 7:32 AM -0500 12/20/13, Igor Fedorenko wrote:
>> Tycho does not introduce arbitrary dependency requirements, this
>> installable unit must be required by one of your projects, otherwise
>> Tycho would not complain about it. There is not way to suppress this
>> kind of errors.
>
> I don't believe it is required by any project of ours.  The proof is that when I removed the eclipse_release_staging repository, the build finally worked.  So I believe it is a transitive dependency pulled in by tycho.  We are using tycho 0.17, however, not the latest.
>
>> I just checked and I see both org.eclipse.pde.ua.ui and
>> org.eclipse.pde.ua.ui.source 1.0.300.v20130830-1837 are present in the
>> repository. So this particular problem must be specific to your environment.
>
> thanks for checking, how did you do it?  is there an eclipse tool that allows one to browse p2 repositories (I don't normally use eclipse).
>
>> Not sure if this affects other developers, but I find Eclipse repository
>> mirrors exceptionally unreliable and always tell Tycho to download from
>> the main repository directly. Nexus p2 proxy implementation is supposed
>> to fallback to main repository automatically, but I have not checked if
>> this logic still works.
>
> is it possible that this is a bug in the nexus-p2-repository plugin?
>
> I have noticed that the nexus p2 composite repositories do not always work as one would expect; I have had to shut down nexus, remove the composite p2 repo, and restart it when changing the member repositories in order to force it to rebuild the composite {artifact,content}.xml files.
>
>> I am not aware of any tool to verify consistency of p2 repositories.
>
> seems like your tool is a good start.. ;)
>
>> I don't know how/where to report this kind of problems.
>
> thanks for your help..
>
> -Russ
>
>>
>> --
>> Regards,
>> Igor
>>
>> On 12/19/2013, 17:05, Russ Tremain wrote:
>>> Hi,
>>>
>>> I have a build using the tycho plugin to pull down p2 content from
>>> http://download.eclipse.org/releases/staging/ and it appears that:
>>>
>>>      org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar
>>>
>>> is missing from that repository, but there are still references to it in
>>> content.xml:
>>>
>>>      <unit id="org.eclipse.pde.ua.ui.source" singleton="false"
>>> version="1.0.300.v20130830-1837">
>>>        <update id="org.eclipse.pde.ua.ui.source"
>>> range="[0.0.0,1.0.300.v20130830-1837)" severity="0" />
>>>        <properties size="9">
>>>          <property name="df_LT.bundleVendor" value="Eclipse.org" />
>>>          <property name="df_LT.bundleName" value="PDE UA UI Source" />
>>>          <property name="org.eclipse.equinox.p2.name"
>>> value="%bundleName" />
>>>          <property name="org.eclipse.equinox.p2.provider"
>>> value="%bundleVendor" />
>>>          <property name="org.eclipse.equinox.p2.bundle.localization"
>>> value="OSGI-INF/l10n/bundle-src" />
>>>          <property name="maven-groupId" value="org.eclipse.pde" />
>>>          <property name="maven-artifactId" value="org.eclipse.pde.ua.ui" />
>>>          <property name="maven-version" value="1.0.300-SNAPSHOT" />
>>>          <property name="maven-classifier" value="sources" />
>>>        </properties>
>>>        <provides size="4">
>>>          <provided name="org.eclipse.pde.ua.ui.source"
>>> version="1.0.300.v20130830-1837" namespace="org.eclipse.equinox.p2.iu" />
>>>          <provided name="org.eclipse.pde.ua.ui.source"
>>> version="1.0.300.v20130830-1837" namespace="osgi.bundle" />
>>>          <provided name="source" version="1.0.0"
>>> namespace="org.eclipse.equinox.p2.eclipse.type" />
>>>          <provided name="df_LT" version="1.0.0"
>>> namespace="org.eclipse.equinox.p2.localization" />
>>>        </provides>
>>>        <artifacts size="1">
>>>          <artifact id="org.eclipse.pde.ua.ui.source"
>>> classifier="osgi.bundle" version="1.0.300.v20130830-1837" />
>>>        </artifacts>
>>>        <touchpoint id="org.eclipse.equinox.p2.osgi" version="1.0.0" />
>>>        <touchpointData size="1">
>>>          <instructions size="1">
>>>            <instruction key="manifest">Bundle-SymbolicName:
>>> org.eclipse.pde.ua.ui.source
>>> Bundle-Version: 1.0.300.v20130830-1837</instruction>
>>>          </instructions>
>>>        </touchpointData>
>>>      </unit>
>>>
>>> Maven throws an error because it can't download the artifact (from nexus
>>> in this case):
>>>
>>> [ERROR] Internal error: java.lang.RuntimeException:
>>> "Messages while reading artifacts from child repositories":
>>> ["Messages while reading artifacts from child repositories":
>>> ["Problems while reading artifacts from
>>> http://localhost:8080/nexus/content/repositories/eclipse-4.4-I-builds":
>>> ["HTTP Server 'Internal Error':
>>> http://localhost:8080/nexus/content/repositories/eclipse-4.4-I-builds/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"],
>>>
>>> "Problems while reading artifacts from
>>> http://localhost:8080/nexus/content/repositories/eclipse_release_staging":
>>> ["HTTP Server 'Internal Error':
>>> http://localhost:8080/nexus/content/repositories/eclipse_release_staging/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"],
>>>
>>> "Messages while reading artifacts from child repositories":
>>> ["Problems while reading artifacts from
>>> http://localhost:8080/nexus/content/repositories/eclipse_release_staging":
>>> ["HTTP Server 'Internal Error':
>>> http://localhost:8080/nexus/content/repositories/eclipse_release_staging/plugins/org.eclipse.pde.ua.ui_1.0.300.v20130830-1837.jar"]]]]
>>> -> [Help 1]
>>>
>>> QUESTIONS:
>>>
>>> We have these problems periodically and generally the solution has been
>>> to try to route around the offending repository, but that is not always
>>> possible.
>>>
>>> How do I verify that the artifact is truly missing from the external p2
>>> repository?
>>>
>>> Are there programs run against these repositories that periodically scan
>>> for missing artifacts and repair the metadata?
>>>
>>> How do we file a "bug" against the offending provider (eclipse.org in
>>> this case)?
>>>
>>> Is there any way to get tycho to "forgive" certain errors in transitive
>>> dependencies?
>>>
>>> I'm very interested in how others debug and correct this type of problems.
>>>
>>> I did find a nice tool that Igor Fedorenko wrote, that I found helpful
>>> in validating p2 site url's, but it doesn't do any consistency checks on
>>> the remote p2 repository.
>>>
>>> thanks in advance,
>>> -Russ
>>>
>>> [1] https://github.com/ifedorenko/p2-browser.git
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>> _______________________________________________
>> tycho-user mailing list
>> [hidden email]
>> https://dev.eclipse.org/mailman/listinfo/tycho-user
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]