commons-dbcp : no-JDBC3 version on ibiblio ?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

commons-dbcp : no-JDBC3 version on ibiblio ?

Nicolas De Loof-3

Hello,

I'm using commons-dbcp in my project, that runs on a JDK 1.3. It
requires the commons-dbcp project to be compiled with some options to
"exclude" JDBC3 code.

The commons-dbcp jar in maven ibiblio repository is the "official" full
JDBC3 aware version.
What is the "best-practice" way to handle such a case ?
- ask commons-dbcp to upload a second jar in apache repository (then,
what name to use ?)
- put the expected jar in my private repository (I'd prefer all OS
libraries to be on ibiblio)
- any other ?

Thanks for any suggestion

Nico.

This message contains information that may be privileged or confidential and is the property of the Capgemini Group. It is intended only for the person to whom it is addressed. If you are not the intended recipient,  you are not authorized to read, print, retain, copy, disseminate,  distribute, or use this message or any part thereof. If you receive this  message in error, please notify the sender immediately and delete all  copies of this message.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: commons-dbcp : no-JDBC3 version on ibiblio ?

Brett Porter
On 5/30/05, Nicolas De Loof <[hidden email]> wrote:
> - ask commons-dbcp to upload a second jar in apache repository (then,
> what name to use ?)

This one.

(commons-dbcp-nojdbc3-1.2.jar or something, I guess, with a copy of
the pom that excludes those dependencies)

- Brett

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]