Xdoc, URLs and &

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Xdoc, URLs and &

Jon Strayer
I would like to include a url that has a few parameters in an xdoc.

The URL is long, but it looks something like this:
http://blablabla.com//fn_custom_login.asp?hidetree=true&client=Services

When I put it in like this xdoc complains about the entity &client.

When I use  http://blablabla.com//fn_custom_login.asp?hidetree=true&client=Services

I get an url that doesn't work (the entity & isn't ever translated to an &).

Is there a workaround?

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Xdoc, URLs and &

arikkfir
Hi

try escaping the ampersands ("&") by changing each "&" occurance into a
"&" (without the quotes). This is an XML issue, btw, not a Maven issue,
as you cannot put ampersands in XML without escaping it (reserved
character).

----- Original Message -----
From: "Jon Strayer" <[hidden email]>
To: "Maven Users List" <[hidden email]>
Sent: Wednesday, May 25, 2005 7:35 PM
Subject: Xdoc, URLs and &


I would like to include a url that has a few parameters in an xdoc.

The URL is long, but it looks something like this:
http://blablabla.com//fn_custom_login.asp?hidetree=true&client=Services

When I put it in like this xdoc complains about the entity &client.

When I use
http://blablabla.com//fn_custom_login.asp?hidetree=true&amp;client=Services

I get an url that doesn't work (the entity &amp; isn't ever translated to an
&).

Is there a workaround?

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Xdoc, URLs and &

Jamie Bisotti
Uhhhh...I think he already tired that and it does not work.  Check the
original post again.

On 5/25/05, Arik Kfir <[hidden email]> wrote:

> Hi
>
> try escaping the ampersands ("&") by changing each "&" occurance into a
> "&amp;" (without the quotes). This is an XML issue, btw, not a Maven issue,
> as you cannot put ampersands in XML without escaping it (reserved
> character).
>
> ----- Original Message -----
> From: "Jon Strayer" <[hidden email]>
> To: "Maven Users List" <[hidden email]>
> Sent: Wednesday, May 25, 2005 7:35 PM
> Subject: Xdoc, URLs and &
>
>
> I would like to include a url that has a few parameters in an xdoc.
>
> The URL is long, but it looks something like this:
> http://blablabla.com//fn_custom_login.asp?hidetree=true&client=Services
>
> When I put it in like this xdoc complains about the entity &client.
>
> When I use
> http://blablabla.com//fn_custom_login.asp?hidetree=true&amp;client=Services
>
> I get an url that doesn't work (the entity &amp; isn't ever translated to an
> &).
>
> Is there a workaround?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Jamie Bisotti
Software Engineer
Lexmark International, Inc.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Xdoc, URLs and &

arikkfir
oooops! trigger happy on the "send" button :) sorry...

actually I'm doing it in mevenide and it does work...what maven version are
you using?

----- Original Message -----
From: "Jamie Bisotti" <[hidden email]>
To: "Maven Users List" <[hidden email]>
Sent: Wednesday, May 25, 2005 8:14 PM
Subject: Re: Xdoc, URLs and &


Uhhhh...I think he already tired that and it does not work.  Check the
original post again.

On 5/25/05, Arik Kfir <[hidden email]> wrote:

> Hi
>
> try escaping the ampersands ("&") by changing each "&" occurance into a
> "&amp;" (without the quotes). This is an XML issue, btw, not a Maven
> issue,
> as you cannot put ampersands in XML without escaping it (reserved
> character).
>
> ----- Original Message -----
> From: "Jon Strayer" <[hidden email]>
> To: "Maven Users List" <[hidden email]>
> Sent: Wednesday, May 25, 2005 7:35 PM
> Subject: Xdoc, URLs and &
>
>
> I would like to include a url that has a few parameters in an xdoc.
>
> The URL is long, but it looks something like this:
> http://blablabla.com//fn_custom_login.asp?hidetree=true&client=Services
>
> When I put it in like this xdoc complains about the entity &client.
>
> When I use
> http://blablabla.com//fn_custom_login.asp?hidetree=true&amp;client=Services
>
> I get an url that doesn't work (the entity &amp; isn't ever translated to
> an
> &).
>
> Is there a workaround?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Jamie Bisotti
Software Engineer
Lexmark International, Inc.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Xdoc, URLs and &

Jon Strayer
In reply to this post by arikkfir
Arik Kfir wrote:
> Hi
>
> try escaping the ampersands ("&") by changing each "&" occurance into a
> "&amp;" (without the quotes). This is an XML issue, btw, not a Maven
> issue, as you cannot put ampersands in XML without escaping it (reserved
> character).

I did that.  That's how I ended up with a URL that didn't work.

>
> I would like to include a url that has a few parameters in an xdoc.
>
> The URL is long, but it looks something like this:
> http://blablabla.com//fn_custom_login.asp?hidetree=true&client=Services
>
> When I put it in like this xdoc complains about the entity &client.
>
> When I use
> http://blablabla.com//fn_custom_login.asp?hidetree=true&amp;client=Services
>
> I get an url that doesn't work (the entity &amp; isn't ever translated
> to an &).
>
> Is there a workaround?

Besides tinyurl.com?



----

He was so narrow minded he could see through a keyhole with both eyes..."

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Xdoc, URLs and &

Jon Strayer
In reply to this post by arikkfir
1.0.2

On 5/25/05, Arik Kfir <[hidden email]> wrote:

> oooops! trigger happy on the "send" button :) sorry...
>
> actually I'm doing it in mevenide and it does work...what maven version are
> you using?
>
> ----- Original Message -----
> From: "Jamie Bisotti" <[hidden email]>
> To: "Maven Users List" <[hidden email]>
> Sent: Wednesday, May 25, 2005 8:14 PM
> Subject: Re: Xdoc, URLs and &
>
>
> Uhhhh...I think he already tired that and it does not work.  Check the
> original post again.
>
> On 5/25/05, Arik Kfir <[hidden email]> wrote:
> > Hi
> >
> > try escaping the ampersands ("&") by changing each "&" occurance into a
> > "&amp;" (without the quotes). This is an XML issue, btw, not a Maven
> > issue,
> > as you cannot put ampersands in XML without escaping it (reserved
> > character).
> >
> > ----- Original Message -----
> > From: "Jon Strayer" <[hidden email]>
> > To: "Maven Users List" <[hidden email]>
> > Sent: Wednesday, May 25, 2005 7:35 PM
> > Subject: Xdoc, URLs and &
> >
> >
> > I would like to include a url that has a few parameters in an xdoc.
> >
> > The URL is long, but it looks something like this:
> > http://blablabla.com//fn_custom_login.asp?hidetree=true&client=Services
> >
> > When I put it in like this xdoc complains about the entity &client.
> >
> > When I use
> > http://blablabla.com//fn_custom_login.asp?hidetree=true&amp;client=Services
> >
> > I get an url that doesn't work (the entity &amp; isn't ever translated to
> > an
> > &).
> >
> > Is there a workaround?
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
>
> --
> Jamie Bisotti
> Software Engineer
> Lexmark International, Inc.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Xdoc, URLs and &

arikkfir
can you post the document, or atleast the surrounding fragement? I'm using
1.0.2 too and it seems to work...

----- Original Message -----
From: "Jon Strayer" <[hidden email]>
To: "Maven Users List" <[hidden email]>
Sent: Wednesday, May 25, 2005 10:14 PM
Subject: Re: Xdoc, URLs and &


1.0.2

On 5/25/05, Arik Kfir <[hidden email]> wrote:

> oooops! trigger happy on the "send" button :) sorry...
>
> actually I'm doing it in mevenide and it does work...what maven version
> are
> you using?
>
> ----- Original Message -----
> From: "Jamie Bisotti" <[hidden email]>
> To: "Maven Users List" <[hidden email]>
> Sent: Wednesday, May 25, 2005 8:14 PM
> Subject: Re: Xdoc, URLs and &
>
>
> Uhhhh...I think he already tired that and it does not work.  Check the
> original post again.
>
> On 5/25/05, Arik Kfir <[hidden email]> wrote:
> > Hi
> >
> > try escaping the ampersands ("&") by changing each "&" occurance into a
> > "&amp;" (without the quotes). This is an XML issue, btw, not a Maven
> > issue,
> > as you cannot put ampersands in XML without escaping it (reserved
> > character).
> >
> > ----- Original Message -----
> > From: "Jon Strayer" <[hidden email]>
> > To: "Maven Users List" <[hidden email]>
> > Sent: Wednesday, May 25, 2005 7:35 PM
> > Subject: Xdoc, URLs and &
> >
> >
> > I would like to include a url that has a few parameters in an xdoc.
> >
> > The URL is long, but it looks something like this:
> > http://blablabla.com//fn_custom_login.asp?hidetree=true&client=Services
> >
> > When I put it in like this xdoc complains about the entity &client.
> >
> > When I use
> > http://blablabla.com//fn_custom_login.asp?hidetree=true&amp;client=Services
> >
> > I get an url that doesn't work (the entity &amp; isn't ever translated
> > to
> > an
> > &).
> >
> > Is there a workaround?
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
>
> --
> Jamie Bisotti
> Software Engineer
> Lexmark International, Inc.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: Xdoc, URLs and &

Arnaud Héritier
In theory it was fixed one year ago :

http://jira.codehaus.org/browse/MPXDOC-92

Arnaud
 

> -----Message d'origine-----
> De : Arik Kfir [mailto:[hidden email]]
> Envoyé : mercredi 25 mai 2005 23:17
> À : Maven Users List; Jon Strayer
> Objet : Re: Xdoc, URLs and &
>
> can you post the document, or atleast the surrounding
> fragement? I'm using
> 1.0.2 too and it seems to work...
>
> ----- Original Message -----
> From: "Jon Strayer" <[hidden email]>
> To: "Maven Users List" <[hidden email]>
> Sent: Wednesday, May 25, 2005 10:14 PM
> Subject: Re: Xdoc, URLs and &
>
>
> 1.0.2
>
> On 5/25/05, Arik Kfir <[hidden email]> wrote:
> > oooops! trigger happy on the "send" button :) sorry...
> >
> > actually I'm doing it in mevenide and it does work...what
> maven version
> > are
> > you using?
> >
> > ----- Original Message -----
> > From: "Jamie Bisotti" <[hidden email]>
> > To: "Maven Users List" <[hidden email]>
> > Sent: Wednesday, May 25, 2005 8:14 PM
> > Subject: Re: Xdoc, URLs and &
> >
> >
> > Uhhhh...I think he already tired that and it does not work.
>  Check the
> > original post again.
> >
> > On 5/25/05, Arik Kfir <[hidden email]> wrote:
> > > Hi
> > >
> > > try escaping the ampersands ("&") by changing each "&"
> occurance into a
> > > "&amp;" (without the quotes). This is an XML issue, btw,
> not a Maven
> > > issue,
> > > as you cannot put ampersands in XML without escaping it (reserved
> > > character).
> > >
> > > ----- Original Message -----
> > > From: "Jon Strayer" <[hidden email]>
> > > To: "Maven Users List" <[hidden email]>
> > > Sent: Wednesday, May 25, 2005 7:35 PM
> > > Subject: Xdoc, URLs and &
> > >
> > >
> > > I would like to include a url that has a few parameters
> in an xdoc.
> > >
> > > The URL is long, but it looks something like this:
> > >
> http://blablabla.com//fn_custom_login.asp?hidetree=true&client
=Services
> > >
> > > When I put it in like this xdoc complains about the
> entity &client.
> > >
> > > When I use
> > >
> http://blablabla.com//fn_custom_login.asp?hidetree=true&amp;cl
ient=Services

> > >
> > > I get an url that doesn't work (the entity &amp; isn't
> ever translated
> > > to
> > > an
> > > &).
> > >
> > > Is there a workaround?
> > >
> > >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> > >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
> >
> > --
> > Jamie Bisotti
> > Software Engineer
> > Lexmark International, Inc.
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]