What's happened to wagon's sshExecutable setting?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

What's happened to wagon's sshExecutable setting?

Daniel Serodio
I'm on Windows XP, and I'm trying to make Maven deployment use my private key which is stored in PuTTY's Pageant ssh agent.

I found an old recipe on the net that says I should use the following settings.xml:

<server>
    <id>my-repo</id>
    <configuration>
        <sshExecutable>c:/Progra~1/PuTTY/plink.exe</sshExecutable>
        <scpExecutable>c:/Progra~1/PuTTY/pscp.exe</scpExecutable>
    </configuration>
</server>

But when I try this, I get the following error:

[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error retrieving previous build number for artifact 'br.pucsp.apt:ereinion:jar': repository metadata for: 'snapshot br.pucsp.apt:ereinion:2.0.0-SNAPSHOT'
 could not be retrieved from repository: vulcano-repo due to an error: While configuring wagon for 'vulcano-repo': Unable to apply wagon configuration.

Cannot find setter nor field in org.apache.maven.wagon.providers.ssh.jsch.ScpWagon for 'sshExecutable'
Reply | Threaded
Open this post in threaded view
|

Re: What's happened to wagon's sshExecutable setting?

brettporter
Administrator
You need to use scpexe:// for the URL instead of scp://

- Brett

On 10/09/2009, at 6:09 AM, Daniel Serodio wrote:

>
> I'm on Windows XP, and I'm trying to make Maven deployment use my  
> private key
> which is stored in PuTTY's Pageant ssh agent.
>
> I found an old recipe on the net that says I should use the following
> settings.xml:
>
> <server>
>    <id>my-repo</id>
>    <configuration>
>        <sshExecutable>c:/Progra~1/PuTTY/plink.exe</sshExecutable>
>        <scpExecutable>c:/Progra~1/PuTTY/pscp.exe</scpExecutable>
>    </configuration>
> </server>
>
> But when I try this, I get the following error:
>
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error retrieving previous build number for artifact
> 'br.pucsp.apt:ereinion:jar': repository metadata for: 'snapshot
> br.pucsp.apt:ereinion:2.0.0-SNAPSHOT'
> could not be retrieved from repository: vulcano-repo due to an  
> error: While
> configuring wagon for 'vulcano-repo': Unable to apply wagon  
> configuration.
>
> Cannot find setter nor field in
> org.apache.maven.wagon.providers.ssh.jsch.ScpWagon for 'sshExecutable'
> --
> View this message in context: http://www.nabble.com/What%27s-happened-to-wagon%27s-sshExecutable-setting--tp25372367p25372367.html
> Sent from the Wagon - Users mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: What's happened to wagon's sshExecutable setting?

Daniel Serodio
Great! Thanks for the tip. Is this documented somewhere I couldn't find?

Regards,
Daniel Serodio
brettporter wrote
You need to use scpexe:// for the URL instead of scp://

- Brett

On 10/09/2009, at 6:09 AM, Daniel Serodio wrote:

>
> I'm on Windows XP, and I'm trying to make Maven deployment use my  
> private key
> which is stored in PuTTY's Pageant ssh agent.
>
> I found an old recipe on the net that says I should use the following
> settings.xml:
>
> <server>
>    <id>my-repo</id>
>    <configuration>
>        <sshExecutable>c:/Progra~1/PuTTY/plink.exe</sshExecutable>
>        <scpExecutable>c:/Progra~1/PuTTY/pscp.exe</scpExecutable>
>    </configuration>
> </server>
>
> But when I try this, I get the following error:
>
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error retrieving previous build number for artifact
> 'br.pucsp.apt:ereinion:jar': repository metadata for: 'snapshot
> br.pucsp.apt:ereinion:2.0.0-SNAPSHOT'
> could not be retrieved from repository: vulcano-repo due to an  
> error: While
> configuring wagon for 'vulcano-repo': Unable to apply wagon  
> configuration.
>
> Cannot find setter nor field in
> org.apache.maven.wagon.providers.ssh.jsch.ScpWagon for 'sshExecutable'
Reply | Threaded
Open this post in threaded view
|

Re: What's happened to wagon's sshExecutable setting?

brettporter
Administrator
It used to be on the site, but it seems the page is gone now...

On 11/09/2009, at 12:18 AM, Daniel Serodio wrote:

>
> Great! Thanks for the tip. Is this documented somewhere I couldn't  
> find?
>
> Regards,
> Daniel Serodio
>
> brettporter wrote:
>>
>> You need to use scpexe:// for the URL instead of scp://
>>
>> - Brett
>>
>> On 10/09/2009, at 6:09 AM, Daniel Serodio wrote:
>>
>>>
>>> I'm on Windows XP, and I'm trying to make Maven deployment use my
>>> private key
>>> which is stored in PuTTY's Pageant ssh agent.
>>>
>>> I found an old recipe on the net that says I should use the  
>>> following
>>> settings.xml:
>>>
>>> <server>
>>>   <id>my-repo</id>
>>>   <configuration>
>>>       <sshExecutable>c:/Progra~1/PuTTY/plink.exe</sshExecutable>
>>>       <scpExecutable>c:/Progra~1/PuTTY/pscp.exe</scpExecutable>
>>>   </configuration>
>>> </server>
>>>
>>> But when I try this, I get the following error:
>>>
>>> [ERROR] BUILD ERROR
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] Error retrieving previous build number for artifact
>>> 'br.pucsp.apt:ereinion:jar': repository metadata for: 'snapshot
>>> br.pucsp.apt:ereinion:2.0.0-SNAPSHOT'
>>> could not be retrieved from repository: vulcano-repo due to an
>>> error: While
>>> configuring wagon for 'vulcano-repo': Unable to apply wagon
>>> configuration.
>>>
>>> Cannot find setter nor field in
>>> org.apache.maven.wagon.providers.ssh.jsch.ScpWagon for  
>>> 'sshExecutable'
>>
>
> --
> View this message in context: http://www.nabble.com/What%27s-happened-to-wagon%27s-sshExecutable-setting--tp25372367p25384179.html
> Sent from the Wagon - Users mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]