[VOTE] Release Apache Maven GPG Plugin version 3.0.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[VOTE] Release Apache Maven GPG Plugin version 3.0.0

Hervé BOUTEMY
Hi,
 
We solved 13 issues:
https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317521&version=12330781&styleName=Text
 
Staging repo:
https://repository.apache.org/content/repositories/maven-1563/
https://repository.apache.org/content/repositories/maven-1563/org/apache/maven/plugins/maven-gpg-plugin/3.0.0/maven-gpg-plugin-3.0.0-source-release.zip
 
Source release checksum(s):
maven-gpg-plugin-3.0.0-source-release.zip sha512: 773e1ba20d3edd6924bf7c909c0bf68746d79874a0df258da05ccc2b3138415f0183350b54209a3003eb081cc11e22bc316a7d8a7016fe4dab30eb0db5a9b0ac
 
Staging site:
https://maven.apache.org/plugins-archives/maven-gpg-plugin-LATEST/
 
Guide to testing staged releases:
https://maven.apache.org/guides/development/guide-testing-releases.html
 
Vote open for at least 72 hours.
 
[ ] +1
[ ] +0
[ ] -1



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Maven GPG Plugin version 3.0.0

Elliotte Rusty Harold
Ther GPG plugin is using these two deprecated classes:

import org.apache.maven.artifact.factory.ArtifactFactory;
import org.apache.maven.artifact.metadata.ArtifactMetadata;

However I can find no documentation about why these are deprecated are
what is supposed to be used instead. Does anyone know?

On Wed, Apr 15, 2020 at 3:25 PM Tibor Digana <[hidden email]> wrote:

>
> Sorry my -1 due to all integration tests have failed with the following errors:
>
> Caused by: java.lang.IllegalArgumentException: Can't parse version of
> gpg (GnuPG) 2.0.26 (Gpg4win 2.2.3)
>     at org.apache.maven.plugins.gpg.GpgVersion.compareTo(GpgVersion.java:60)
>     at org.apache.maven.plugins.gpg.GpgVersion.isBefore(GpgVersion.java:101)
>     at org.apache.maven.plugins.gpg.GpgSigner.generateSignatureForFile(GpgSigner.java:89)
>     at org.apache.maven.plugins.gpg.AbstractGpgSigner.generateSignatureForArtifact(AbstractGpgSigner.java:203)
>     at org.apache.maven.plugins.gpg.GpgSignAttachedMojo.execute(GpgSignAttachedMojo.java:178)
>     at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
>
> The version on the command line:
>
> $ gpg --version
> gpg (GnuPG) 2.0.26 (Gpg4win 2.2.3)
> libgcrypt 1.6.2
> Copyright (C) 2013 Free Software Foundation, Inc.
> License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
> This is free software: you are free to change and redistribute it.
> There is NO WARRANTY, to the extent permitted by law.
>
> On Sun, Apr 12, 2020 at 2:50 PM Hervé BOUTEMY <[hidden email]> wrote:
> >
> > Hi,
> >
> > We solved 13 issues:
> > https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317521&version=12330781&styleName=Text
> >
> > Staging repo:
> > https://repository.apache.org/content/repositories/maven-1563/
> > https://repository.apache.org/content/repositories/maven-1563/org/apache/maven/plugins/maven-gpg-plugin/3.0.0/maven-gpg-plugin-3.0.0-source-release.zip
> >
> > Source release checksum(s):
> > maven-gpg-plugin-3.0.0-source-release.zip sha512: 773e1ba20d3edd6924bf7c909c0bf68746d79874a0df258da05ccc2b3138415f0183350b54209a3003eb081cc11e22bc316a7d8a7016fe4dab30eb0db5a9b0ac
> >
> > Staging site:
> > https://maven.apache.org/plugins-archives/maven-gpg-plugin-LATEST/
> >
> > Guide to testing staged releases:
> > https://maven.apache.org/guides/development/guide-testing-releases.html
> >
> > Vote open for at least 72 hours.
> >
> > [ ] +1
> > [ ] +0
> > [ ] -1
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>
>
> --
> Cheers
> Tibor
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


--
Elliotte Rusty Harold
[hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]