Using antlr4-maven-plugin in reproducible builds?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Using antlr4-maven-plugin in reproducible builds?

Christofer Dutz
Hi all,

I am currently trying to adjust the build configuration of the projects I’m involved in to be able to generate reproducible builds.

One of the things I read are important for this, is to fix the line.separator so I added that to the “apache-release” profile.

This seems to work perfectly … until one project uses the antlr4-maven-plugin (well actually the antlr2 and 3 versions too).
In this case I’m getting angry errors from antlr …

Any other projects have this this issue too? I tried taking it to the antlr mailinglist (google group) but not getting any responses from there.


Chris