Upgrading maven-release-plugin to maven-scm-api 1.9.5 ?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Upgrading maven-release-plugin to maven-scm-api 1.9.5 ?

Feblot, Alexandre
Hi,
Jgit provider exposes password if it contains special characters : SCM-817<https://issues.apache.org/jira/browse/SCM-817> (https://issues.apache.org/jira/browse/SCM-817) was fixed in maven-scm-api 1.9.5 which was released in July 1st, 2016. maven-scm-api 1.9.6 has even been released since then.
However, maven-release-plugin has not been updated with it so far.
I found a waiting pull request <https://github.com/apache/maven-release/pull/7> (https://github.com/apache/maven-release/pull/7) doing this on github, but I don't know if/how this repository is monitored, as your doc page states your official repository is a svn one.
So my questions are:

*         Is there any chance you release a maven-release-plugin 2.5.4 depending on maven-scn-api 1.9.5 or 1.9.6 somedays in a not too far future?

*         What more can be done to help this happen?

Thanks
--
Cordialement/Regards,

Alexandre Feblot
CM Buildmasters


"Misys" is the trade name of the Misys group of companies. This email and any attachments have been scanned for known viruses using multiple scanners. This email message is intended for the named recipient only. It may be privileged and/or confidential. If you are not the named recipient of this email please notify us immediately and do not copy it or use it for any purpose, nor disclose its contents to any other person. This email does not constitute the commencement of legal relations between you and Misys. Please refer to the executed contract between you and the relevant member of the Misys group for the identity of the contracting party with which you are dealing.