Quantcast

Site builds fail with Doxia 1.1.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Site builds fail with Doxia 1.1.1

Steven Swor
Hi,

I'm having trouble getting site builds to work using Doxia 1.1.1

My environment is (dumped from "mvn --version"):

Apache Maven 2.2.0 (r788681; 2009-06-26 08:04:01-0500)
Java version: 1.5.0_19
Java home: /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/
Home
Default locale: en_US, platform encoding: MacRoman
OS name: "mac os x" version: "10.5.7" arch: "i386" Family: "unix"


I figured the best way to eliminate any errors on my part would be to  
try and build something I knew was working elsewhere, so I checked out  
the Doxia stuff from the source repository and tried to run the site  
goal on the Doxia Site project.  The build failed with the following  
error:

------------------------------------------------------------------------
[ERROR]BUILD ERROR
------------------------------------------------------------------------
Internal error in the plugin manager executing goal  
'org.apache.maven.doxia:doxia-maven-plugin:1.1.1:render-books': Unable  
to load the mojo 'org.apache.maven.doxia:doxia-maven-plugin:
1.1.1:render-books' in the plugin 'org.apache.maven.doxia:doxia-maven-
plugin'. A required class is missing: hidden/org/codehaus/plexus/
interpolation/ValueSource
hidden.org.codehaus.plexus.interpolation.ValueSource

Attached is the output from running "mvn -e --debug --fail-fast clean  
site" on the Doxia Site project.

This is the same error I get when I try to run any site build against  
Doxia 1.1.1.  Am I doing something wrong here, is there a problem with  
the 1.1.1 release?  Any insight into this matter would be greatly  
appreciated.

Thanks,
Steve



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Site builds fail with Doxia 1.1.1

Lukas Theussl-4

Hi,

I can't reproduce your problem, the doxia site builds fine here (tested with clean
repo, maven 2.1.0 and 2.2.0).

The same stack trace has been reported by Vincent a few days ago [1], I don't know
what's the conclusion, maybe he knows more in the meantime.

Cheers,
-Lukas

[1] http://www.nabble.com/Using-latest-Plexus-Utils-in-javadoc-plugin-td24628610.html


Steven Swor wrote:

> Hi,
>
> I'm having trouble getting site builds to work using Doxia 1.1.1
>
> My environment is (dumped from "mvn --version"):
>
> Apache Maven 2.2.0 (r788681; 2009-06-26 08:04:01-0500)
> Java version: 1.5.0_19
> Java home: /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home
> Default locale: en_US, platform encoding: MacRoman
> OS name: "mac os x" version: "10.5.7" arch: "i386" Family: "unix"
>
>
> I figured the best way to eliminate any errors on my part would be to
> try and build something I knew was working elsewhere, so I checked out
> the Doxia stuff from the source repository and tried to run the site
> goal on the Doxia Site project.  The build failed with the following error:
>
> ------------------------------------------------------------------------
> [ERROR]BUILD ERROR
> ------------------------------------------------------------------------
> Internal error in the plugin manager executing goal
> 'org.apache.maven.doxia:doxia-maven-plugin:1.1.1:render-books': Unable
> to load the mojo
> 'org.apache.maven.doxia:doxia-maven-plugin:1.1.1:render-books' in the
> plugin 'org.apache.maven.doxia:doxia-maven-plugin'. A required class is
> missing: hidden/org/codehaus/plexus/interpolation/ValueSource
> hidden.org.codehaus.plexus.interpolation.ValueSource
>
> Attached is the output from running "mvn -e --debug --fail-fast clean
> site" on the Doxia Site project.
>
> This is the same error I get when I try to run any site build against
> Doxia 1.1.1.  Am I doing something wrong here, is there a problem with
> the 1.1.1 release?  Any insight into this matter would be greatly
> appreciated.
>
> Thanks,
> Steve
>
>
Loading...