Simply doxi twiki test not running

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Simply doxi twiki test not running

Josep Llort Tella
Hi

I've tryed so simply test class with

Parser parser = new TWikiParser();
Reader reader = ReaderFactory.newReader( new
File("/home/jllort/Escritorio/TWikiParserTest.twiki"), "UTF-8" );
OutputStream out = new BufferedOutputStream(new
FileOutputStream("/home/jllort/Escritorio/out.html"));
parser.parse(reader, new TWikiSinkFactory().createSink(out, "UTF-8"));

But the output it's the same than input, could you tell me some idea about
what I'm doing wrong. I don't know what I'm missing, any example will be
appreciated too.

Thanks on advance

Josep
    OpenKM Team ( be open my friend )
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Simply doxi twiki test not running

Lukas Theussl-4

You are using a TwikiSinkFactory to create the ouput, which will create,
guess, some twiki output. Try a XhtmlSinkFactory instead.

HTH,
-Lukas


Josep Llort Tella wrote:

> Hi
>
> I've tryed so simply test class with
>
> Parser parser = new TWikiParser();
> Reader reader = ReaderFactory.newReader( new
> File("/home/jllort/Escritorio/TWikiParserTest.twiki"), "UTF-8" );
> OutputStream out = new BufferedOutputStream(new
> FileOutputStream("/home/jllort/Escritorio/out.html"));
> parser.parse(reader, new TWikiSinkFactory().createSink(out, "UTF-8"));
>
> But the output it's the same than input, could you tell me some idea about
> what I'm doing wrong. I don't know what I'm missing, any example will be
> appreciated too.
>
> Thanks on advance
>
> Josep
>      OpenKM Team ( be open my friend )
>
Loading...