Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

Sylwester Lachiewicz
+1

sob., 23 maj 2020, 09:22 użytkownik Hervé BOUTEMY <[hidden email]>
napisał:

> Le vendredi 22 mai 2020, 02:13:16 CEST Olivier Lamy a écrit :
> > > +  * discussions on Maven > 3.0.x (3.1 or 3.2 or 3.3? details still
> TDB) +
> > > Java 8 prerequisites
> >
> > Don't be shy Hervé we can definitely says >= 3.3.9 (at least you will not
> > hear any objections from me :) )
>
> looking at our history https://maven.apache.org/docs/history.html, there
> is 1
> year between 3.1.max and 3.2.max then 1 year to 3.3.max: not so much
> and AFAIK, many people went from 3.0 to 3.3+
>
> looks a good idea to me: +1
>
> any objection?
>
> Regards,
>
> Hervé
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

Arnaud Héritier
+1

On Sat, May 23, 2020 at 11:13 AM Enrico Olivelli <[hidden email]>
wrote:

> +1
>
> Enrico
>
> Il Sab 23 Mag 2020, 09:40 Sylwester Lachiewicz <[hidden email]> ha
> scritto:
>
> > +1
> >
> > sob., 23 maj 2020, 09:22 użytkownik Hervé BOUTEMY <[hidden email]
> >
> > napisał:
> >
> > > Le vendredi 22 mai 2020, 02:13:16 CEST Olivier Lamy a écrit :
> > > > > +  * discussions on Maven > 3.0.x (3.1 or 3.2 or 3.3? details still
> > > TDB) +
> > > > > Java 8 prerequisites
> > > >
> > > > Don't be shy Hervé we can definitely says >= 3.3.9 (at least you will
> > not
> > > > hear any objections from me :) )
> > >
> > > looking at our history https://maven.apache.org/docs/history.html,
> there
> > > is 1
> > > year between 3.1.max and 3.2.max then 1 year to 3.3.max: not so much
> > > and AFAIK, many people went from 3.0 to 3.3+
> > >
> > > looks a good idea to me: +1
> > >
> > > any objection?
> > >
> > > Regards,
> > >
> > > Hervé
> > >
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
>


--
-----
Arnaud Héritier
http://aheritier.net
Mail/GTalk: aheritier AT gmail DOT com
Twitter/Skype : aheritier
Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

rfscholte
As discussed before: compatibility should either be 3.3.1 (since 3.3.0 didn't make it) or 3.5.0, we should not include the (highest) bugfix version.

Robert


On 23-5-2020 12:43:35, Arnaud Héritier <[hidden email]> wrote:
+1

On Sat, May 23, 2020 at 11:13 AM Enrico Olivelli
wrote:

> +1
>
> Enrico
>
> Il Sab 23 Mag 2020, 09:40 Sylwester Lachiewicz ha
> scritto:
>
> > +1
> >
> > sob., 23 maj 2020, 09:22 użytkownik Hervé BOUTEMY
> >
> > napisał:
> >
> > > Le vendredi 22 mai 2020, 02:13:16 CEST Olivier Lamy a écrit :
> > > > > + * discussions on Maven > 3.0.x (3.1 or 3.2 or 3.3? details still
> > > TDB) +
> > > > > Java 8 prerequisites
> > > >
> > > > Don't be shy Hervé we can definitely says >= 3.3.9 (at least you will
> > not
> > > > hear any objections from me :) )
> > >
> > > looking at our history https://maven.apache.org/docs/history.html,
> there
> > > is 1
> > > year between 3.1.max and 3.2.max then 1 year to 3.3.max: not so much
> > > and AFAIK, many people went from 3.0 to 3.3+
> > >
> > > looks a good idea to me: +1
> > >
> > > any objection?
> > >
> > > Regards,
> > >
> > > Hervé
> > >
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
>


--
-----
Arnaud Héritier
http://aheritier.net
Mail/GTalk: aheritier AT gmail DOT com
Twitter/Skype : aheritier
Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

michaelo
Am 2020-05-24 um 10:41 schrieb Olivier Lamy:

> On Sat, 23 May 2020 at 21:33, Robert Scholte <[hidden email]> wrote:
>
>> As discussed before: compatibility should either be 3.3.1 (since 3.3.0
>> didn't make it) or 3.5.0, we should not include the (highest) bugfix
>> version.
>>
> Great this means we can can rid of this hackhish refection stuff for
> aether...
>
> you mean we should support 3.3.1 3.3.3 and 3.3.9?
> by support I mean fixing security issues.
> so in this case what happen in case of a security issue for 3.3.1 do we
> have a to release 3.3.1.1 3.3.3.1 3.3.9.1
> Not sure I understand what we mean with support?
> anyway if we say all plugins must be at least 3.3.1 it's good progress

I think we have discussed this before as I have raised this at least
once this one. The upshot is that we try to support (in terms of API and
ABI) in Plugins and Components a huge variety of Maven versions, but
only the last stable minor branch of Maven receives fixes.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

olamy
@All
Can we update the compatibility plan document saying we support from 3.5.4
and 3.6.3.
plugins will use API from 3.5.4 and can use java8 from now (June 2020) .
As 3.7.0 is on his way (soon) supporting 3 series seems enough. (with 3.7.0
using java8)
@Robert
As you didn't answer, I wonder if you still have strong opinions?


On Sun, 24 May 2020 at 18:46, Michael Osipov <[hidden email]> wrote:

> Am 2020-05-24 um 10:41 schrieb Olivier Lamy:
> > On Sat, 23 May 2020 at 21:33, Robert Scholte <[hidden email]>
> wrote:
> >
> >> As discussed before: compatibility should either be 3.3.1 (since 3.3.0
> >> didn't make it) or 3.5.0, we should not include the (highest) bugfix
> >> version.
> >>
> > Great this means we can can rid of this hackhish refection stuff for
> > aether...
> >
> > you mean we should support 3.3.1 3.3.3 and 3.3.9?
> > by support I mean fixing security issues.
> > so in this case what happen in case of a security issue for 3.3.1 do we
> > have a to release 3.3.1.1 3.3.3.1 3.3.9.1
> > Not sure I understand what we mean with support?
> > anyway if we say all plugins must be at least 3.3.1 it's good progress
>
> I think we have discussed this before as I have raised this at least
> once this one. The upshot is that we try to support (in terms of API and
> ABI) in Plugins and Components a huge variety of Maven versions, but
> only the last stable minor branch of Maven receives fixes.
>


--
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy
Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

Anders Hammar
On Tue, May 26, 2020 at 8:37 AM Olivier Lamy <[hidden email]> wrote:

> On Tue, 26 May 2020 at 08:05, Robert Scholte <[hidden email]> wrote:
>
> > I think it is pretty impressive that we can say that our plugins still
> > support a wide range of Maven versions.
> >
> > So my vote will be 3.1.0
> >
>
> even if it doesn't happen that much my only concern is what we will do in
> case of security issue with 3.1.0 what versions will we have to fix?
> by saying we support 3.1.0 we must be clear (and it seems obvious to me) we
> will only release 3.1.2 in case of security issue (same with other 3.x.x
> series)
> but still this can be a lot to maintain/release etc... (well ok still in
> the very rare case of security issue)
>

It looks like we're back att the confusion what we're talking about. There
are two different aspects:
1. Minimum version for compatibility (in plugins)
2. What Maven version(s) do we support, i.e. provide (important) fixes for

Two very different things IMO. If our plugins are compatible with Maven
3.1.0 that DOES NOT mean we will provide fixes for Maven 3.1.x. Most
likely we will only provide (secuirty) fixes for the latest minor version
(currently 3.6).

/Anders


>
>
> >
> > Robert
> >
> > On 25-5-2020 22:53:47, Olivier Lamy <[hidden email]> wrote:
> > @All
> > Can we update the compatibility plan document saying we support from
> 3.5.4
> > and 3.6.3.
> > plugins will use API from 3.5.4 and can use java8 from now (June 2020) .
> > As 3.7.0 is on his way (soon) supporting 3 series seems enough. (with
> 3.7.0
> > using java8)
> > @Robert
> > As you didn't answer, I wonder if you still have strong opinions?
> >
> >
> > On Sun, 24 May 2020 at 18:46, Michael Osipov wrote:
> >
> > > Am 2020-05-24 um 10:41 schrieb Olivier Lamy:
> > > > On Sat, 23 May 2020 at 21:33, Robert Scholte
> > > wrote:
> > > >
> > > >> As discussed before: compatibility should either be 3.3.1 (since
> 3.3.0
> > > >> didn't make it) or 3.5.0, we should not include the (highest) bugfix
> > > >> version.
> > > >>
> > > > Great this means we can can rid of this hackhish refection stuff for
> > > > aether...
> > > >
> > > > you mean we should support 3.3.1 3.3.3 and 3.3.9?
> > > > by support I mean fixing security issues.
> > > > so in this case what happen in case of a security issue for 3.3.1 do
> we
> > > > have a to release 3.3.1.1 3.3.3.1 3.3.9.1
> > > > Not sure I understand what we mean with support?
> > > > anyway if we say all plugins must be at least 3.3.1 it's good
> progress
> > >
> > > I think we have discussed this before as I have raised this at least
> > > once this one. The upshot is that we try to support (in terms of API
> and
> > > ABI) in Plugins and Components a huge variety of Maven versions, but
> > > only the last stable minor branch of Maven receives fixes.
> > >
> >
> >
> > --
> > Olivier Lamy
> > http://twitter.com/olamy | http://linkedin.com/in/olamy
> >
>
>
> --
> Olivier Lamy
> http://twitter.com/olamy | http://linkedin.com/in/olamy
>
Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

olamy
On Tue, 26 May 2020 at 9:00 pm, Anders Hammar <[hidden email]> wrote:

> On Tue, May 26, 2020 at 8:37 AM Olivier Lamy <[hidden email]> wrote:
>
> > On Tue, 26 May 2020 at 08:05, Robert Scholte <[hidden email]>
> wrote:
> >
> > > I think it is pretty impressive that we can say that our plugins still
> > > support a wide range of Maven versions.
> > >
> > > So my vote will be 3.1.0
> > >
> >
> > even if it doesn't happen that much my only concern is what we will do in
> > case of security issue with 3.1.0 what versions will we have to fix?
> > by saying we support 3.1.0 we must be clear (and it seems obvious to me)
> we
> > will only release 3.1.2 in case of security issue (same with other 3.x.x
> > series)
> > but still this can be a lot to maintain/release etc... (well ok still in
> > the very rare case of security issue)
> >
>
> It looks like we're back att the confusion what we're talking about. There
> are two different aspects:
> 1. Minimum version for compatibility (in plugins)
> 2. What Maven version(s) do we support, i.e. provide (important) fixes for
>
> Two very different things IMO. If our plugins are compatible with Maven
> 3.1.0 that DOES NOT mean we will provide fixes for Maven 3.1.x. Most
> likely we will only provide (secuirty) fixes for the latest minor version
> (currently 3.6).


Yes it definitely makes sense and I have definitely missed a discussion
somewhere (sorry too much notifications spam :))

To avoid such confusion is it write somewhere? I’m happy if you can provide
a RTFM


> /Anders
>
>
> >
> >
> > >
> > > Robert
> > >
> > > On 25-5-2020 22:53:47, Olivier Lamy <[hidden email]> wrote:
> > > @All
> > > Can we update the compatibility plan document saying we support from
> > 3.5.4
> > > and 3.6.3.
> > > plugins will use API from 3.5.4 and can use java8 from now (June 2020)
> .
> > > As 3.7.0 is on his way (soon) supporting 3 series seems enough. (with
> > 3.7.0
> > > using java8)
> > > @Robert
> > > As you didn't answer, I wonder if you still have strong opinions?
> > >
> > >
> > > On Sun, 24 May 2020 at 18:46, Michael Osipov wrote:
> > >
> > > > Am 2020-05-24 um 10:41 schrieb Olivier Lamy:
> > > > > On Sat, 23 May 2020 at 21:33, Robert Scholte
> > > > wrote:
> > > > >
> > > > >> As discussed before: compatibility should either be 3.3.1 (since
> > 3.3.0
> > > > >> didn't make it) or 3.5.0, we should not include the (highest)
> bugfix
> > > > >> version.
> > > > >>
> > > > > Great this means we can can rid of this hackhish refection stuff
> for
> > > > > aether...
> > > > >
> > > > > you mean we should support 3.3.1 3.3.3 and 3.3.9?
> > > > > by support I mean fixing security issues.
> > > > > so in this case what happen in case of a security issue for 3.3.1
> do
> > we
> > > > > have a to release 3.3.1.1 3.3.3.1 3.3.9.1
> > > > > Not sure I understand what we mean with support?
> > > > > anyway if we say all plugins must be at least 3.3.1 it's good
> > progress
> > > >
> > > > I think we have discussed this before as I have raised this at least
> > > > once this one. The upshot is that we try to support (in terms of API
> > and
> > > > ABI) in Plugins and Components a huge variety of Maven versions, but
> > > > only the last stable minor branch of Maven receives fixes.
> > > >
> > >
> > >
> > > --
> > > Olivier Lamy
> > > http://twitter.com/olamy | http://linkedin.com/in/olamy
> > >
> >
> >
> > --
> > Olivier Lamy
> > http://twitter.com/olamy | http://linkedin.com/in/olamy
> >
>
--
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy
Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

Hervé BOUTEMY
In reply to this post by olamy
Le mardi 26 mai 2020, 00:05:39 CEST Robert Scholte a écrit :

> I missed the proposal for the version. I saw 3.2.5 and that can't be
> correct, hence I tried to explain what the correct version should be. So
> correct minimum version will be one of: 3.0, 3.1.0, 3.2.1, 3.3.1, 3.5.0
> This is the version we should compile with, our integration tests use the
> latest bugfix for all.
>
> Just like the discussions around what the minimum Java version should be,
> the same counts for the minimum Maven version.
>
> What is the benefit for version X? (Keep in mind, that every individual
> plugin may choose a different minimum in case a specific change/feature is
> required) 3.1.0 is very clear to me: switch to eclipse aether (package
> change) and JSR330 support for plugins. All others contain (close to) no
> changes to the API, so there's no real gain.
>
> By using higher versions of Maven you might force people to upgrade Maven or
> stick to old plugins in case they can't upgrade. I don't think it should be
> our plugins to enforce a higher version of Maven. Hence I don't see any
> reason to require 3.5.0 or 3.6.0.
>
> I think it is pretty impressive that we can say that our plugins still
> support a wide range of Maven versions.
>
> So my vote will be 3.1.0
ok for me

Regards,

Hervé

>
> Robert
>
> On 25-5-2020 22:53:47, Olivier Lamy <[hidden email]> wrote:
> @All
> Can we update the compatibility plan document saying we support from 3.5.4
> and 3.6.3.
> plugins will use API from 3.5.4 and can use java8 from now (June 2020) .
> As 3.7.0 is on his way (soon) supporting 3 series seems enough. (with 3.7.0
> using java8)
> @Robert
> As you didn't answer, I wonder if you still have strong opinions?
>
> On Sun, 24 May 2020 at 18:46, Michael Osipov wrote:
> > Am 2020-05-24 um 10:41 schrieb Olivier Lamy:
> > > On Sat, 23 May 2020 at 21:33, Robert Scholte
> >
> > wrote:
> > >> As discussed before: compatibility should either be 3.3.1 (since 3.3.0
> > >> didn't make it) or 3.5.0, we should not include the (highest) bugfix
> > >> version.
> > >
> > > Great this means we can can rid of this hackhish refection stuff for
> > > aether...
> > >
> > > you mean we should support 3.3.1 3.3.3 and 3.3.9?
> > > by support I mean fixing security issues.
> > > so in this case what happen in case of a security issue for 3.3.1 do we
> > > have a to release 3.3.1.1 3.3.3.1 3.3.9.1
> > > Not sure I understand what we mean with support?
> > > anyway if we say all plugins must be at least 3.3.1 it's good progress
> >
> > I think we have discussed this before as I have raised this at least
> > once this one. The upshot is that we try to support (in terms of API and
> > ABI) in Plugins and Components a huge variety of Maven versions, but
> > only the last stable minor branch of Maven receives fixes.
>
> --
> Olivier Lamy
> http://twitter.com/olamy | http://linkedin.com/in/olamy





---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]