Re: maven-site-plugin java8

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: maven-site-plugin java8

Karl Heinz Marbaise-3
Hi,

On 19.05.20 07:45, Olivier Lamy wrote:
> Hi
> Any objections for this PR
> https://github.com/apache/maven-site-plugin/pull/21 ?
> I prefer to ask rather than seeing my commit reverted

+1 from me.

Kind regards
Karl Heinz Marbaise

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: maven-site-plugin java8

Hervé BOUTEMY
Le mercredi 20 mai 2020, 10:10:12 CEST Olivier Lamy a écrit :

> Hervé,
>
> On Wed, 20 May 2020 at 17:06, Hervé BOUTEMY <[hidden email]> wrote:
> > instead of continuing discussion here and there about Maven and Java
> > prerequisites, I started to describe our past plan to work on defining our
> > future plan:
> > https://maven.apache.org/developers/compatibility-plan.html
>
> I do not discuss anything. I just ask for review/approval or not of a PR
> that's it.
> If you guys have different views... fair enough...
> Just approve or not approve the PR and voila.
> I don't want to have same discussions again and again as in the past.

as you wish

1. not in a bugfix version, like 3.9.1

2. is it an exception to our Java 7 current requirement, caused by some good
cause, still to be explained? (Maven Checkstyle Plugin being the current
example of such good cause)

3. is it a general plan on Java 8 requirement upgrade? If yes, please help
create the plan so we stop half discussions in multiple contexts: the Maven
prerequisite has to be part of the plan, for example

>
> > Don't hesitate to contribute
> >
> > on the future upgrade of prerequisites, one useful documentation for users
> > requiring to stay on earlier Java releases will be IMHO to not only put
> > current Java Version prerequisite but also the last release requiring
> > previous
> > Java versions.
> >
> > For example on plugin or components
> >
> >   https://maven.apache.org/plugins/maven-site-plugin/summary.html
> >
> > adding an additional section telling the last release compatible with Java
> > 7,
> > 6 or even 5: that should not be much documentation to add, and very useful
> > to
> > ease the current hard research anybody has to do when the last release of
> > a
> > component has a Java prerequisite that does not match your own
> > expectations
> > (without judging the expectations validity of component provider nor
> > consumer)
> >
> > Regards,
> >
> > Hervé
> >
> > Le mardi 19 mai 2020, 07:45:27 CEST Olivier Lamy a écrit :
> > > Hi
> > > Any objections for this PR
> > > https://github.com/apache/maven-site-plugin/pull/21 ?
> > > I prefer to ask rather than seeing my commit reverted
> > >
> > > cheers
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]





---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]