Re: [maven-site] branch master updated: few precisions

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [maven-site] branch master updated: few precisions

olamy
On Thu, 21 May 2020 at 16:43, <[hidden email]> wrote:

> This is an automated email from the ASF dual-hosted git repository.
>
> hboutemy pushed a commit to branch master
> in repository https://gitbox.apache.org/repos/asf/maven-site.git
>
>
> The following commit(s) were added to refs/heads/master by this push:
>      new 60bb862  few precisions
> 60bb862 is described below
>
> commit 60bb862225fd4b017c2cdd084a29ddafe0d1f641
> Author: Hervé Boutemy <[hidden email]>
> AuthorDate: Thu May 21 08:43:04 2020 +0200
>
>     few precisions
> ---
>  content/apt/developers/compatibility-plan.apt | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/content/apt/developers/compatibility-plan.apt
> b/content/apt/developers/compatibility-plan.apt
> index b370a31..17ed1c4 100644
> --- a/content/apt/developers/compatibility-plan.apt
> +++ b/content/apt/developers/compatibility-plan.apt
> @@ -44,11 +44,11 @@ Maven Compatibility Plan
>
>  * Maven Plan
>
> -  * Until ..., Maven 2.2.1 + Java 5 prerequisites, with plugins versions
> in 2.x
> +  * Until 2012?, Maven 2.2.1 + Java 5 prerequisites, with plugins
> versions in 2.x
>
> -  * Since ..., Maven 3.0 + Java 7 prerequisites, with plugins in 3.x
> +  * Since 2012?, Maven 3.0 + Java 7 prerequisites, with plugins in 3.x
>
> -  * Since ..., discussions on Maven 3.2.5? + Java 8 prerequisites
> +  * discussions on Maven > 3.0.x (3.1 or 3.2 or 3.3? details still TDB) +
> Java 8 prerequisites
>

Don't be shy Hervé we can definitely says >= 3.3.9 (at least you will not
hear any objections from me :) )


>
>  * Context
>
> @@ -56,7 +56,7 @@ Maven Compatibility Plan
>
>    * JDK/JRE support dates:
>
> -    * Java 5 is closed source, EOLed by binary providers on ...
> +    * Java 5 is closed source, End of Public Update in 2009
>
>      * Java 6 is Open Source, maintained at OpenJDK until ...
>
>
>

--
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy
Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

Elliotte Rusty Harold
I don't think I've seen anything earlier than 3.3.x in recent memory,
but 3.3.x is definitely still out there in the wild being used for new
development.

Given the massive amount of important work that remains to be done to
upgrade plugins to Maven 3.1 and Java 7, or even Maven 3 and Java 5, I
would hate to see people expending any energy on Java 8 right now. The
ROI on that migration is neutral at best and possibly negative if
people go all in on lambdas.

On Mon, May 25, 2020 at 4:53 PM Olivier Lamy <[hidden email]> wrote:

>
> @All
> Can we update the compatibility plan document saying we support from 3.5.4
> and 3.6.3.
> plugins will use API from 3.5.4 and can use java8 from now (June 2020) .
> As 3.7.0 is on his way (soon) supporting 3 series seems enough. (with 3.7.0
> using java8)
> @Robert
> As you didn't answer, I wonder if you still have strong opinions?
>
>
> On Sun, 24 May 2020 at 18:46, Michael Osipov <[hidden email]> wrote:
>
> > Am 2020-05-24 um 10:41 schrieb Olivier Lamy:
> > > On Sat, 23 May 2020 at 21:33, Robert Scholte <[hidden email]>
> > wrote:
> > >
> > >> As discussed before: compatibility should either be 3.3.1 (since 3.3.0
> > >> didn't make it) or 3.5.0, we should not include the (highest) bugfix
> > >> version.
> > >>
> > > Great this means we can can rid of this hackhish refection stuff for
> > > aether...
> > >
> > > you mean we should support 3.3.1 3.3.3 and 3.3.9?
> > > by support I mean fixing security issues.
> > > so in this case what happen in case of a security issue for 3.3.1 do we
> > > have a to release 3.3.1.1 3.3.3.1 3.3.9.1
> > > Not sure I understand what we mean with support?
> > > anyway if we say all plugins must be at least 3.3.1 it's good progress
> >
> > I think we have discussed this before as I have raised this at least
> > once this one. The upshot is that we try to support (in terms of API and
> > ABI) in Plugins and Components a huge variety of Maven versions, but
> > only the last stable minor branch of Maven receives fixes.
> >
>
>
> --
> Olivier Lamy
> http://twitter.com/olamy | http://linkedin.com/in/olamy



--
Elliotte Rusty Harold
[hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: next level of compatibility (was Re: [maven-site] branch master updated: few precisions)

olamy
On Tue, 26 May 2020 at 22:47, Elliotte Rusty Harold <[hidden email]>
wrote:

> I don't think I've seen anything earlier than 3.3.x in recent memory,
> but 3.3.x is definitely still out there in the wild being used for new
> development.
>
> Given the massive amount of important work that remains to be done to
> upgrade plugins to Maven 3.1 and Java 7, or even Maven 3 and Java 5, I
> would hate to see people expending any energy on Java 8 right now. The
> ROI on that migration is neutral at best and possibly negative if
> people go all in on lambdas.
>

it will be possible to use java8 but it's not mandatory.
Don't this feature about being able to java8 as a mandatory "we have to
migrate the code"
It's just when working on fixing bug or improving some parts you can or not
use java8.
lambdas can be nice in some cases by making code more readable.
I see this as a way to attract more people to contribute by using new java
language features.


>
> On Mon, May 25, 2020 at 4:53 PM Olivier Lamy <[hidden email]> wrote:
> >
> > @All
> > Can we update the compatibility plan document saying we support from
> 3.5.4
> > and 3.6.3.
> > plugins will use API from 3.5.4 and can use java8 from now (June 2020) .
> > As 3.7.0 is on his way (soon) supporting 3 series seems enough. (with
> 3.7.0
> > using java8)
> > @Robert
> > As you didn't answer, I wonder if you still have strong opinions?
> >
> >
> > On Sun, 24 May 2020 at 18:46, Michael Osipov <[hidden email]>
> wrote:
> >
> > > Am 2020-05-24 um 10:41 schrieb Olivier Lamy:
> > > > On Sat, 23 May 2020 at 21:33, Robert Scholte <[hidden email]>
> > > wrote:
> > > >
> > > >> As discussed before: compatibility should either be 3.3.1 (since
> 3.3.0
> > > >> didn't make it) or 3.5.0, we should not include the (highest) bugfix
> > > >> version.
> > > >>
> > > > Great this means we can can rid of this hackhish refection stuff for
> > > > aether...
> > > >
> > > > you mean we should support 3.3.1 3.3.3 and 3.3.9?
> > > > by support I mean fixing security issues.
> > > > so in this case what happen in case of a security issue for 3.3.1 do
> we
> > > > have a to release 3.3.1.1 3.3.3.1 3.3.9.1
> > > > Not sure I understand what we mean with support?
> > > > anyway if we say all plugins must be at least 3.3.1 it's good
> progress
> > >
> > > I think we have discussed this before as I have raised this at least
> > > once this one. The upshot is that we try to support (in terms of API
> and
> > > ABI) in Plugins and Components a huge variety of Maven versions, but
> > > only the last stable minor branch of Maven receives fixes.
> > >
> >
> >
> > --
> > Olivier Lamy
> > http://twitter.com/olamy | http://linkedin.com/in/olamy
>
>
>
> --
> Elliotte Rusty Harold
> [hidden email]
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

--
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy