Re: maven-antrun-plugin

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: maven-antrun-plugin

Enrico Olivelli
Shivaji
Sorry for late reply.
I have some troubles with my local env.

I will start working on it as soon as possible.

We have to check:
- pending blocker  tickets in JIRA
- pending pull requests
- upgrading dependencies and parent poms
- build ok on builds.apache.org

Then we are good to go.
Personally I am not familiar with this plugin but if the build is already
stable and we do not have showstoppers the release procedure is quite
straightforward

Please help me with the checklist above
I hope we can cut a release within a couple of week.

And other help is very appreciated
If any other committer that is used to use and work with this plugin wants
to pick this release up then it is worth to think about driving the release

Cheers

Il Gio 27 Feb 2020, 21:57 Shivaji Thanneeru <[hidden email]>
ha scritto:

> Enrico Olivelli
>
> Can you please release new version of maven-antrun plugin?
>
> Thanks,
>
> Shivaji Thanneeru
> 610-314-9159
>
>
>
> On Fri, Dec 20, 2019 at 11:45 AM Shivaji Thanneeru <
> [hidden email]> wrote:
>
>> Ok, no problem.
>>
>> On Fri, Dec 20, 2019 at 11:44 AM Enrico Olivelli <[hidden email]>
>> wrote:
>>
>>> Shivaji,
>>> Unfortunately I don't have time these days, I hope any other committer
>>> can volunteer
>>>
>>> If no one volunteers I can pick this up, but in January
>>>
>>> Enrico
>>>
>>> Il ven 20 dic 2019, 17:12 Shivaji Thanneeru <[hidden email]>
>>> ha scritto:
>>>
>>>> Hi,
>>>> MANTRUN-221 resolves a bug introduced by MANTRUN-178, where it
>>>> incorrectly
>>>> assumes that mavenProject.getProperties() will contain all properties
>>>> present in the session.  The PR is merged to master after it is
>>>> approved.
>>>> Please release the new version of maven-antrun-plugin as soon as
>>>> possible.
>>>>
>>>> Thanks,
>>>>
>>>> Shivaji Thanneeru
>>>> 610-314-9159
>>>>
>>>> --
>> Thanks,
>>
>> Shivaji Thanneeru
>> 610-314-9159
>>
>>
Reply | Threaded
Open this post in threaded view
|

Re: maven-antrun-plugin

Eric Lilja
No no, not at all, if you see my first reply in this thread, I am
personally in favor of moving to latest Ant for this plugin, even if it
requires Java 8!

- Eric L

On Sun, Mar 1, 2020 at 4:19 PM Enrico Olivelli <[hidden email]> wrote:

> Il Dom 1 Mar 2020, 16:04 Eric Lilja <[hidden email]> ha scritto:
>
> > Oh, so ant has already been bumped to 1.9.14 (released March 2019), which
> > is the highest version of Ant not requiring java 8?
> >
>
> For other plugins, like checkstyle, we are following the main dependency,
> so if ant moved to java8 I am fine with moving to java 8 this plugin as
> well
>
> Do you have a strong reason for keeping java7?
>
> Enrico
>
>
> > - Eric L
> >
> > On Sun, Mar 1, 2020 at 3:35 PM Elliotte Rusty Harold <[hidden email]
> >
> > wrote:
> >
> > > Deps look good except for org.apache.ant which is as high as it can go
> > > without requiring Java 8.
> > >
> > > --
> > > Elliotte Rusty Harold
> > > [hidden email]
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
>