Re: m-pmd-p - Upgrade to Maven 3

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: m-pmd-p - Upgrade to Maven 3

Robert Scholte-8
I would say no. Just keep it on 3(but do switch to 3 segments, i.e 3.9.0).  
Maven-site-plugin and maven-compiler-plugin suffered with the same issue,  
they were already on 3.x before they were Maven3-only.

IIRC there's a small list with plugins which couldn't follow this new  
convention.

Robert

On Sat, 28 Oct 2017 10:30:51 +0200, Andreas Dangel <[hidden email]>  
wrote:

> Hi,
>
> I'm working on MPMD-240 [1] and the current trunk version of the plugin
> is 3.9-SNAPSHOT.
>
> Shall I move its version to 4.0.0-SNAPSHOT? Other plugins where at 2.x
> before the maven 3 upgrade and moved to 3.0.0-SNAPSHOT afterwards.
>
> Is the matching major version of the plugin and maven version just a
> coincidence or actually required? Would it be any problem, that the next
> m-pmd-p would be 4.0.0?
>
> And one more question: 4.0.0-SNAPSHOT or 4.0-SNAPSHOT?
>
>
> Regards,
>
> Andreas
>
>
> [1] https://issues.apache.org/jira/browse/MPMD-240

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]