Re: aspectj compile got error with Generic Type in java 5

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: aspectj compile got error with Generic Type in java 5

Carlos Sanchez-2
Probably you need to use AspectJ 5 jar
There're some issues about that in JIRA
http://jira.codehaus.org/browse/MPASPECTJ

Try adding the aspectj 5 jar to your project.xml

On 6/2/05, Robert Nguyen <[hidden email]> wrote:

>  
>
> Hi Carlos,
>     I try to use maven:aspectj with my project. It is working fine if I am
> not declare generic data such as
>
> public List<String> l = new ArrayList<String>();
>
> this will give me the error below. I also try to download aspectjrt 5, but
> it does not help.
>
> I did not know how to report his error through the website, so I send you
> and email instead.
>
> Is there anything I can do to get this issue resolve.
>
> Thanks,
> Robert
>
> =============================================================
> aspectj:compile:
>     [iajc] ignored: -source 1.5 at
> [warning] couldn't find aspectjrt.jar on classpath, checked: d:\Maven
> 1.0.2\lib\endorsed\xerces-2.4.0.jar;d:\Maven
> 1.0.2\lib\endorsed\xml-apis-1.0.b2.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\rt.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\i18n.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\sunrsasign.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\jsse.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\jce.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\charsets.jar;C:\Program
> Files\Java\jdk1.5.0\jre\classes;C:\Program
> Files\Java\jdk1.5.0\jre\lib\ext\dnsns.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\ext\localedata.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\ext\sunjce_provider.jar;C:\Program
> Files\Java\jdk1.5.0\jre\lib\ext\sunpkcs11.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\fitnesse\jars\fitnesse-20050405.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\hibernate\jars\hibernate-3.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\antlr\jars\antlr-2.7.4.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\dom4j\jars\dom4j-1.4.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\commons-collections\jars\commons-collections-2.1.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\commons-logging\jars\commons-logging-1.0.4.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\commons-el\jars\commons-el-1.0.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\commons-lang\jars\commons-lang-2.0.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\c3p0\jars\c3p0-0.9.0-pre3.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\log4j\jars\log4j-1.2.9.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\ehcache\jars\ehcache-1.1.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\jta\jars\jta-1.0.1B.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\commons-io\jars\commons-io-1.0.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\dbunit\jars\dbunit-2.1.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\dtdparser\jars\dtdparser-1.21.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\junit\jars\junit-3.8.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\mysql\jars\mysql-connector-java-3.0.10-stable-bin.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\cglib\jars\cglib-full-2.0.2.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\maverick\jars\maverick-all-1.0.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\commons-validator\jars\commons-validator-1.1.4.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\servletapi\jars\javax.servlet.jsp-1.0.jar;C:\Documents
> and
> Settings\rnguyen\.maven\repository\aspectj\jars\aspectjrt-1.2.jar;D:\eclipse\workspace\testaj\target\classes
>
>        
> D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8
> [error] Syntax error on tokens, delete these tokens
> public List<String> l = new ArrayList<String>();
>            ^^^^^^
> D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8
> [error] Syntax error on token "<", ( expected
> public List<String> l = new ArrayList<String>();
>                                      
> D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8
> [error] Syntax error on token "(", invalid Expression
> public List<String> l = new ArrayList<String>();
>                                              
> MessageHolder:  (1 warning)  (3 error)
> [error   0]: error at public List<String> l = new ArrayList<String>();
>            ^^^^^^
> D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8:0
> Syntax error on tokens, delete these tokens
> [error   1]: error at public List<String> l = new ArrayList<String>();
>                                      
> D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8:0
> Syntax error on token "<", ( expected
> [error   2]: error at public List<String> l = new ArrayList<String>();
>                                              
> D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8:0
> Syntax error on token "(", invalid Expression
>  
>
> Robert Nguyen
> Senior Software Engineer
> Phone: 949.754.8401
>
> Quest Software
> 8001 Irvine Center Drive
> Irvine, CA 92618
> www.Quest.com
> Nasdaq: QSFT

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: aspectj compile got error with Generic Type in java 5

stéphane bouchet
Hi,
I am using Java 5 with AspectJ 1.5.0M2. in order to work with maven, i changed
the jars in my maven's repository from 1.2 to 1.5.0.

St?phane.

Carlos Sanchez a ?crit :

> Probably you need to use AspectJ 5 jar
> There're some issues about that in JIRA
> http://jira.codehaus.org/browse/MPASPECTJ
>
> Try adding the aspectj 5 jar to your project.xml
>
> On 6/2/05, Robert Nguyen <[hidden email]> wrote:
>
>>
>>
>>Hi Carlos,
>>    I try to use maven:aspectj with my project. It is working fine if I am
>>not declare generic data such as
>>
>>public List<String> l = new ArrayList<String>();
>>
>>this will give me the error below. I also try to download aspectjrt 5, but
>>it does not help.
>>
>>I did not know how to report his error through the website, so I send you
>>and email instead.
>>
>>Is there anything I can do to get this issue resolve.
>>
>>Thanks,
>>Robert
>>
>>=============================================================
>>aspectj:compile:
>>    [iajc] ignored: -source 1.5 at
>>[warning] couldn't find aspectjrt.jar on classpath, checked: d:\Maven
>>1.0.2\lib\endorsed\xerces-2.4.0.jar;d:\Maven
>>1.0.2\lib\endorsed\xml-apis-1.0.b2.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\rt.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\i18n.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\sunrsasign.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\jsse.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\jce.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\charsets.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\classes;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\ext\dnsns.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\ext\localedata.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\ext\sunjce_provider.jar;C:\Program
>>Files\Java\jdk1.5.0\jre\lib\ext\sunpkcs11.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\fitnesse\jars\fitnesse-20050405.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\hibernate\jars\hibernate-3.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\antlr\jars\antlr-2.7.4.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\dom4j\jars\dom4j-1.4.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\commons-collections\jars\commons-collections-2.1.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\commons-logging\jars\commons-logging-1.0.4.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\commons-el\jars\commons-el-1.0.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\commons-lang\jars\commons-lang-2.0.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\c3p0\jars\c3p0-0.9.0-pre3.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\log4j\jars\log4j-1.2.9.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\ehcache\jars\ehcache-1.1.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\jta\jars\jta-1.0.1B.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\commons-io\jars\commons-io-1.0.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\dbunit\jars\dbunit-2.1.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\dtdparser\jars\dtdparser-1.21.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\junit\jars\junit-3.8.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\mysql\jars\mysql-connector-java-3.0.10-stable-bin.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\cglib\jars\cglib-full-2.0.2.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\maverick\jars\maverick-all-1.0.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\commons-validator\jars\commons-validator-1.1.4.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\servletapi\jars\javax.servlet.jsp-1.0.jar;C:\Documents
>>and
>>Settings\rnguyen\.maven\repository\aspectj\jars\aspectjrt-1.2.jar;D:\eclipse\workspace\testaj\target\classes
>>
>>        
>>D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8
>>[error] Syntax error on tokens, delete these tokens
>>public List<String> l = new ArrayList<String>();
>>           ^^^^^^
>>D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8
>>[error] Syntax error on token "<", ( expected
>>public List<String> l = new ArrayList<String>();
>>                                    
>>D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8
>>[error] Syntax error on token "(", invalid Expression
>>public List<String> l = new ArrayList<String>();
>>                                            
>>MessageHolder:  (1 warning)  (3 error)
>>[error   0]: error at public List<String> l = new ArrayList<String>();
>>           ^^^^^^
>>D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8:0
>>Syntax error on tokens, delete these tokens
>>[error   1]: error at public List<String> l = new ArrayList<String>();
>>                                    
>>D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8:0
>>Syntax error on token "<", ( expected
>>[error   2]: error at public List<String> l = new ArrayList<String>();
>>                                            
>>D:\eclipse\workspace\testaj\src\test\junit\LoginView.java:8:0
>>Syntax error on token "(", invalid Expression
>>
>>
>>Robert Nguyen
>>Senior Software Engineer
>>Phone: 949.754.8401
>>
>>Quest Software
>>8001 Irvine Center Drive
>>Irvine, CA 92618
>>www.Quest.com
>>Nasdaq: QSFT
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]