Re: [VOTE] Release Apache Maven PMD Plugin version 3.9.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Maven PMD Plugin version 3.9.0

Karl Heinz Marbaise-3
Hi,

I have checked with the following:

Removing existing release test area...done.
Downloading release package
maven-pmd-plugin-3.9.0-source-release.zip...done.
Downloading sha1 package for
maven-pmd-plugin-3.9.0-source-release.zip...done.
Downloading md5 package maven-pmd-plugin-3.9.0-source-release.zip...done.
Filename: maven-pmd-plugin-3.9.0-source-release.zip..
    SHA1 Checksum :
         generated : 41cf7d1f3418af893f944aac78d5178608cf7c9c
              read : 41cf7d1f3418af893f944aac78d5178608cf7c9c from file
maven-pmd-plugin-3.9.0-source-release.zip.sha1
    Compare Result : ok.

    MD5 Checksum :
         generated : fd7e6944fe1debf9ed14ecdd52714ffd
              read : fd7e6944fe1debf9ed14ecdd52714ffd from file
maven-pmd-plugin-3.9.0-source-release.zip.md5
    Compare Result : ok.
Using the following Maven versions for testing
Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da;
2013-02-19 14:51:28+0100)
Apache Maven 3.1.1 (0728685237757ffbf44136acec0402957f723d9a; 2013-09-17
17:22:22+0200)
Apache Maven 3.2.5 (12a6b3acb947671f09b81f49094c53f426d8cea1;
2014-12-14T18:29:23+01:00)
Apache Maven 3.3.1 (cab6659f9874fa96462afef40fcf6bc033d58c1c;
2015-03-13T21:10:27+01:00)
Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5;
2015-11-10T17:41:47+01:00)
Apache Maven 3.5.0 (ff8f5e7444045639af65f6095c62210b5713f426;
2017-04-03T21:39:06+02:00)
Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
2017-10-18T09:58:13+02:00)
Apache Maven 3.5.3-SNAPSHOT (899f452522ab811872e09d2f863b3b05d58ae173;
2017-12-22T16:05:53+01:00)
Start testing...
jdk1.7.0_79.jdk
   apache-maven-3.0.5..Unpacking done.Building failed.
   apache-maven-3.1.1..Unpacking done.Building fine.
   apache-maven-3.2.5..Unpacking done.Building fine.
   apache-maven-3.3.1..Unpacking done.Building fine.
   apache-maven-3.3.9..Unpacking done.Building fine.
   apache-maven-3.5.0..Unpacking done.Building fine.
   apache-maven-3.5.2..Unpacking done.Building fine.
   apache-maven-3.5.3-SNAPSHOT..Unpacking done.Building fine.
jdk1.8.0_131.jdk
   apache-maven-3.0.5..Unpacking donBuilding failed.
   apache-maven-3.1.1..Unpacking done.Building fine.
   apache-maven-3.2.5..Unpacking done.Building fine.
   apache-maven-3.3.1..Unpacking done.Building fine.
   apache-maven-3.3.9..Unpacking done.Building fine.
   apache-maven-3.5.0..Unpacking done.Building fine.
   apache-maven-3.5.2..Unpacking done.Building fine.
   apache-maven-3.5.3-SNAPSHOT..Unpacking done.Building fine.
jdk1.8.0_144.jdk
   apache-maven-3.0.5..Unpacking done.Building failed.
   apache-maven-3.1.1..Unpacking donBuilding fine...
   apache-maven-3.2.5..Unpacking done.Building fine.
   apache-maven-3.3.1..Unpacking done.Building fine.
   apache-maven-3.3.9..Unpacking done.Building fine.
   apache-maven-3.5.0..Unpacking donBuilding fine...
   apache-maven-3.5.2..Unpacking done.Building fine.
   apache-maven-3.5.3-SNAPSHOT..Unpacking done.Building fine.
jdk-9.0.1.jdk
   apache-maven-3.0.5..Unpacking done.Building failed.
   apache-maven-3.1.1..Unpacking done.Building fine.
   apache-maven-3.2.5..Unpacking donBuilding fine...
   apache-maven-3.3.1..Unpacking done.Building fine.
   apache-maven-3.3.9..Unpacking done.Building fine.
   apache-maven-3.5.0..Unpacking done.Building fine.
   apache-maven-3.5.2..Unpacking done.Building fine.
   apache-maven-3.5.3-SNAPSHOT..Unpacking done.Building fine.


Only Maven 3.0.5 is failing over all JDK's..

The integration tests which is failing:
[ERROR] The following builds failed:
[ERROR] *  MPMD-244-logging/pom.xml

Furthermore the log of the failing part:
Running post-build script:
/Users/kama/maven-release-checker/test-area/jdk1.7.0_79.jdk/apache-maven-3.0.5/maven-pmd-plugin-3.9.0/target/it/MPMD-244-logging/verify.groovy
Assertion failed:

assert 2 == buildLog.text.count( "net.sourceforge.pmd.PMDException:
Error while parsing
${currentDir}/logging-enabled/src/main/java/BrokenFile.java" )
          |  |        |    |
                  |
          |  |        |    1
 
/Users/kama/maven-release-checker/test-area/jdk1.7.0_79.jdk/apache-maven-3.0.5/maven-pmd-plugin-3.9.0/target/it/MPMD-244-logging
          |  |        Apache Maven 3.0.5
(r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19 14:51:28+0100)
          |  |        Maven home: /usr/local/apache-maven-3.0.5
          |  |        Java version: 1.7.0_79, vendor: Oracle Corporation
          |  |        Java home:
/Library/Java/JavaVirtualMachines/jdk1.7.0_79.jdk/Contents/Home/jre
          |  |        Default locale: en_US, platform encoding: UTF-8
          |  |        OS name: "mac os x", version: "10.11.6", arch:
"x86_64", family: "mac"
          |  |        [INFO] Error stacktraces are turned on.
          |  |        [DEBUG] Reading global settings from
/usr/local/apache-maven-3.0.5/conf/settings.xml
          |  |        [DEBUG] Reading user settings from
/Users/kama/maven-release-checker/test-area/jdk1.7.0_79.jdk/apache-maven-3.0.5/maven-pmd-plugin-3.9.0/target/it/interpolated-settings.xml
          |  |        [DEBUG] Using local repository at
/Users/kama/maven-release-checker/test-area/jdk1.7.0_79.jdk/apache-maven-3.0.5/maven-pmd-plugin-3.9.0/target/local-repo
          |  |        [DEBUG] Using manager
EnhancedLocalRepositoryManager with priority 10 for
/Users/kama/maven-release-checker/test-area/jdk1.7.0_79.jdk/apache-maven-3.0.5/maven-pmd-plugin-3.9.0/target/local-repo
          |  |        [INFO] Scanning for projects...
          |  |        [DEBUG] Extension realms for project
org.apache.maven.plugins.pmd.its:MPMD-244-logging:pom:1.0-SNAPSHOT: (none)
          |  |        [DEBUG] Looking up lifecyle mappings for packaging
pom from ClassRealm[plexus.core, parent: null]

If you like I can offer log files...

I don't see this as release blocking ...

So +1 from me

Kind regards
Karl Heinz Marbaise

On 21/01/18 18:35, Andreas Dangel wrote:
---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]