Re: [VOTE] Release Apache Maven Enforcer Plugin version 3.0.0-M1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Maven Enforcer Plugin version 3.0.0-M1

Peter Ansell
The sha1 matches for me and the plugin (including requireJavaVersion)
works under both Oracle JDK 8+u131 and Oracle JDK 9+177.

Thanks,

Peter

On 27 July 2017 at 06:58, Robert Scholte <[hidden email]> wrote:

> Hi,
>
> We solved 14 issues:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317520&version=12330768&styleName=Text
>
> There are still a couple of issues left in JIRA:
> https://issues.apache.org/jira/issues/?jql=project%20%3D%2012317520%20AND%20status%20%3D%20Open%20ORDER%20BY%20key%20DESC%2C%20priority%20DESC
>
> Staging repo:
> https://repository.apache.org/content/repositories/maven-1349
> https://repository.apache.org/service/local/repositories/maven-1349/content/org/apache/maven/enforcer/enforcer/3.0.0-M1/enforcer-3.0.0-M1-source-release.zip
>
> Source release checksum(s):
> enforcer-3.0.0-M1-source-release.zip sha1:
> 20b6e4800bb6357a25db6da3bdacc45675b9b5c8
>
> Staging site:
> https://maven.apache.org/enforcer-archives/enforcer-LATEST/
>
> Guide to testing staged releases:
> https://maven.apache.org/guides/development/guide-testing-releases.html
>
> NOTE: this is a milestone release, because there are still some open issues
> which need to be fixed before the official 3.0.0.
> This release is mainly there to provide a Java9 compatible plugin (previous
> versions fail the build).
>
> Vote open for at least 72 hours.
>
> [ ] +1
> [ ] +0
> [ ] -1
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Maven Enforcer Plugin version 3.0.0-M1

rfscholte
Thanks for testing. Can I translate this to a +1 vote?

Robert

On Fri, 28 Jul 2017 02:04:40 +0200, Peter Ansell <[hidden email]>  
wrote:

> The sha1 matches for me and the plugin (including requireJavaVersion)
> works under both Oracle JDK 8+u131 and Oracle JDK 9+177.
>
> Thanks,
>
> Peter
>
> On 27 July 2017 at 06:58, Robert Scholte <[hidden email]> wrote:
>> Hi,
>>
>> We solved 14 issues:
>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317520&version=12330768&styleName=Text
>>
>> There are still a couple of issues left in JIRA:
>> https://issues.apache.org/jira/issues/?jql=project%20%3D%2012317520%20AND%20status%20%3D%20Open%20ORDER%20BY%20key%20DESC%2C%20priority%20DESC
>>
>> Staging repo:
>> https://repository.apache.org/content/repositories/maven-1349
>> https://repository.apache.org/service/local/repositories/maven-1349/content/org/apache/maven/enforcer/enforcer/3.0.0-M1/enforcer-3.0.0-M1-source-release.zip
>>
>> Source release checksum(s):
>> enforcer-3.0.0-M1-source-release.zip sha1:
>> 20b6e4800bb6357a25db6da3bdacc45675b9b5c8
>>
>> Staging site:
>> https://maven.apache.org/enforcer-archives/enforcer-LATEST/
>>
>> Guide to testing staged releases:
>> https://maven.apache.org/guides/development/guide-testing-releases.html
>>
>> NOTE: this is a milestone release, because there are still some open  
>> issues
>> which need to be fixed before the official 3.0.0.
>> This release is mainly there to provide a Java9 compatible plugin  
>> (previous
>> versions fail the build).
>>
>> Vote open for at least 72 hours.
>>
>> [ ] +1
>> [ ] +0
>> [ ] -1
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Release Apache Maven Enforcer Plugin version 3.0.0-M1

Manfred Moser-4
In reply to this post by Peter Ansell
Wow Karl! Very nice testing effort.

+1 from me (with less testing but still some ubuntu and osx based runs..)

Manfred

Karl Heinz Marbaise wrote on 2017-07-28 14:44:

> Hi,
>
> +1 from me.
>
>
> Tested with JDK 9+180 the following Maven versions:
>  o Maven 3.5.0, Maven 3.3.9, Maven 3.2.5, Maven 3.1.1, Maven 3.0.5
>
> Tested with JDK 1.8.0_144 the following Maven versions:
>  o Maven 3.5.0, Maven 3.3.9, Maven 3.2.5, Maven 3.1.1, Maven 3.0.5
> Tested with JDK 1.8.0_131, Maven 3.5.0, Maven 3.3.9
>
> Only got a warnings with JDK 9: Should be addressed for final 3.0.0...
>
> Running org.apache.maven.plugins.enforcer.TestDefaultEnforcementRuleHelper
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by
> org.mockito.cglib.core.ReflectUtils$2
> (file:/Users/kama/.m2/repository/org/mockito/mockito-core/1.9.5/mockito-core-1.9.5.jar)
>
> to method
> java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int,java.security.ProtectionDomain)
> WARNING: Please consider reporting this to the maintainers of
> org.mockito.cglib.core.ReflectUtils$2
> WARNING: Use --illegal-access=warn to enable warnings of further illegal
> reflective access operations
> WARNING: All illegal access operations will be denied in a future release
>
> Second:
> [INFO] --- maven-invoker-plugin:2.0.0:run (integration-test) @
> maven-enforcer-plugin ---
> [INFO] Building: always-fail/pom.xml
> [INFO] ..SUCCESS (2.7 s)
> [INFO] Building: always-fail-warn/pom.xml
> [INFO] run script verify.groovy
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by
> org.codehaus.groovy.reflection.CachedClass$3$1
> (file:/Users/kama/.m2/repository/org/codehaus/groovy/groovy/2.0.1/groovy-2.0.1.jar)
>
> to method java.lang.Object.finalize()
> WARNING: Please consider reporting this to the maintainers of
> org.codehaus.groovy.reflection.CachedClass$3$1
> WARNING: Use --illegal-access=warn to enable warnings of further illegal
> reflective access operations
> WARNING: All illegal access operations will be denied in a future release
> [INFO] ..SUCCESS (3.0 s)
>
> which is based on Maven Invoker Plugin 2.0.0 should be fine with Maven
> Invoker Plugin 3.0.0...
>
> Kind regards
> Karl Heinz Marbaise
>
> On 26/07/17 22:58, Robert Scholte wrote:
>> Hi,
>>
>> We solved 14 issues:
>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317520&version=12330768&styleName=Text
>>
>>
>>
>> There are still a couple of issues left in JIRA:
>> https://issues.apache.org/jira/issues/?jql=project%20%3D%2012317520%20AND%20status%20%3D%20Open%20ORDER%20BY%20key%20DESC%2C%20priority%20DESC
>>
>>
>>
>> Staging repo:
>> https://repository.apache.org/content/repositories/maven-1349
>> https://repository.apache.org/service/local/repositories/maven-1349/content/org/apache/maven/enforcer/enforcer/3.0.0-M1/enforcer-3.0.0-M1-source-release.zip
>>
>>
>>
>> Source release checksum(s):
>> enforcer-3.0.0-M1-source-release.zip sha1:
>> 20b6e4800bb6357a25db6da3bdacc45675b9b5c8
>>
>> Staging site:
>> https://maven.apache.org/enforcer-archives/enforcer-LATEST/
>>
>> Guide to testing staged releases:
>> https://maven.apache.org/guides/development/guide-testing-releases.html
>>
>> NOTE: this is a milestone release, because there are still some open
>> issues which need to be fixed before the official 3.0.0.
>> This release is mainly there to provide a Java9 compatible plugin
>> (previous versions fail the build).
>>
>> Vote open for at least 72 hours.
>>
>> [ ] +1
>> [ ] +0
>> [ ] -1
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>
> Mit freundlichem Gruß
> Karl-Heinz Marbaise
> --
> SoftwareEntwicklung Beratung Schulung    Tel.: +49 (0) 2405 / 415 893
> Dipl.Ing.(FH) Karl-Heinz Marbaise        USt.IdNr: DE191347579
> Hauptstrasse 177
> 52146 Würselen                           http://www.soebes.de
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...