Re: [VOTE] JDK 8 Minimum Requirement for Maven 3.7.0

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] JDK 8 Minimum Requirement for Maven 3.7.0

Romain Manni-Bucau
Le mar. 29 oct. 2019 à 22:24, Tibor Digana <[hidden email]> a
écrit :

> Karl, I am not happy with this short text because you did not say that we
> will turn the code to J8.
> There is a plugin automating this transformation.
> One man can do it in his private and that's it.
> Of course somebody has to execute performance tests.
>
> Without changing the code we would not be eligible for young Java
> contributors.
> The users can use JDK8-14 since we are not a blocker to use any JDK today
> but the topic should be about the code.
>

This is not fully true.
Typically today i took a j7 codebase and updated part of its API to j8 in
the area i was patching. This was great for my contribution and didnt need
to rewrite all the code.
New dev are not worse than us caude they know what are lambas, they will
understand loops and util classes so we dont need to worry about that, just
enabling them is already a huge step and not automating it but letting them
do is an opportunity for contributions.


> So, now it is a bit strange vote.
>
> On Tue, Oct 29, 2019 at 9:11 PM Karl Heinz Marbaise <[hidden email]>
> wrote:
>
> > Hi to all,
> >
> > based on the discusion this is the formal VOTE to lift the minimum of
> > Maven Core with version 3.7.0 to JDK 8 minimum.
> >
> > Vote open for at least 72 hours.
> >
> > [ ] +1
> > [ ] +0
> > [ ] -1
> >
> >
> > Kind regards
> > Karl Heinz Marbaise
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] JDK 8 Minimum Requirement for Maven 3.7.0

Hervé BOUTEMY
+1

Regards,

Hervé

Le mardi 29 octobre 2019, 21:11:33 CET Karl Heinz Marbaise a écrit :

> Hi to all,
>
> based on the discusion this is the formal VOTE to lift the minimum of
> Maven Core with version 3.7.0 to JDK 8 minimum.
>
> Vote open for at least 72 hours.
>
> [ ] +1
> [ ] +0
> [ ] -1
>
>
> Kind regards
> Karl Heinz Marbaise
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]





---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] JDK 8 Minimum Requirement for Maven 3.7.0

Gabriel Belingueres-2
In reply to this post by Romain Manni-Bucau
+1

Kind regards
Gabriel

El mar., 29 de octubre de 2019 17:11, Karl Heinz Marbaise <[hidden email]>
escribió:

> Hi to all,
>
> based on the discusion this is the formal VOTE to lift the minimum of
> Maven Core with version 3.7.0 to JDK 8 minimum.
>
> Vote open for at least 72 hours.
>
> [ ] +1
> [ ] +0
> [ ] -1
>
>
> Kind regards
> Karl Heinz Marbaise
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>