Re: [VOTE] Apache Maven Compiler 3.6.2

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Apache Maven Compiler 3.6.2

Hervé BOUTEMY
+1

Regards,

Hervé

Le mercredi 26 juillet 2017, 09:44:01 CEST Olivier Lamy a écrit :

> Hi,
> I'd like to release Apache Maven Compiler Plugin version 3.6.2.
>
> We fixed 3 issues:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317225&ve
> rsion=12339154
>
> Staging repo: https://repository.apache.org/content/repositories/maven-1348/
>
> Source release:
> *
> https://repository.apache.org/content/repositories/maven-1348/org/apache/mav
> en/plugins/maven-compiler-plugin/3.6.2/maven-compiler-plugin-3.6.2-source-re
> lease.zip
>
> Staging site:
> http://maven.apache.org/components/plugins-archives/maven-compiler-plugin-LA
> TEST/ Guide to testing staged releases:
> https://maven.apache.org/guides/development/guide-testing-releases.html
>
> Vote open for at least 72 hours.
>
> [ ] +1
> [ ] +0
> [ ] -1
>
> My +1
>
> Cheers



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Apache Maven Compiler 3.6.2

Karl Heinz Marbaise-3
Hi,

I have rechecked the whole log files (testing my release checker script
;-() of the runs and found the following for the JDK 9 tests:

And yes the error message is correct cause the "modules" in the JDK 9 is
a single file and not a directory...(was there change?)...


[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-compiler-plugin:3.6.2:compile
(default-compile) on project error-prone-compiler: Fatal error
compiling: CompilerException: InvocationTargetException:
java.nio.file.NotDirectoryException:
/Library/Java/JavaVirtualMachines/jdk1.9.0_ea+180.jdk/Contents/Home/lib/modules
-> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to
execute goal
org.apache.maven.plugins:maven-compiler-plugin:3.6.2:compile
(default-compile) on project error-prone-compiler: Fatal error compiling
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
        at
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
        at
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
        at
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
        at
org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
        at
org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
        at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)

Furthermore I found the following:

[parsing
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/Helloable.groovy
- #1/3]
[parsing
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyHello.groovy
- #2/3]
[parsing
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyMain.groovy
- #3/3]
[reading    groovy/lang/GroovyObject.class]
[reading    groovy/lang/MetaClass.class]
[analyzing
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/Helloable.groovy
- #1/3]
Annotation processing got disabled, since it requires a 1.6 compliant JVM
----------
1. ERROR in
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/Helloable.groovy
(at line 1)
        /*
        ^
[analyzing
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyHello.groovy
- #2/3]
[completed
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/Helloable.groovy
- #1/3]
[analyzing
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyMain.groovy
- #3/3]
[completed
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyHello.groovy
- #2/3]
[writing    GroovyMain.class - #1]
The type java.lang.Object cannot be resolved. It is indirectly
referenced from required .class files
----------
----------
2. ERROR in
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyHello.groovy
(at line 1)
        /*
        ^
The type java.lang.String cannot be resolved. It is indirectly
referenced from required .class files
----------
[completed
/Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyMain.groovy
- #3/3]
[3 units compiled]
[1 .class file generated]
[INFO] Compilation complete.  Compiled 3 files.
[DEBUG] incrementalBuildHelper#afterRebuildExecution
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :



So for JDK 9 there is a problem in there...

[INFO] --- maven-checkstyle-plugin:2.15:check (checkstyle-check) @
maven-compiler-plugin ---
[INFO] There is 1 error reported by Checkstyle 6.1.1 with
config/maven_checks.xml ruleset.
[INFO] Ignored 1 error, 0 violation remaining.
[INFO]
[INFO] --- maven-invoker-plugin:2.0.0:verify (integration-test) @
maven-compiler-plugin ---
[INFO] -------------------------------------------------
[INFO] Build Summary:
[INFO]   Passed: 36, Failed: 3, Errors: 0, Skipped: 0
[INFO] -------------------------------------------------
[ERROR] The following builds failed:
[ERROR] *  error-prone-compiler/pom.xml
[ERROR] *  groovy-project-with-new-plexus-compiler/pom.xml
[ERROR] *  MCOMPILER-197/pom.xml
[INFO] -------------------------------------------------
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 2:56.376s
[INFO] Finished at: Sun Jul 30 14:03:11 CEST 2017
[INFO] Final Memory: 37M/128M


Unfortunately my script handled that not correctly...;-(...(Needs
improvements)..

Kind regards
Karl Heinz Marbaise

On 29/07/17 15:44, Karl Heinz Marbaise wrote:

> Hi,
>
> Tested the following (via mvn -Prun-its clean verify)
>
> JDK 1.7.0_79: Maven 3.5.0, 3.3.9, 3.3.1, 3.2.5, 3.1.1, 3.0.5
> JDK 1.8.0_131: Maven 3.5.0, 3.3.9, 3.3.1, 3.2.5, 3.1.1, 3.0.5
> JDK 1.8.0_144: Maven 3.5.0, 3.3.9, 3.3.1, 3.2.5, 3.1.1, 3.0.5
> JDK 1.9.0EA+180: Maven 3.5.0, 3.3.9, 3.3.1, 3.2.5, 3.1.1, 3.0.5
>
> So +1 from me.
>
> Kind regards
> Karl Heinz Marbaise
>
> On 26/07/17 01:44, Olivier Lamy wrote:
>> Hi,
>> I'd like to release Apache Maven Compiler Plugin version 3.6.2.
>>
>> We fixed 3 issues:
>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317225&version=12339154 
>>
>>
>> Staging repo:
>> https://repository.apache.org/content/repositories/maven-1348/
>>
>> Source release:
>> *
>> https://repository.apache.org/content/repositories/maven-1348/org/apache/maven/plugins/maven-compiler-plugin/3.6.2/maven-compiler-plugin-3.6.2-source-release.zip 
>>
>>
>> Staging site:
>> http://maven.apache.org/components/plugins-archives/maven-compiler-plugin-LATEST/ 
>>
>> Guide to testing staged releases:
>> https://maven.apache.org/guides/development/guide-testing-releases.html
>>
>> Vote open for at least 72 hours.
>>
>> [ ] +1
>> [ ] +0
>> [ ] -1
>>
>> My +1
>>
>> Cheers
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [VOTE] Apache Maven Compiler 3.6.2

rfscholte
Hi,

All these tests are actually testing other libraries:

error-prone-compiler: <compilerId>javac-with-errorprone</compilerId>
groovy-project-with-new-plexus-compiler:  
<compilerId>groovy-eclipse-compiler</compilerId>
MCOMPILER-197: <Aopenjpa.metamodel>true</Aopenjpa.metamodel>

So it means that those libraries nor Java 9 ready, but the  
maven-compiler-plugin itself is.

Robert

On Sun, 30 Jul 2017 15:21:51 +0200, Karl Heinz Marbaise  
<[hidden email]> wrote:

> Hi,
>
> I have rechecked the whole log files (testing my release checker script  
> ;-() of the runs and found the following for the JDK 9 tests:
>
> And yes the error message is correct cause the "modules" in the JDK 9 is  
> a single file and not a directory...(was there change?)...
>
>
> [ERROR] Failed to execute goal  
> org.apache.maven.plugins:maven-compiler-plugin:3.6.2:compile  
> (default-compile) on project error-prone-compiler: Fatal error  
> compiling: CompilerException: InvocationTargetException:  
> java.nio.file.NotDirectoryException:  
> /Library/Java/JavaVirtualMachines/jdk1.9.0_ea+180.jdk/Contents/Home/lib/modules  
> -> [Help 1]
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to  
> execute goal  
> org.apache.maven.plugins:maven-compiler-plugin:3.6.2:compile  
> (default-compile) on project error-prone-compiler: Fatal error compiling
> at  
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:217)
> at  
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
> at  
> org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
> at  
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
> at  
> org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
> at  
> org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
> at  
> org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
> at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
> at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
> at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
>
> Furthermore I found the following:
>
> [parsing  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/Helloable.groovy  
> - #1/3]
> [parsing  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyHello.groovy  
> - #2/3]
> [parsing  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyMain.groovy  
> - #3/3]
> [reading    groovy/lang/GroovyObject.class]
> [reading    groovy/lang/MetaClass.class]
> [analyzing  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/Helloable.groovy  
> - #1/3]
> Annotation processing got disabled, since it requires a 1.6 compliant JVM
> ----------
> 1. ERROR in  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/Helloable.groovy  
> (at line 1)
> /*
> ^
> [analyzing  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyHello.groovy  
> - #2/3]
> [completed  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/Helloable.groovy  
> - #1/3]
> [analyzing  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyMain.groovy  
> - #3/3]
> [completed  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyHello.groovy  
> - #2/3]
> [writing    GroovyMain.class - #1]
> The type java.lang.Object cannot be resolved. It is indirectly  
> referenced from required .class files
> ----------
> ----------
> 2. ERROR in  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyHello.groovy  
> (at line 1)
> /*
> ^
> The type java.lang.String cannot be resolved. It is indirectly  
> referenced from required .class files
> ----------
> [completed  
> /Users/kama/maven-release-checker/release-test/jdk1.9.0_ea+180.jdk/apache-maven-3.0.5/maven-compiler-plugin-3.6.2/target/it/groovy-project-with-new-plexus-compiler/src/main/groovy/GroovyMain.groovy  
> - #3/3]
> [3 units compiled]
> [1 .class file generated]
> [INFO] Compilation complete.  Compiled 3 files.
> [DEBUG] incrementalBuildHelper#afterRebuildExecution
> [INFO] -------------------------------------------------------------
> [ERROR] COMPILATION ERROR :
>
>
>
> So for JDK 9 there is a problem in there...
>
> [INFO] --- maven-checkstyle-plugin:2.15:check (checkstyle-check) @  
> maven-compiler-plugin ---
> [INFO] There is 1 error reported by Checkstyle 6.1.1 with  
> config/maven_checks.xml ruleset.
> [INFO] Ignored 1 error, 0 violation remaining.
> [INFO]
> [INFO] --- maven-invoker-plugin:2.0.0:verify (integration-test) @  
> maven-compiler-plugin ---
> [INFO] -------------------------------------------------
> [INFO] Build Summary:
> [INFO]   Passed: 36, Failed: 3, Errors: 0, Skipped: 0
> [INFO] -------------------------------------------------
> [ERROR] The following builds failed:
> [ERROR] *  error-prone-compiler/pom.xml
> [ERROR] *  groovy-project-with-new-plexus-compiler/pom.xml
> [ERROR] *  MCOMPILER-197/pom.xml
> [INFO] -------------------------------------------------
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Total time: 2:56.376s
> [INFO] Finished at: Sun Jul 30 14:03:11 CEST 2017
> [INFO] Final Memory: 37M/128M
>
>
> Unfortunately my script handled that not correctly...;-(...(Needs  
> improvements)..
>
> Kind regards
> Karl Heinz Marbaise
>
> On 29/07/17 15:44, Karl Heinz Marbaise wrote:
>> Hi,
>>  Tested the following (via mvn -Prun-its clean verify)
>>  JDK 1.7.0_79: Maven 3.5.0, 3.3.9, 3.3.1, 3.2.5, 3.1.1, 3.0.5
>> JDK 1.8.0_131: Maven 3.5.0, 3.3.9, 3.3.1, 3.2.5, 3.1.1, 3.0.5
>> JDK 1.8.0_144: Maven 3.5.0, 3.3.9, 3.3.1, 3.2.5, 3.1.1, 3.0.5
>> JDK 1.9.0EA+180: Maven 3.5.0, 3.3.9, 3.3.1, 3.2.5, 3.1.1, 3.0.5
>>  So +1 from me.
>>  Kind regards
>> Karl Heinz Marbaise
>>  On 26/07/17 01:44, Olivier Lamy wrote:
>>> Hi,
>>> I'd like to release Apache Maven Compiler Plugin version 3.6.2.
>>>
>>> We fixed 3 issues:
>>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12317225&version=12339154 
>>> Staging repo:  
>>> https://repository.apache.org/content/repositories/maven-1348/
>>>
>>> Source release:
>>> *
>>> https://repository.apache.org/content/repositories/maven-1348/org/apache/maven/plugins/maven-compiler-plugin/3.6.2/maven-compiler-plugin-3.6.2-source-release.zip 
>>> Staging site:
>>> http://maven.apache.org/components/plugins-archives/maven-compiler-plugin-LATEST/ 
>>> Guide to testing staged releases:
>>> https://maven.apache.org/guides/development/guide-testing-releases.html
>>>
>>> Vote open for at least 72 hours.
>>>
>>> [ ] +1
>>> [ ] +0
>>> [ ] -1
>>>
>>> My +1
>>>
>>> Cheers
>>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...