Re: Unexpected dependency requirement when performing "package", but not "install"

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Unexpected dependency requirement when performing "package", but not "install"

Eric Lilja
I just wanted to mention that I saw that a pull request containing a fix
for this nuisance was made the same day I opened the ticket in Jira. This
is impressive and very much appreciated, so thank you for that! Hoping to
see this fix in the next milestone release of Surefire, then!

Have a great week!

- Eric L

On Thu, Oct 1, 2020 at 1:49 PM Eric Lilja <[hidden email]> wrote:

> I opened https://issues.apache.org/jira/browse/SUREFIRE-1850
>
> Thanks!
>
> - Eric L
>
> On Wed, Sep 30, 2020 at 11:30 PM Eric Lilja <[hidden email]> wrote:
>
>> Of course, I will do it when I get to the office tomorrow, thanks!
>>
>> - Eric L
>>
>> On Wed, Sep 30, 2020 at 5:51 PM Elliotte Rusty Harold <[hidden email]>
>> wrote:
>>
>>> Looks like we don't need that. Can you file a bug in Jira?
>>>
>>> On Wed, Sep 30, 2020 at 11:12 AM Eric Lilja <[hidden email]>
>>> wrote:
>>> >
>>> > Hello, I have to set up Maven on a system which is completely offline,
>>> > restricted to work on a few, select projects.
>>> >
>>> > During testing, everything initially looked good, I could perform "mvn
>>> > clean install" in all projects without issue, and could perform other
>>> > Maven-task as well, Intellij was happy, it could resolve all projects
>>> > fully, run all test cases etc, and did not complain about any missing
>>> > artifacts.
>>> >
>>> > However, then I noticed, almost by accident, that I couldn't do
>>> "package"
>>> > or "verify" (which was odd, since install works, which is a later
>>> phase!),
>>> > because then surefire (3.0.0-M5) would complain it was
>>> > missing org.apache.maven:maven-toolchain:jar:3.0-alpha-2 (or one of its
>>> > dependencies).
>>> >
>>> > Why Surefire would suddenly need that artifact (some old alpha from
>>> > 2009..), during package- or verify-phase feels weird to me since the
>>> later
>>> > phase, install, works, and install entails packaging and verification
>>> > (compile also works, btw)
>>> >
>>> > surefire-3.0.0-M3 also suffers from this issue...2.18.1 does not
>>> >
>>> > What's going on here? Is my analysis correct, that if I can do "mvn
>>> clean
>>> > install", then "mvn clean package" should not be an issue, since
>>> installs
>>> > entails packaging?
>>> >
>>> > For this exotic setup, we can easily work around this, obviously, but
>>> it
>>> > feels like a bug to me so I wanted to share it with you
>>> >
>>> > - Eric L
>>>
>>>
>>>
>>> --
>>> Elliotte Rusty Harold
>>> [hidden email]
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>