Re: Surefire 2.21 release date ?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Surefire 2.21 release date ?

Olivier Lamy
this build is failing:
https://builds.apache.org/view/M-R/view/Maven/job/surefire/job/SUREFIRE-1463/136/console
to be able to run with jdk9/10 we need to change enforcer jdk rule which is
currently <version>[1.8, 1.9)</version>
until this change we cannot build with 9/10 without skipping enforcer check
So if we want to build with 9/10 we must change that or remove this rule
which doesn't help for testing with new jdk....

On 10 February 2018 at 10:35, Tibor Digana <[hidden email]> wrote:

> If you could see my issues reported to INFRA you would see what is going
> on. I am currently running 23 parallel jobs, also supporting JDK10.
> If they run standalone there is no issue. Once the machine is overloaded 3
> or 4 problems happen nevertheless JDK is set.
> So from my side it is working on JDKs but I want to working on these few
> issues and change the concurrency in the build script.
> I will work on it this weekend.
> I will get back to you tomorrow evening.
>
> On Fri, Feb 9, 2018 at 11:51 PM, Olivier Lamy <[hidden email]> wrote:
>
> > On 9 February 2018 at 21:57, Enrico Olivelli <[hidden email]>
> wrote:
> >
> > > Il ven 9 feb 2018, 02:13 Olivier Lamy <[hidden email]> ha scritto:
> > >
> > > > On 8 February 2018 at 07:00, Hervé BOUTEMY <[hidden email]>
> > > wrote:
> > > >
> > > > > Le jeudi 8 février 2018, 06:45:24 CET Olivier Lamy a écrit :
> > > > > > Hi,
> > > > > > I'm looking now at having surefire/failsafe working with jdk10
> (yup
> > > > first
> > > > > > RC is expected really soon :-)
> > > > > > I can't get failsafe working with jdk10 because of a
> commons-lang3
> > > bug
> > > > > (see
> > > > > > https://issues.apache.org/jira/browse/SUREFIRE-1473 due to
> > > > > > https://issues.apache.org/jira/browse/LANG-1365)
> > > > > > So I simply upgraded to commons-lang3 but now it looks enforcer
> is
> > > > > > configured to enforce 1.6.
> > > > > > Well as I was thinking: 1.6 really in 2018?
> > > > > > So I created SUREFIRE-1474 and push it.
> > > > > > Let me know if you have any issues with that?
> > > > > no issue with that: if people want old JDK, they need old Maven
> > > Surefire
> > > > > Plugin
> > > > > version, that's quite natural
> > > > > Please just add a table in the plugin doc about which is the latest
> > > > > Surefire
> > > > > version that support which JDK
> > > > >
> > > >
> > > > where is the page?
> > > >
> > >
> > > Is it this one?
> > >
> > > https://cwiki.apache.org/confluence/display/MAVEN/Java+9+-+Jigsaw
> >
> >
> > not sure if it's this page. I was looking for one with a kind of matrix
> > saying jdk level for plugins etc...
> >
> >
> >
> > >
> > >
> > > Enrico
> > >
> > >
> >
> >
> >
> > >
> > > >
> > > > >
> > > > > Regards,
> > > > >
> > > > > Hervé
> > > > >
> > > > > > As jdk10 is very soon. I'm happy to release surefire ASAP now.
> > > > > >
> > > > > > WDYT?
> > > > > >
> > > > > > Cheers
> > > > > > Olivier
> > > > > >
> > > > > > On 4 February 2018 at 19:11, Enrico Olivelli <
> [hidden email]>
> > > > > wrote:
> > > > > > > Il dom 4 feb 2018, 19:38 Tibor Digana <[hidden email]>
> > ha
> > > > > scritto:
> > > > > > > > Hi Enrico,
> > > > > > > >
> > > > > > > > I have got working build script and got some issues on
> > > integration
> > > > > tests
> > > > > > >
> > > > > > > in
> > > > > > >
> > > > > > > > TestNG & Java 10.
> > > > > > > > See this CLI. I think the JaCoCo Agent property is the issue
> > > > because
> > > > > it
> > > > > > >
> > > > > > > is
> > > > > > >
> > > > > > > > not resolved. I will try to put an empty string in there.
> Maybe
> > > the
> > > > > > > > build
> > > > > > > > would pass.
> > > > > > >
> > > > > > > Thank you Tibor for the update. Unfortunately I don't have a
> > > Windows
> > > > > box
> > > > > > > to
> > > > > > > reproduce the issue.
> > > > > > >
> > > > > > > From the error I guess you are right
> > > > > > >
> > > > > > > Enrico
> > > > > > >
> > > > > > > > [windows-jdk10-maven3.5.x] [ERROR] Command was cmd.exe /X /C
> > > > > > > > "F:\jenkins\tools\java\jdk10-ea+37\bin\java ${jacoco.agent}
> > -jar
> > > > > > > >
> > > > > > > > C:\Users\jenkins\AppData\Local\Temp\1\
> > > surefire3375403847264435698\
> > > > > > >
> > > > > > > surefirebooter6458194328264691762.jar
> > > > > > >
> > > > > > > > C:\Users\jenkins\AppData\Local\Temp\1\
> > > surefire3375403847264435698
> > > > > > > > 2018-02-04T17-23-23_801-jvmRun1
> surefire15708374661287747855tm
> > p
> > > > > > > > surefire_015474024382399849038tmp"
> > > > > > > >
> > > > > > > >
> > > > > > > >
> > > > > > > > On Fri, Feb 2, 2018 at 12:23 AM, Tibor Digana <
> > > > > [hidden email]>
> > > > > > > >
> > > > > > > > wrote:
> > > > > > > > > It's ok, not annoying.
> > > > > > > > > The issue SUREFIRE-1374 is quite easy to workaround and
> > > therefore
> > > > > I am
> > > > > > > > > working on more difficult issue - the build process.
> > > > > > > > > So regarding build process I contacted our INFRA team and
> > found
> > > > the
> > > > > > > > > problem. Now the build is running in [1] and the build
> script
> > > is
> > > > in
> > > > > > >
> > > > > > > [2].
> > > > > > >
> > > > > > > > I
> > > > > > > >
> > > > > > > > > should get this working first. We are testing JDK 7, 8, 9,
> 10
> > > on
> > > > > Linux
> > > > > > > >
> > > > > > > > and
> > > > > > > >
> > > > > > > > > Windows and Maven 3.2 - 3.5.
> > > > > > > > >
> > > > > > > > > [1]: https://builds.apache.org/
> > view/M-R/view/Maven/job/maven->
> > > >
> > > > > > > surefire-pipeline/job/SUREFIRE-1463/
> > > > > > > > > [2]: https://github.com/apache/
> maven-surefire/blob/SUREFIRE-
> > >
> > > >
> > > > >
> > > > > > 1463/Jenkinsfile
> > > > > > > > >
> > > > > > > > >
> > > > > > > > > On Thu, Feb 1, 2018 at 1:55 PM, Enrico Olivelli <
> > > > > [hidden email]>
> > > > > > > > >
> > > > > > > > > wrote:
> > > > > > > > >> Sorry, I don't want to annoy.
> > > > > > > > >> I see that SUREFIRE-1374 needs feedback from users.
> > > > > > > > >> I took a look but I don't know how to move forward that
> > issue
> > > > > > > > >>
> > > > > > > > >> Is it a blocker for 2.21 release ? o can it be post-poned
> to
> > > > 2.2 ?
> > > > > > > > >>
> > > > > > > > >> 2.21 is a great milestone to move people to Java 9
> > > > > > > > >>
> > > > > > > > >> -- Enrico
> > > > > > > > >>
> > > > > > > > >> 2018-01-23 17:49 GMT+01:00 Enrico Olivelli <
> > > [hidden email]
> > > > >:
> > > > > > > > >> > 2018-01-16 21:26 GMT+01:00 Enrico Olivelli <
> > > > [hidden email]
> > > > > >:
> > > > > > > > >> >> Il gio 11 gen 2018, 22:26 Tibor Digana <
> > > > [hidden email]>
> > > > > ha
> > > > > > > > >> >>
> > > > > > > > >> >> scritto:
> > > > > > > > >> >>> I was busy at work but now I am free.
> > > > > > > > >> >>> I need to have a help with investigating a bug
> > > > > > > > >> >>> https://issues.apache.org/jira/browse/SUREFIRE-1450
> > > > > > > > >>
> > > > > > > > >> >>> I should fix branches which are already in progress:
> > > > > > > > >> UnicodeTestNamesIT
> > > > > > > > >>
> > > > > > > > >> >>> and
> > > > > > > > >> >>> JaCoCO (SUREFIRE-1455).
> > > > > > > > >> >
> > > > > > > > >> > Tibor
> > > > > > > > >> >
> > > > > > > > >> > I see that now SUREFIRE-1455 (JaCoCo) is closed
> > > > > > > > >> > https://issues.apache.org/jira/browse/SUREFIRE-1455
> > > > > > > > >> >
> > > > > > > > >> > And I see that SUREFIRE-1461 about UnicodeTestNamesIT is
> > > > closed
> > > > > too
> > > > > > > > >> > https://issues.apache.org/jira/browse/SUREFIRE-1461
> > > > > > > > >> >
> > > > > > > > >> >
> > > > > > > > >> > It seems that for 2.21 there is only one task open
> > > > > > > > >> >
> > > > > > > > >> > https://issues.apache.org/
> jira/browse/SUREFIRE-1374?jql=
> > > > > > > > >> > project%20%3D%20SUREFIRE%20AND%20status%20in%20(Open%
> > > > > > > > >> > 2C%20%22In%20Progress%22%2C%20Reopened)%20AND%
> > 20fixVersion%
> > > > > > > > >>
> > > > > > > > >> 20%3D%202.21.0.
> > > > > > > > >>
> > > > > > > > >> > Jigsaw
> > > > > > > > >> >
> > > > > > > > >> > Do you need some help ?
> > > > > > > > >> > I am looking forward a release of 2.21
> > > > > > > > >> >
> > > > > > > > >> > Thank you
> > > > > > > > >> > Enrico
> > > > > > > > >> >
> > > > > > > > >> >> I can pick one on these, just tell me which is the best
> > > > > > > > >> >>
> > > > > > > > >> >> Then all ITs setup with JDK 9.
> > > > > > > > >> >>
> > > > > > > > >> >>> On Wed, Jan 10, 2018 at 11:17 AM, Enrico Olivelli <
> > > > > > > > >>
> > > > > > > > >> [hidden email]>
> > > > > > > > >>
> > > > > > > > >> >>> wrote:
> > > > > > > > >> >>> > (resending)
> > > > > > > > >> >>> >
> > > > > > > > >> >>> > Hi Tibor,
> > > > > > > > >> >>> > Do you have any plan about the release date of
> > surefire
> > > > > 2.21.0
> > > > > > > > >> >>> > ?
> > > > > > > > >> >>> >
> > > > > > > > >> >>> > If you have some tasks to do I will be happy to
> help.
> > > > > > > > >> >>> >
> > > > > > > > >> >>> > Cheers
> > > > > > > > >> >>> >
> > > > > > > > >> >>> > Enrico
> > > > > > > > >> >>
> > > > > > > > >> >> --
> > > > > > > > >> >>
> > > > > > > > >> >>
> > > > > > > > >> >> -- Enrico Olivelli
> > > > > > >
> > > > > > > --
> > > > > > >
> > > > > > >
> > > > > > > -- Enrico Olivelli
> > > > >
> > > > >
> > > > >
> > > > > ------------------------------------------------------------
> > ---------
> > > > > To unsubscribe, e-mail: [hidden email]
> > > > > For additional commands, e-mail: [hidden email]
> > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Olivier Lamy
> > > > http://twitter.com/olamy | http://linkedin.com/in/olamy
> > > >
> > >
> > >
> > > --
> > >
> > >
> > > -- Enrico Olivelli
> > >
> >
> >
> >
> > --
> > Olivier Lamy
> > http://twitter.com/olamy | http://linkedin.com/in/olamy
> >
>



--
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy