Re: Question: EoL for Maven 3.0.5

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Question: EoL for Maven 3.0.5

Karl Heinz Marbaise-3
Hi Robert,

On 17/08/18 12:07, Robert Scholte wrote:
> Hi Karl Heinz,
>
> Maven 3.0.5 is already EOL, meaning we don't develop on it anymore.

In the way you describe yes of course, but we haven't yet officially
announced that...

> If you talk about plugins supporting Maven 3 (not 3.0.5!), that's up to
> the plugin.
> In general I don't think there are that much API changes that will break
> the plugin.

No this is not what I'm talking about.. Keeping 3 compatiblity is just
fine.... only a few exceptions we might need to reconsider...but this is
a different thread.

>
> Assuming you're talking about maven-install-plugin and
> maven-deploy-plugin, the question should be:
> Can we require at least Maven 3.1.0 for these plugins so we can drop
> maven-artifact-transfer and simply use Eclipse Aether?

No...Ok yes patially but I wouldn't drop maven-artifact-transfer cause
using Eclipse Aether isn't that simple as the word "simply" implies...

Using maven-artifact-transfer makes it easier in plugins and extentions
to handle different scenarios....and prevents code duplications etc.

and no I woudln't say to require Maven 3.1.0 as minimum, cause we have
not yet lifted all plugins to Maven 3 minimum....

That would be the next step after a Time (which might be discussed about
what amount of time we think it makes sense) of Announcing 3.0.5 EoL...

> This is for me a valid case to ask this question, for most others I'd
> like to stay Maven 3.0 compatible when possible, it makes communication
> a LOT easier :)

Yes of course.

Kind regards
Karl Heinz Marbaise

>
> Robert
>
> On Fri, 17 Aug 2018 11:56:48 +0200, Karl Heinz Marbaise
> <[hidden email]> wrote:
>
>> Hi to all,
>>
>> based on looking on the history of released I thought about EoL for
>> Maven 3.0.5 ..
>>
>> The question is: What do you think about it?
>>
>> Kind regards
>> Karl Heinz Marbaise
>>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Question: EoL for Maven 3.0.5

rfscholte
Hi Karl Heinz,

AFAIK we've only talked about EOL when we had to backport code.
Once we decide to stop backporting code on the old version, we should  
announce that.
Right now we're not in such a situation.

thanks,
Robert

On Sun, 19 Aug 2018 11:24:06 +0200, Karl Heinz Marbaise  
<[hidden email]> wrote:

> Hi Robert,
>
> On 17/08/18 12:07, Robert Scholte wrote:
>> Hi Karl Heinz,
>>  Maven 3.0.5 is already EOL, meaning we don't develop on it anymore.
>
> In the way you describe yes of course, but we haven't yet officially  
> announced that...
>
>> If you talk about plugins supporting Maven 3 (not 3.0.5!), that's up to  
>> the plugin.
>> In general I don't think there are that much API changes that will  
>> break the plugin.
>
> No this is not what I'm talking about.. Keeping 3 compatiblity is just  
> fine.... only a few exceptions we might need to reconsider...but this is  
> a different thread.
>
>>  Assuming you're talking about maven-install-plugin and  
>> maven-deploy-plugin, the question should be:
>> Can we require at least Maven 3.1.0 for these plugins so we can drop  
>> maven-artifact-transfer and simply use Eclipse Aether?
>
> No...Ok yes patially but I wouldn't drop maven-artifact-transfer cause  
> using Eclipse Aether isn't that simple as the word "simply" implies...
>
> Using maven-artifact-transfer makes it easier in plugins and extentions  
> to handle different scenarios....and prevents code duplications etc.
>
> and no I woudln't say to require Maven 3.1.0 as minimum, cause we have  
> not yet lifted all plugins to Maven 3 minimum....
>
> That would be the next step after a Time (which might be discussed about  
> what amount of time we think it makes sense) of Announcing 3.0.5 EoL...
>
>> This is for me a valid case to ask this question, for most others I'd  
>> like to stay Maven 3.0 compatible when possible, it makes communication  
>> a LOT easier :)
>
> Yes of course.
>
> Kind regards
> Karl Heinz Marbaise
>
>>  Robert
>>  On Fri, 17 Aug 2018 11:56:48 +0200, Karl Heinz Marbaise  
>> <[hidden email]> wrote:
>>
>>> Hi to all,
>>>
>>> based on looking on the history of released I thought about EoL for  
>>> Maven 3.0.5 ..
>>>
>>> The question is: What do you think about it?
>>>
>>> Kind regards
>>> Karl Heinz Marbaise
>>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Question: EoL for Maven 3.0.5

Olivier Lamy
In reply to this post by Karl Heinz Marbaise-3
+1

On Wed, 12 Sep 2018 at 18:00, Tibor Digana
<[hidden email]> wrote:

> Hi all,
>
> I would like to have Maven 3.1.1 instead in our Jenkins and env script of
> Groovy on GitBox.
> What is your opinion and needs?
>
> Tibor
>
> On Sun, Aug 19, 2018 at 11:24 AM Karl Heinz Marbaise <[hidden email]>
> wrote:
>
> > Hi Robert,
> >
> > On 17/08/18 12:07, Robert Scholte wrote:
> > > Hi Karl Heinz,
> > >
> > > Maven 3.0.5 is already EOL, meaning we don't develop on it anymore.
> >
> > In the way you describe yes of course, but we haven't yet officially
> > announced that...
> >
> > > If you talk about plugins supporting Maven 3 (not 3.0.5!), that's up to
> > > the plugin.
> > > In general I don't think there are that much API changes that will
> break
> > > the plugin.
> >
> > No this is not what I'm talking about.. Keeping 3 compatiblity is just
> > fine.... only a few exceptions we might need to reconsider...but this is
> > a different thread.
> >
> > >
> > > Assuming you're talking about maven-install-plugin and
> > > maven-deploy-plugin, the question should be:
> > > Can we require at least Maven 3.1.0 for these plugins so we can drop
> > > maven-artifact-transfer and simply use Eclipse Aether?
> >
> > No...Ok yes patially but I wouldn't drop maven-artifact-transfer cause
> > using Eclipse Aether isn't that simple as the word "simply" implies...
> >
> > Using maven-artifact-transfer makes it easier in plugins and extentions
> > to handle different scenarios....and prevents code duplications etc.
> >
> > and no I woudln't say to require Maven 3.1.0 as minimum, cause we have
> > not yet lifted all plugins to Maven 3 minimum....
> >
> > That would be the next step after a Time (which might be discussed about
> > what amount of time we think it makes sense) of Announcing 3.0.5 EoL...
> >
> > > This is for me a valid case to ask this question, for most others I'd
> > > like to stay Maven 3.0 compatible when possible, it makes communication
> > > a LOT easier :)
> >
> > Yes of course.
> >
> > Kind regards
> > Karl Heinz Marbaise
> >
> > >
> > > Robert
> > >
> > > On Fri, 17 Aug 2018 11:56:48 +0200, Karl Heinz Marbaise
> > > <[hidden email]> wrote:
> > >
> > >> Hi to all,
> > >>
> > >> based on looking on the history of released I thought about EoL for
> > >> Maven 3.0.5 ..
> > >>
> > >> The question is: What do you think about it?
> > >>
> > >> Kind regards
> > >> Karl Heinz Marbaise
> > >>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
> --
> Cheers
> Tibor
>


--
Olivier Lamy
http://twitter.com/olamy | http://linkedin.com/in/olamy
Reply | Threaded
Open this post in threaded view
|

Re: Question: EoL for Maven 3.0.5

Sylwester Lachiewicz
Hi,
i’m also thinking about required minimum Maven version to something more
than 3.0 - to migrate to 3.x and use SLF4j and JSR-330 features (3.1) in
plugins.

Sylwester

[1] If you want to use JSR-330, you must understand that your code won't be
compatible with Maven 2 or 3.0.x but only with Maven 3.1.0+: even if
JSR-330 is available in core since Maven 3.0-beta-3, it was made available
to plugins and extensions only in Maven 3.1.0 (MNG-5343).

[2] https://maven.apache.org/maven-logging.html




czw., 13 wrz 2018 o 01:37 użytkownik Olivier Lamy <[hidden email]>
napisał:

> +1
>
> On Wed, 12 Sep 2018 at 18:00, Tibor Digana
> <[hidden email]> wrote:
>
> > Hi all,
> >
> > I would like to have Maven 3.1.1 instead in our Jenkins and env script of
> > Groovy on GitBox.
> > What is your opinion and needs?
> >
> > Tibor
> >
> > On Sun, Aug 19, 2018 at 11:24 AM Karl Heinz Marbaise <[hidden email]>
> > wrote:
> >
> > > Hi Robert,
> > >
> > > On 17/08/18 12:07, Robert Scholte wrote:
> > > > Hi Karl Heinz,
> > > >
> > > > Maven 3.0.5 is already EOL, meaning we don't develop on it anymore.
> > >
> > > In the way you describe yes of course, but we haven't yet officially
> > > announced that...
> > >
> > > > If you talk about plugins supporting Maven 3 (not 3.0.5!), that's up
> to
> > > > the plugin.
> > > > In general I don't think there are that much API changes that will
> > break
> > > > the plugin.
> > >
> > > No this is not what I'm talking about.. Keeping 3 compatiblity is just
> > > fine.... only a few exceptions we might need to reconsider...but this
> is
> > > a different thread.
> > >
> > > >
> > > > Assuming you're talking about maven-install-plugin and
> > > > maven-deploy-plugin, the question should be:
> > > > Can we require at least Maven 3.1.0 for these plugins so we can drop
> > > > maven-artifact-transfer and simply use Eclipse Aether?
> > >
> > > No...Ok yes patially but I wouldn't drop maven-artifact-transfer cause
> > > using Eclipse Aether isn't that simple as the word "simply" implies...
> > >
> > > Using maven-artifact-transfer makes it easier in plugins and extentions
> > > to handle different scenarios....and prevents code duplications etc.
> > >
> > > and no I woudln't say to require Maven 3.1.0 as minimum, cause we have
> > > not yet lifted all plugins to Maven 3 minimum....
> > >
> > > That would be the next step after a Time (which might be discussed
> about
> > > what amount of time we think it makes sense) of Announcing 3.0.5 EoL...
> > >
> > > > This is for me a valid case to ask this question, for most others I'd
> > > > like to stay Maven 3.0 compatible when possible, it makes
> communication
> > > > a LOT easier :)
> > >
> > > Yes of course.
> > >
> > > Kind regards
> > > Karl Heinz Marbaise
> > >
> > > >
> > > > Robert
> > > >
> > > > On Fri, 17 Aug 2018 11:56:48 +0200, Karl Heinz Marbaise
> > > > <[hidden email]> wrote:
> > > >
> > > >> Hi to all,
> > > >>
> > > >> based on looking on the history of released I thought about EoL for
> > > >> Maven 3.0.5 ..
> > > >>
> > > >> The question is: What do you think about it?
> > > >>
> > > >> Kind regards
> > > >> Karl Heinz Marbaise
> > > >>
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
> > --
> > Cheers
> > Tibor
> >
>
>
> --
> Olivier Lamy
> http://twitter.com/olamy | http://linkedin.com/in/olamy
>
Reply | Threaded
Open this post in threaded view
|

Re: Question: EoL for Maven 3.0.5

Karl Heinz Marbaise-3
In reply to this post by Karl Heinz Marbaise-3
Hi,

On 15/09/18 13:40, Elliotte Rusty Harold wrote:
> Does deprecation of a release include purging info about the old
> versions from maven-site? I frequently find mentions of things that
> are true in Maven 2 scattered across the pages.

 From my point of view it should be removed cause Maven 2 is long time
EoL ...so the information should be updated to represent Maven 3+..

So if you found such things it would be good to give a hint (or create a
JIRA ticket for it or create PR for it) to fix it...

Kind regards
Karl Heinz Marbaise

>
> On Sat, Sep 15, 2018 at 2:10 AM, Tibor Digana <[hidden email]> wrote:
>> +1 for EOL 3.0.5
>> +1 for EOL of entire Java 5 release including Maven 3.1.x
>> If the only 3.0.5 would be deprecated, then pls use 3.1.x.
>> If we do not support 3.1.x in CI then we have to start of deprecating 3.1.x.
>> So decide, because user may use 3.1.x and we should use it in CI as well;
>> or not to use either.
>>
>> On Fri, Aug 17, 2018 at 11:56 AM Karl Heinz Marbaise <[hidden email]>
>> wrote:
>>
>>> Hi to all,
>>>
>>> based on looking on the history of released I thought about EoL for
>>> Maven 3.0.5 ..
>>>
>>> The question is: What do you think about it?
>>>
>>> Kind regards
>>> Karl Heinz Marbaise

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]