Re: Question: EoL for Maven 3.0.5

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Question: EoL for Maven 3.0.5

Robert Scholte-8
Hi Karl Heinz,

Maven 3.0.5 is already EOL, meaning we don't develop on it anymore.
If you talk about plugins supporting Maven 3 (not 3.0.5!), that's up to  
the plugin.
In general I don't think there are that much API changes that will break  
the plugin.

Assuming you're talking about maven-install-plugin and  
maven-deploy-plugin, the question should be:
Can we require at least Maven 3.1.0 for these plugins so we can drop  
maven-artifact-transfer and simply use Eclipse Aether?
This is for me a valid case to ask this question, for most others I'd like  
to stay Maven 3.0 compatible when possible, it makes communication a LOT  
easier :)

Robert

On Fri, 17 Aug 2018 11:56:48 +0200, Karl Heinz Marbaise  
<[hidden email]> wrote:

> Hi to all,
>
> based on looking on the history of released I thought about EoL for  
> Maven 3.0.5 ..
>
> The question is: What do you think about it?
>
> Kind regards
> Karl Heinz Marbaise
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]