Re: Process maven mdo files via ModelloCLI

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Process maven mdo files via ModelloCLI

herve.boutemy
Hi William,

Debian already worked on this: I don't precisely know how they did, but you
should probably have a look.

A few hints on your investigations:
- on the .mdo files in plexus-containers, I added them only to generate
documentation [1], then you can just ignore that ones
- are you using the old Ant build file, that was used to bootstrap Maven?

Regards,

Hervé

[1] http://codehaus-plexus.github.io/plexus-containers/plexus-container-default/plexus-components.html
http://codehaus-plexus.github.io/plexus-containers/plexus-container-default/
plexus-configuration.html

Le jeudi 23 août 2018, 03:21:53 CEST William L. Thomson Jr. a écrit :

> On Thu, 14 Jun 2018 10:41:14 -0400
>
> "William L. Thomson Jr." <[hidden email]> wrote:
> > I have been working on packaging and building Maven from source on
> > Gentoo. Without using Maven, just straight javac, etc.  It is looking
> > like I cannot do this without using pre-generated sources on Maven
> > Central. I am having issues with ModelloCLI loading plugins.
> > https://github.com/codehaus-plexus/modello/issues/15
> >
> > Even more interesting, seems to be a chicken/egg situation with parts
> > of Plexus. Which also has mdo files.
> > https://github.com/codehaus-plexus/plexus-containers/tree/plexus-container
> > s-1.x/plexus-container-default/src/main/mdo
> Working on actually making my maven packages usable per user
> interest.[1][2] I think I may have a clue as to my longtime issue with
> ModelloCli. The plexus situation is a mess!
>
> Beyond the Sonatype repos that were forked into codehause-plexus. I
> discovered that Maven itself wants eclipse sisu.plexus[3] NOT
> plexus-container-default[4]. Which are basically the same package.
> Though the sisu.plexus one is a bit different, and is the one Maven
> itself uses. I need to swap some stuff out for Modello and see if that
> fixes my issue with ModelloCli, so I can generate java from .mdo files.
>
> There is a similar situation with eclipse-aether[5] and
> maven-resolver[6]. But that is more Maven specific, as Modello only
> uses Plexus not Aether.
>
> Funny enough I started out packaging Maven for Gradle. I am making
> more progress with Maven cli mvn [1] than I am with Gradle's cli :)
>
> Maven from source on Gentoo has been voodoo for years till 2018!!!
>
> 1. https://github.com/Obsidian-StudiosInc/os-xtoo/issues/54
> 2. https://github.com/Obsidian-StudiosInc/os-xtoo/issues/56
> 3.
> https://github.com/eclipse/sisu.plexus/tree/master/org.eclipse.sisu.plexus
> 4.
> https://github.com/codehaus-plexus/plexus-containers/tree/master/plexus-con
> tainer-default 5. https://github.com/eclipse/aether-core
> 6. https://github.com/apache/maven-resolver



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Process maven mdo files via ModelloCLI

William L. Thomson Jr.
On Sun, 26 Aug 2018 13:54:13 -0400
"William L. Thomson Jr." <[hidden email]> wrote:

> Not sure if using plexus-containers rather than sisu-plexus, is the
> cause for ModelloCli to not be able to load/find the Java plugin. Just
> one thing I have not tried with Modello.

After trying this out, that does seem to be the problem. I need to
replace all instances of plexus-container-default with sisu-plexus.
See the output in this comment, its very different than anything I have
seen. This is very encouraging!

[main] WARN Sisu - Error injecting:
org.codehaus.modello.plugin.java.JavaModelloGenerator

https://github.com/Obsidian-StudiosInc/os-xtoo/issues/48#issuecomment-416063706

--
William L. Thomson Jr.

attachment0 (201 bytes) Download Attachment