Re: Heads up, Plexus IO/Archiver is going Java 7

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: Heads up, Plexus IO/Archiver is going Java 7

Anders Hammar
How would we handle this wrt versions of our plugins when the requirements
for those are bumped from Java 6 to Java 7?

For example, maven-jar-plugin has plexus-archiver as a dependency. m-jar-p
v3.0.2 requires Java 6. Is a bump to v3.1.0 enough for going to Java 7?

/Anders

On Thu, May 4, 2017 at 10:39 PM, Michael Osipov <[hidden email]> wrote:

> Hi folks,
>
> five months ago I asked about Java 7 upgrade of Plexus Archiver [1] and
> received no reaction. I will move to a new major and integrate Plamen's
> changes.
>
> Additionally, he was so kind to work on Plexus IO too and remove all pre
> Java 7 code [2]. I will raise major too and merge his changes.
>
> This will effectively will change a lot of our codebase to Java 7.
>
> If I won't receive any profound objection, the PRs will be merged.
>
> Michael
>
> [1] https://github.com/codehaus-plexus/plexus-archiver/pull/55
> [2] https://github.com/codehaus-plexus/plexus-io/pull/5
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Re: Heads up, Plexus IO/Archiver is going Java 7

Michael Osipov-3
That's the big question I'd like clarify first.
Commons Compress has gone Java 7 in a minor release and people are requesting
it for Plexus Archiver...

> How would we handle this wrt versions of our plugins when the requirements
> for those are bumped from Java 6 to Java 7?
>
> For example, maven-jar-plugin has plexus-archiver as a dependency. m-jar-p
> v3.0.2 requires Java 6. Is a bump to v3.1.0 enough for going to Java 7?
>
> /Anders
>
> On Thu, May 4, 2017 at 10:39 PM, Michael Osipov <[hidden email]> wrote:
>
> > Hi folks,
> >
> > five months ago I asked about Java 7 upgrade of Plexus Archiver [1] and
> > received no reaction. I will move to a new major and integrate Plamen's
> > changes.
> >
> > Additionally, he was so kind to work on Plexus IO too and remove all pre
> > Java 7 code [2]. I will raise major too and merge his changes.
> >
> > This will effectively will change a lot of our codebase to Java 7.
> >
> > If I won't receive any profound objection, the PRs will be merged.
> >
> > Michael
> >
> > [1] https://github.com/codehaus-plexus/plexus-archiver/pull/55
> > [2] https://github.com/codehaus-plexus/plexus-io/pull/5
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Re: Re: Heads up, Plexus IO/Archiver is going Java 7

Michael Osipov-3
This will also ultimately mean that these plugins will run with Maven 3.3 only
if someone still uses an older version and Java 6 to build their projects.

> That's the big question I'd like clarify first.
> Commons Compress has gone Java 7 in a minor release and people are requesting
> it for Plexus Archiver...
>
> > How would we handle this wrt versions of our plugins when the requirements
> > for those are bumped from Java 6 to Java 7?
> >
> > For example, maven-jar-plugin has plexus-archiver as a dependency. m-jar-p
> > v3.0.2 requires Java 6. Is a bump to v3.1.0 enough for going to Java 7?
> >
> > /Anders
> >
> > On Thu, May 4, 2017 at 10:39 PM, Michael Osipov <[hidden email]> wrote:
> >
> > > Hi folks,
> > >
> > > five months ago I asked about Java 7 upgrade of Plexus Archiver [1] and
> > > received no reaction. I will move to a new major and integrate Plamen's
> > > changes.
> > >
> > > Additionally, he was so kind to work on Plexus IO too and remove all pre
> > > Java 7 code [2]. I will raise major too and merge his changes.
> > >
> > > This will effectively will change a lot of our codebase to Java 7.
> > >
> > > If I won't receive any profound objection, the PRs will be merged.
> > >
> > > Michael
> > >
> > > [1] https://github.com/codehaus-plexus/plexus-archiver/pull/55
> > > [2] https://github.com/codehaus-plexus/plexus-io/pull/5
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Re: Re: Heads up, Plexus IO/Archiver is going Java 7

Anders Hammar
On Fri, May 5, 2017 at 10:22 AM, Michael Osipov <[hidden email]> wrote:

> This will also ultimately mean that these plugins will run with Maven 3.3
> only
> if someone still uses an older version and Java 6 to build their projects.
>

I don't follow.
Not to confuse anyone we should separate the Java requirement and the Maven
requirement (which we already do). The plugins will require Java 7 for the
build after this change, but could still work with Maven 3.0 (depending on
what we specify for the plugin).

If someone still uses Java 6, they have to stay with Maven <3.3 as v3.3+
requires Java 7. For plugins that now bump to Java 7 requirement they have
to stay with current plugin versions. So if we currently have a sever issue
in a plugin we should probably release a bug fix for thay before going Java
7. Just to be kind to our users.

/Anders



>
> > That's the big question I'd like clarify first.
> > Commons Compress has gone Java 7 in a minor release and people are
> requesting
> > it for Plexus Archiver...
> >
> > > How would we handle this wrt versions of our plugins when the
> requirements
> > > for those are bumped from Java 6 to Java 7?
> > >
> > > For example, maven-jar-plugin has plexus-archiver as a dependency.
> m-jar-p
> > > v3.0.2 requires Java 6. Is a bump to v3.1.0 enough for going to Java 7?
> > >
> > > /Anders
> > >
> > > On Thu, May 4, 2017 at 10:39 PM, Michael Osipov <[hidden email]>
> wrote:
> > >
> > > > Hi folks,
> > > >
> > > > five months ago I asked about Java 7 upgrade of Plexus Archiver [1]
> and
> > > > received no reaction. I will move to a new major and integrate
> Plamen's
> > > > changes.
> > > >
> > > > Additionally, he was so kind to work on Plexus IO too and remove all
> pre
> > > > Java 7 code [2]. I will raise major too and merge his changes.
> > > >
> > > > This will effectively will change a lot of our codebase to Java 7.
> > > >
> > > > If I won't receive any profound objection, the PRs will be merged.
> > > >
> > > > Michael
> > > >
> > > > [1] https://github.com/codehaus-plexus/plexus-archiver/pull/55
> > > > [2] https://github.com/codehaus-plexus/plexus-io/pull/5
> > > >
> > > > ------------------------------------------------------------
> ---------
> > > > To unsubscribe, e-mail: [hidden email]
> > > > For additional commands, e-mail: [hidden email]
> > > >
> > > >
> > >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>