Re: Cutting Checkstyle 3.1.1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Cutting Checkstyle 3.1.1

Elliotte Rusty Harold
On Thu, Feb 6, 2020 at 9:33 AM Enrico Olivelli <[hidden email]> wrote:

>
> Hi folks,
> We should release checkstyle plugin in order to have a version of the
> plugin compatible to the latest version of checkstyle (8.29).
>
> There are security issues that are flagging old Checkstyle versions,
> and I have noticed the github bot started to flag our plugin and
> suggest an upgrade of checkstyle dependency but actually
> maven-checkstyle-plugin 3.1.0 is not compatible with 8.29.
>

No objection to a release, but I'm surprised they're not compatible. I
updated one of my projects yesterday to 3.1.0/8.29 and didn't notice
any issues:

https://github.com/GoogleCloudPlatform/appengine-plugins-core/pull/830/files


--
Elliotte Rusty Harold
[hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]