Re: Continued problems releasing components

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Continued problems releasing components

dennisl
Okay, answering myself here.

Had a look in JIRA and found 2 issues that are related to my problems:
https://issues.apache.org/jira/browse/MRELEASE-1038
https://issues.apache.org/jira/browse/MRELEASE-1042

I believe that 1038 is what bit me, because now remember seeing a strange
warning in the log:
[WARNING] The requested profile "pom.xml" could not be activated because it
does not exist.

I'm on Windows and the actual Maven execution, does not show up in the log,
like it does for Arnaud on OSX(?) in 1042.

Would the correct work around be to remove all active profiles in
settings.xml?

--
Dennis Lundberg


Den ons 5 aug. 2020 kl 18:42 skrev Dennis Lundberg <[hidden email]>:

> Hi,
>
> As I mentioned on my release of maven-shared-utils, I had problems with
> the release process.
>
> I have just started the release for Maven Resources Plugin and Maven
> Filtering and have had continued problems. This time I went in and deleted
> the failed release attempt tags from git and started over.
>
> I still haven't figured out where the problem lies, but here's the short
> version of what happened.
>
> This time I used Maven 3.3.9 and OpenJDK 8 from the start to avoid using
> toolchains. Everything went fine up to and including
> maven release:prepare
>
> But when I ran
> mvn release:perform
> things fell apart, again.
>
> Having learned from the previous release failure I had a decent idea about
> what went wrong. The profile activation for Maven Release Plugin does not
> kick in, so no sources jar, no javadoc jar, no source distribution and no
> signatures.
>
> Either there is something with my environment that messes things up, or
> else there are problems in the parent POM chain. Having had a quick look at
> the POMs, I noticed some contradicting configuration for
> maven-release-plugin between Maven parent and Apache parent. I tried the
> same release commands again using Maven 3.6.3, in case there were some POM
> inheritance issues that have been fixed, but the results were the same.
>
> Finally I had to resort to manually trigger the releaseProfiles parameter
> for the plugin and also the Maven profile, so the command that worked for
> me looked like this:
> mvn release:perform -DreleaseProfiles=apache-release -Papache-release
>
> Earlier I tried with only -D, but that didn't work. I haven't tried using
> only -P.
>
> Has anybody else had similar problems?
> Do you have any clue as to what might be wrong?
>
> --
> Dennis Lundberg
>