[RESULT] [VOTE] Release Apache Maven Enforcer version 1.4.2

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[RESULT] [VOTE] Release Apache Maven Enforcer version 1.4.2

stephenconnolly
Ok, I'm dropping this and respinning as 3.0.0

On 20 June 2017 at 10:02, Stephen Connolly <[hidden email]>
wrote:

> Hi,
>
> We solved 14 issues:
> https://issues.apache.org/jira/secure/ReleaseNote.jspa?
> projectId=12317520&version=12333353&styleName=Text
>
> There are still a couple of issues left in JIRA:
> <a href="https://issues.apache.org/jira/issues/?jql=project%20%">https://issues.apache.org/jira/issues/?jql=project%20%
> 3D%2012317520%20AND%20status%20%3D%20Open%20ORDER%20BY%
> 20key%20DESC%2C%20priority%20DESC
>
> Staging repo:
> https://repository.apache.org/content/repositories/maven-1342/
> https://repository.apache.org/content/repositories/maven-
> 1342/org/apache/maven/enforcer/enforcer/1.4.2/
> enforcer-1.4.2-source-release.zip
>
> Source release checksum(s):
> enforcer-1.4.2-source-release.zip-source-release.zip sha1:
> 213f832f38529f02b38de6b7b2cc5804964e244f
>
> Staging site:
> https://maven.apache.org/components/enforcer-archives/enforcer-LATEST/
>
> Guide to testing staged releases:
> https://maven.apache.org/guides/development/guide-testing-releases.html
>
> Vote open for at least 72 hours.
>
> [ ] +1
> [ ] +0
> [ ] -1
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [RESULT] [VOTE] Release Apache Maven Enforcer version 1.4.2

gboue
Yes, it should work with Java 9, I ran all the integration tests of the
plugin with 9ea175 without any issues. This error is already solved for
3.0.0 by upgrading to commons-lang3.

Guillaume


Le 26/06/2017 à 13:53, Mark Derricutt a écrit :

>
> On 23 Jun 2017, at 7:48, Stephen Connolly wrote:
>
>     Ok, I'm dropping this and respinning as 3.0.0
>
> Does 1.4.2/3.0.0 work with Java 9?
>
> I was just testing a build and hit:
>
> Caused by: org.apache.maven.plugin.PluginExecutionException: Execution
> com.smxemail.tiles:com.smxemail.tiles.enforcements:3.0.64::enforce-versions
> of goal org.apache.maven.plugins:maven-enforcer-plugin:1.4.1:enforce
> failed: An API incompatibility was encountered while executing
> org.apache.maven.plugins:maven-enforcer-plugin:1.4.1:enforce:
> java.lang.ExceptionInInitializerError: null
>
> ....
>
> |at
> org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:181)
> ... 21 more |
>
> Caused by: java.lang.ExceptionInInitializerError
> at
> org.apache.maven.plugins.enforcer.RequireJavaVersion.execute(RequireJavaVersion.java:52)
> at
> org.apache.maven.plugins.enforcer.EnforceMojo.execute(EnforceMojo.java:193)
> at
> org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
> ... 21 more
> Caused by: java.lang.StringIndexOutOfBoundsException: begin 0, end 3,
> length 1
> at java.base/java.lang.String.checkBoundsBeginEnd(String.java:3116)
> at java.base/java.lang.String.substring(String.java:1885)
> at
> org.apache.commons.lang.SystemUtils.getJavaVersionAsFloat(SystemUtils.java:1122)
> at org.apache.commons.lang.SystemUtils.<clinit>(SystemUtils.java:818)
> ... 24 more
>
> I guess the version of commons-lang used doesn't like the new Java 9
> version string.
>
> ------------------------------------------------------------------------
>
> "The ease with which a change can be implemented has no relevance at
> all to whether it is the right change for the (Java) Platform for all
> time." — Mark Reinhold.
>
> Mark Derricutt
> http://www.theoryinpractice.net
> http://www.chaliceofblood.net
> http://plus.google.com/+MarkDerricutt
> http://twitter.com/talios
> http://facebook.com/mderricutt
>



---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus
Loading...