Problems with dependency-plugin + Mockito + Java 11

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems with dependency-plugin + Mockito + Java 11

Andrew Todd-2
Hi,

I'm wondering if anyone else has found a solution to this problem. I use
the maven-dependency-plugin's analyze-only goal to look issues in my
dependency tree.

https://maven.apache.org/plugins/maven-dependency-plugin/analyze-only-mojo.html

When I started using Java 11, I had to override the plugin's ASM dependency
so that it would continue to work:

            <dependency>
              <groupId>org.ow2.asm</groupId>
              <artifactId>asm</artifactId>
              <version>7.0</version>
            </dependency>

And everything did work, until I started using Mockito in my unit tests. As
soon as I add calls to Mockito, I get the following error message:

Execution dependency-plugin of goal
org.apache.maven.plugins:maven-dependency-plugin:3.1.1:analyze-only failed:
This feature requires ASM7

Of course, I'm already using ASM7.

I've tried setting <ignoreNonCompile>true</ignoreNonCompile> to see if I
can skip analysis of the test classes, but this doesn't seem to work.


Thanks,
Andrew Todd