Problem to download dependency on Ubuntu

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem to download dependency on Ubuntu

Tibor Digana
My command *mvn clean* is not able to download a new artifact
*org.arquillian.universe:arquillian-junit:pom*
however it exists on Maven Central.

I run the command on Ubuntu Konsole, and nothing is downloaded.
When I run wget [1] from the same Konsole, the POM is downloaded.

The settings.xml is not a problem, I checked. There is a mirror of central
and URL of Nexus in company.

Is there any native difference between wget and mvn/Java on Ubuntu so that
the remote mavenrepo may not be reached?
I did setup of /etc/environment, /etc/network/interface, ~/.profile due to
proxy, DNS, http_no_proxy, etc. but nothing helps.

Any hint would be helpful here.
MAVEN and JAVA_OPTS is not set.

[1]: wget
http://mavenrepo.ads.local/nexus/content/groups/public/org/arquillian/arquillian-universe/1.1.13.7/arquillian-universe-1.1.13.7.pom

Thx
Tibor
Reply | Threaded
Open this post in threaded view
|

Re: Problem to download dependency on Ubuntu

Tibor Digana-2
These are my logs from mvn -X clean

[DEBUG] Using mirror nexus (
http://mavenrepo.ads.local/nexus/content/groups/public) for central (
https://repo.maven.apache.org/maven2).
...
[DEBUG] Using transporter WagonTransporter with priority -1.0 for
http://mavenrepo.ads.local/nexus/content/groups/public
[DEBUG] Using connector BasicRepositoryConnector with priority 0.0 for
http://mavenrepo.ads.local/nexus/content/groups/public with
username=deployment, password=***
Downloading:
http://mavenrepo.ads.local/nexus/content/groups/public/org/arquillian/arquillian-universe/1.1.13.7/arquillian-universe-1.1.13.7.pom
[WARNING] Failed to create parent directories for tracking file
/home/xms40/.m2/repository/org/arquillian/arquillian-universe/
1.1.13.7/arquillian-universe-1.1.13.7.pom.lastUpdated
...
[ERROR] Non-resolvable import POM: Could not transfer artifact
org.arquillian:arquillian-universe:pom:1.1.13.7 from/to nexus (
http://mavenrepo.ads.local/nexus/content/groups/public):
/home/xms40/.m2/repository/org/arquillian/arquillian-universe/
1.1.13.7/arquillian-universe-1.1.13.7.pom.part.lock (No such file or
directory)


On Mon, Nov 27, 2017 at 10:46 PM, Nick Stolwijk <[hidden email]>
wrote:

> Did you also configure your proxy in the settings.xml? [1]
>
> Hth,
>
> Nick
>
> [1] https://maven.apache.org/guides/mini/guide-proxies.html
>
> Nick Stolwijk
>
> ~~~ Try to leave this world a little better than you found it and, when
> your turn comes to die, you can die happy in feeling that at any rate you
> have not wasted your time but have done your best ~~~
>
> Lord Baden-Powell
>
> On Mon, Nov 27, 2017 at 10:22 PM, Tibor Digana <[hidden email]>
> wrote:
>
> > My command *mvn clean* is not able to download a new artifact
> > *org.arquillian.universe:arquillian-junit:pom*
> > however it exists on Maven Central.
> >
> > I run the command on Ubuntu Konsole, and nothing is downloaded.
> > When I run wget [1] from the same Konsole, the POM is downloaded.
> >
> > The settings.xml is not a problem, I checked. There is a mirror of
> central
> > and URL of Nexus in company.
> >
> > Is there any native difference between wget and mvn/Java on Ubuntu so
> that
> > the remote mavenrepo may not be reached?
> > I did setup of /etc/environment, /etc/network/interface, ~/.profile due
> to
> > proxy, DNS, http_no_proxy, etc. but nothing helps.
> >
> > Any hint would be helpful here.
> > MAVEN and JAVA_OPTS is not set.
> >
> > [1]: wget
> > http://mavenrepo.ads.local/nexus/content/groups/public/
> > org/arquillian/arquillian-universe/1.1.13.7/arquillian-
> > universe-1.1.13.7.pom
> >
> > Thx
> > Tibor
> >
>



--
Cheers
Tibor