Problem setting up Eclipse to use Atlassian SDK

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problem setting up Eclipse to use Atlassian SDK

wbastow
I have followed the instructions in the How to Build an Atlassian Plugin at http://confluence.atlassian.com/display/DEVNET/How+to+Build+an+Atlassian+Plugin.  

In these instructions, it tells me how to add m2eclipse to my Eclipse installation.  
First it sends me to http://m2eclipse.sonatype.org/ for installation instructions for m2eclipse.
I followed the instructions on http://m2eclipse.sonatype.org/installing-m2eclipse.html.
However, i do not see Maven in the Eclipse --> Windows --> Preferences list as it says I should.
Therefore, I cannot configure m2eclipse inside of Eclipse.

I tried to re-install m2eclipse, but it tells me that the install failed because m2eclipse is already installed.
I went so far as to un-install Eclipse and start over from scratch, but with the same results.

In the Atlassian SDK instructions, it says that if you have Eclipse without the m2eclipse plugin, then:

If you are using Eclipse without the M2Eclipse plugin:

    * Run the following command: atlas-mvn eclipse:eclipse
    * Then configure your workspace with the Maven repository location:

      atlas-mvn -Declipse.workspace=<path-to-eclipse-workspace> eclipse:add-maven-repo

      Note: You can accomplish the same thing by adding the M2_REPO classpath variable, pointing to your $HOME/.m2/repository directory, in your Eclipse preferences

After running this, I see M2_REPO classpath variable in Eclipse, but still no Maven in the Windows --> Preferences list.
Also, I do not see my project in the Package Explorer inside of Eclipse.

Can someone tell me what is going wrong?

I am running on ubuntu linux in a VM on a Windows XP machine.  
Walt B