Quantcast

Override plugin dependency version

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Override plugin dependency version

jan_bar
Hi,

I use a plugin (xmlbeans-maven-plugin). It depends on some jar
(xmlbeans/xbean-2.0.0.jar) but I want to use new version of that jar
(xbean-2.2.0.jar). How can I do that? If I specify new version in my POM
dependencies, the plugin still downloads (and apprently uses) old version.

Thank you, Jan




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Override plugin dependency version

Yann Albou
Hi Jan,

What I tried to do to resolve this problem is to define a propeties
xmlbeans.version in the plugin:

  <dependencies>
     <dependency>
       <groupId>org.apache.</groupId>
       <artifactId>xmlbean</artifactId>
       <version>${xmlbean.version}</version>
     </dependency>
   </dependencies>
   <properties>
        <xmlbean.version>2.0.0</xmlbean.version>
   </properties>


And then when you run maven in your project use:
mvn -Dxmlbean.version=2.2.0 install

unfortunalty if you define xmlbean.version in your project pom, then the
  plugin will ignore this value! I don't know if it is an expected
behavior...
Do someone know about it?

Yann.

jan_bar wrote:
> Hi,
>
> I use a plugin (xmlbeans-maven-plugin). It depends on some jar
> (xmlbeans/xbean-2.0.0.jar) but I want to use new version of that jar
> (xbean-2.2.0.jar). How can I do that? If I specify new version in my POM
> dependencies, the plugin still downloads (and apprently uses) old version.
>
> Thank you, Jan


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...