Not a chance to show conflicts in dependency tree?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Not a chance to show conflicts in dependency tree?

Nicolas Peifer
Hi,

I'm trying to show dependency conflicts using "mvn dependency:tree
-Dverbose -Dincludes=commons-collections" as described in the
documentation[1]. Unfortunately, this gives the following error:

"Verbose not supported since maven-dependency-plugin 3.0"

I tested it with Maven 3.3.9 and 3.5.4. Does anyone know a solution
(apart from downgrading the plugin)?

Kind regards,

Nicolas Peifer

[1]
https://maven.apache.org/plugins/maven-dependency-plugin/examples/resolving-conflicts-using-the-dependency-tree.html


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Not a chance to show conflicts in dependency tree?

Mark Prins
On 11-09-18 10:56, Nicolas Peifer wrote:

> Hi,
>
> I'm trying to show dependency conflicts using "mvn dependency:tree
> -Dverbose -Dincludes=commons-collections" as described in the
> documentation[1]. Unfortunately, this gives the following error:
>
> "Verbose not supported since maven-dependency-plugin 3.0"
>
> I tested it with Maven 3.3.9 and 3.5.4. Does anyone know a solution
> (apart from downgrading the plugin)?

verbose probably needs a value, also see the note:
https://maven.apache.org/plugins/maven-dependency-plugin/tree-mojo.html#verbose

Using a different or specific version is as easy as specifying that (eg.
2.10):
"mvn org.apache.maven.plugins:maven-dependency-plugin:2.10:tree"

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Not a chance to show conflicts in dependency tree?

Nicolas Peifer
On 11.09.2018 12:36, Mark Prins wrote:

> On 11-09-18 10:56, Nicolas Peifer wrote:
>> I'm trying to show dependency conflicts using "mvn dependency:tree
>> -Dverbose -Dincludes=commons-collections" as described in the
>> documentation[1]. Unfortunately, this gives the following error:
>>
>> "Verbose not supported since maven-dependency-plugin 3.0"
>>
>> I tested it with Maven 3.3.9 and 3.5.4. Does anyone know a solution
>> (apart from downgrading the plugin)?
>
> verbose probably needs a value, also see the note:
> https://maven.apache.org/plugins/maven-dependency-plugin/tree-mojo.html#verbose
>
> Using a different or specific version is as easy as specifying that
> (eg. 2.10):
> "mvn org.apache.maven.plugins:maven-dependency-plugin:2.10:tree"
Thanks for your reply =)

-Dverbose is sufficient (equivalent to -Dverbose=true).

Thanks for the command example, it works. However, my local maven
repository is broken after executing the command with the fixed
dependency-plugin version and I cannot execute a simple "mvn clean
install" on my project:
"Failed to execute goal
org.apache.maven.plugins:maven-install-plugin:2.5.2:install
(default-install) on project *****: Execution default-install of goal
org.apache.maven.plugins:maven-install-plugin:2.5.2:install failed:
Unable to load the mojo 'install' (or one of its required components)
from the plugin 'org.apache.maven.plugins:maven-install-plugin:2.5.2':
com.google.inject.ProvisionException: Unable to provision, see the
following errors:
[ERROR]
[ERROR] 1) Error injecting: private org.eclipse.aether.spi.log.Logger
org.apache.maven.repository.internal.DefaultVersionRangeResolver.logger...."

I solved it by deleting my local maven repository.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]