No transfer protocol found

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

No transfer protocol found

Raivo Rebane
Hello

I have trouble

I tried mvn deploy:deploy-file in different ways:

as example mvn deploy:deploy-file -Durl=repo
-Dfile=/opt/tomcat/latest/lib/or.jar -DgroupId=com.appserv
-DartifactId=devlib -Dpackaging=jar -Dversion=0.1
-Dmaven.wagon.provider.http=wagon-file

But in any cases I got error:

Failed to execute goal
org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy-file
(default-cli) on project AppServ: No transfer protocol found.

What is wrong ?

Regards

Raivo



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: No transfer protocol found

Bernd Eckenfels
Did you specify „repo“ as the url? I think it needs a valid URL here.


--
http://bernd.eckenfels.net
________________________________
Von: Raivo Rebane <[hidden email]>
Gesendet: Friday, October 30, 2020 2:27:05 PM
An: [hidden email] <[hidden email]>
Betreff: No transfer protocol found

Hello

I have trouble

I tried mvn deploy:deploy-file in different ways:

as example mvn deploy:deploy-file -Durl=repo
-Dfile=/opt/tomcat/latest/lib/or.jar -DgroupId=com.appserv
-DartifactId=devlib -Dpackaging=jar -Dversion=0.1
-Dmaven.wagon.provider.http=wagon-file

But in any cases I got error:

Failed to execute goal
org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy-file
(default-cli) on project AppServ: No transfer protocol found.

What is wrong ?

Regards

Raivo



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]